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ART AND IMAGE EDITING

n unmarked surface of metal skin wrapped around an alien

ship adds little to the story behind the ship or its

occupants. But add some patches of rust, a few scorch

marks and impact creases in the metal and you find

yourself face-to-face with battle-scarred travellers recently escaped

from a nightmare on a watery planet.

Textures are one of the basic building blocks for both 2D

illustration and 3D animation. The skin of a human, the liquid feel

of text, and the surface of metal are all common forms for

computer generated textures. Creating realistic textures in the GIMP

is less complex than it might seem. And the key lies where you

might never have guessed: the generation of noise-filled clouds.

GIMP provides two plug-ins for generating clouds, both of which

are called “Plasma”. The first comes with the stock GIMP

distribution while the other can be downloaded as source code

from the GIMP Registry or retrieved from various online resources

in ready-to-use form.  Both will load themselves into the Filters-

>Render>Clouds submenu found in the Canvas menu (click and

hold the right mouse button in a Canvas window to get the Canvas

menu). The version from the GIMP Registry should show in the

menu as “Plasma2”.  A “plasma” is just a type of gas, and clouds

are roughly a gaseous form of water, thus the name of the filters.

In all our examples we’ll be starting by rendering a desaturated

cloud. A desaturated cloud is like a grayscale cloud except that a

desaturated cloud is really a colour cloud with all the colours

washed out. You can add colour back into a desaturated cloud. A

true grayscale cloud cannot be coloured. After we create the

desaturated cloud, we’ll be adding different amount of desaturated

noise. By “noise” we mean random dots distributed about the

current layer. The noise will then be used as a bump map to

generate height within the cloud, or blurred to provide streaks.

PART 2 Realistic surfaces make all the difference between
your images looking merely good or being really great.
Michael J Hammel takes us through every Noisifying detail.

GIMP texture magic

www.cups.org/
CUPS provides networked printing support and
a spooling interface.  
http://gimp-print.sourceforge.net/
GIMP-Print goes way beyond just a GIMP print
plug-in. It’s a full-featured set of drivers for
many printers.  Its drivers are so well done they
are considered better than some of the original

manufacturers drivers and are being used by
many MacOS X users now as well. 
www.linuxprinting.org/foomatic2.9/
Foomatic is the glue between print spoolers 
and printer drivers.
www.linuxprinting.org
This is the place to start to find out if a driver 
is available for your particular printer.

Printer resources
For your GIMP masterpieces
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3  Merge the two layers. The result is good, but
for a little variation in these too-perfect waves,
we’ll apply a ripple (Filters>Distorts> Ripple).
Set the period to 128 and amplitude to 6. Make it
a sine wave with wrapped edges. Finally, colorize
the layers using the Color Mode of the Bucket
Tool. A good color for an aqua appearance would
be a hex triplet value of #009199.

2  Next, add some Waves (Filters>Distorts
>Waves). Make the amplitude 47, the phase 210,
and the wavelength 43. Duplicate this layer. Flip
the duplicate both horizontally and vertically
using the Flip Tool in the Toolbox. Then set the
layer Mode to Difference on the duplicate layer. 

1  As usual, start with a cloud layer. Plasma2 is
best for this. The usual Plasma will work, but
generates a cloud that fills the layer more
uniformly than we want. Apply a radial motion
blur (Filters>Blur>Motion Blur) with a length of
3. After this completes, apply a Gaussian IIR
(Filters>Blur>Gaussin Blur IIR) blur using a
radius of 35. We want this to be heavily blurred.

3  Variations on this technique will produce
many different textures. There are two plasma
filters: Plasma and Plasma2 (the latter is
available from the GIMP Registry but is not
included in the stock GIMP distribution). Using
the Plasma (Filters>Render>Clouds>Plasma)
filter instead of Plasma2 will generate a more
evenly distributed pattern of concrete. This
example used the same settings for Noisify and
Bump Map as the other example, but started
with a desaturated (Image>Colors>Desaturate)
cloud pattern generated with the Plasma filter
instead. While it looks like concrete,
adjustments to the Contrast and Brightness can
soften the appearance and provide you the
initial pattern for more complex textures like
skin or cloth!

1 Start with white background in a new Canvas
window. Add a new layer and fill it with
grayscale clouds using the Plasma2 filter
(Filters>Render>Clouds>Plasma2). Set the
Noise distribution to Exponential and the Noise
Amplitude to 0. Then set the Scaling function to
Norris-like and the Scaling parameter to about
1.7. This should produce a slightly spotty cloud
shape as opposed to soft wispy clouds. The
amount of detail you’ll get will depend on the
Random Seed. You can either try clicking the
Time button several times to find a reasonable
preview or try using the value 1044227968
(which was used in this example) as the
Random Seed.

2  Now apply some noise to this image using
the Noisify filter (Filters>Noise>Noisify). Set the
color channels to be uniform by deselecting the
Independent button. Then move one of the
channel (Red, Green, or Blue) sliders to about
0.30. Apply the plasma layer as a Bump Map
(Filters>Distorts>Bump Map) to the white layer.
The settings of the Bump Map filter depend on
your cloud layer. Play with the Azimuth,
Elevation and Depth and scan around the
Preview a little to see what you will get from
those settings. The Map Type options will
change the image a bit, but are less important
than these other three settings. Be sure to turn
off the visibility of the cloud layer. After you
have applied the Bump Map the white layer will
hold your concrete texture.

CONCRETE

WATER

One of the easiest textures to create is a simple concrete or plaster background. Such textures can be used

to turn a basic 3D box into a cement block or any flat surface into a pavement (US: sidewalk!) or road.

This next texture is again one of the more simple ones, due largely to the availability of two plug-ins in the

stock GIMP distribution: Ripple and Waves. Another plug-in, Water Surface, is available from the GIMP

Registry or its own Web site, but we’ll look at making this texture from scratch, as it is a useful skill.
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3 Colorize the cloud layer using the same
reddish-brown color you used on the original
white background layer. To do this, make sure
the cloud layer is active and type Ctrl-A to
select the entire layer. Then double click on the
paint bucket in the Toolbox – this is the Bucket
Fill tool. In the Tool Options window that opens,
change the Mode to Color. Then click in the
Canvas window. The image should take on a
reddish brown tint. Now set the layer Mode for
the Cloud layer to Multiply. You’ll see some of
the texture show through the white parts of the
cloud layer now.

1 Once again we start with a single white layer.
Fill this layer with a dark, reddish-brown color.
Try a hex triplet value of #a46711 in the Color
Selection window. Your tastes will vary here.
Next, add noise using the Noisify filter
(Filters>Noise>Noisify). Set the color channels to
be uniform (not independent, just as in the
concrete examples) and the channel settings
between 30 and 45. Then duplicate this layer. 

2 Make sure the duplicate layer is the active
layer. Distort the layer with some wind (Filters>
Distorts>Wind). Set the Threshold between 7 and
20 and the Strength between 2 and 5. Make the
wind blow from the left across both edges using a
blast-style effect. Add a transparent layer above
the duplicate layer. This will make the transparent
layer the top layer. Render some grayscale clouds
into this layer. Like the earlier concrete example,
the clouds here should be splotchy. If you have
the Plasma2 filter, use it with a Uniform noise
distribution set to an amplitude of about 1.08 or a
Cauchy distribution with an amplitude of about -
1.12. Norris scaling for both should be between
1.15 to 1.25. Use Brightness/Contrast to reduce
the amount of white so that there is about a
50/50 ratio, and preferably a little more black in
the clouds layer than white.

6  Select by color the black regions in the top
layer (the cloud layer). Increase the Fuzziness
threshold to grab more of the black area.  Add a
transparent layer to the top of the layer stack
and fill it with the original rust color (you should
still have this set as your Foreground color). You
can use the Bucket Tool to fill the selection in
this transparent layer but be sure you reset the
Mode in the Bucket Tool Options window to
Normal. Finally, change the Layer mode to
Addition for the transparent layer. Turn off the
Selection by typing Ctrl-Shift-A in the Canvas
window. Viola! Rust.

5  Turn off the visibility of the Cloud and
duplicate layers for a moment. Click on the
Background layer to make it active. Now apply
some more wind to this layer using the same
settings as you used on the duplicate layer. At
this point you can add some waves to the layer,
although it may or may not add any real
distortion to the overall effect, depending on
the amount of white in the cloud layers. Set the
Waves (Filters>Distorts>Waves) Mode to Smear,
disable Reflective, and set the Amplitude to
about 7, the Phase to about 100 and the
Wavelength to about 16.

4  Add a layer mask to the duplicate layer
(right click on the layer name, then select Add
Layer Mask). Select the cloud layer by clicking
on its layer to make it active and typing Ctrl-A
to select the entire layer. Copy this selection into
the layer mask. Use Ctrl-C to copy the selection.
Then click on the duplicate layer’s mask in the
Layers, Channels, and Paths window and type
Ctrl-V in the Canvas window. With the layer
mask still selected, double click on the Flip tool
(the left/right arrow in the Toolbox). With the
Tool Options window open, click once on the
Canvas window, then switch directions in the
Tool Options window and click again in the
Canvas window. This has the effect of flipping
the layer mask both horizontally and vertically.
Change the layer mode for the duplicate layer
to Divide (aka Dodge).

RUST
A more complex pattern to produce is that of metallic rust. The key ingredients for rust are both color and

pattern. Be sure to experiment with your color choices to find one that meets your minimum standard. 
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7 A selection of grunge end results – it all
depends on what values that you choose.

6 Variations of blend modes and possibly the
order of layers may help produce the effect you
want. Also, flipping the direction of the original
or duplicate layer may help. Color can be added
to any layer or a top layer of colour can be
added with the layer Mode set to Color or
perhaps some other blend mode.

5  Use Select by Color on the GIMPressionist
layer. Again, create a transparent layer above
this and fill the selection with black in this new
layer. Be sure the new transparent layer is
moved to the top of the layer stack. The order
of layers and blend modes should be:

1 Black filled selection from GIMPressionist layer
with layer Mode set to  Divide.

2 Black filled selection from Bump Map layer
with layer Mode set to Multiply.

3 GIMPressionist layer with layer Mode set to
Screen.

4 Bump Map layer with layer Mode set to
Normal.

4  Use Color Select (Select>Select by Color) to
select a region of the Bump Map layer. Create a
transparent layer above this layer and fill the
selection with black. Move the transparent
layer to the top of the layer stack. Apply the
Twist filter (Filters>Distorts>Twist) to the
GIMPressionist layer. In the Twist filter window,
select the Cosines function and Effect 4 in this
filter. You shouldn’t need to change any of the
other parameters.

3  Now comes the trick. We need to set up the
GIMPressionist plug-in (Filters>Artistic>
GIMPressionist) – it’s complex but can produce
fantastic textures. We’re going to apply this to
the duplicate layer. Select the Cubism preset and
apply it. This sets the initial parameters to
something useful, but we’re going to modify
them a bit. First, change the Paper to
canvas2.pgm. Change the brush to
sponge02.pgm, you can scale it up using the
Aspect Ratio if you like. Next change Orientation
span angle to 360 with a start angle > 20 and
using Random orientation. In the Size tab, leave
the Sizes value at 1, with a minimum of 4 and a
maximum of 13 using the Value size setting.
Finally, set the Placement Stroke density to 15
and make them Evenly distributed. This might be
a little slow to calculate. Give it time. When you
click on OK the filter will begin processing. Don’t
be surprised if it takes a while to finish. You can
Update the preview before you do so, but that
will add to the time it takes to finish this step.

2  Use the bump map option of the Emboss
filter (Filters>Distorts>Emboss) on this layer. Use
a low azimuth and elevation (25-35), and a
moderately high depth (60-70). We’ll call this is
our “bump map” layer over which everything
else will be blended. Duplicate this layer.

1 Start with clouds. The clouds should be
relatively soft, little to no harsh edges if
possible. Less cloud fill is probably better for a
grunge look that doesn’t overpower the rest of
the image. If you can’t get one yourself, try a
Random Seed of 1044492096, a Uniform Noise
distribution with an amplitude of -1.12 and
Norris-like scaling with a Scaling parameter of
1.24. Add noise to this with Noisify  using non-
independent color channels set to between
0.05-0.10.
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Two issues digital artists face in their daily work are
the need to undo changes made to previously saved
work and the desire to modify colour content with
simple brush strokes. For the former, they turn to

GIMP’s layer masks to generate non-destructive
changes. For the latter, they look to GIMP’s blend
modes. Next month, we’ll aim our tutorials at both of
these highly desirable yet easy-to-use features. LXF

NEXT MONTH

GRUNGE
Grunge is a popular style these days for print work. Generating grunge is a very personal thing – much like the

music form – so this texture example may or may not produce what you might call grunge. But it does for us.
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