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SKINNING WITH THE GIMP

he chances are you’ve played with programs like

MPlayer, Xine and XMMS if you’re into watching video or

listening to music on your Linux system. These tools

provide user interfaces that stretch the limits of convention

for computer programs. 

But skins aren’t limited to multimedia programs. The advances in

CSS for the Web have made skinning an art unto itself for website

design. Take a look at the ‘Zen Garden’ (www.csszengarden.com/)
or Eric Meyer’s ‘css/edge’ (www.meyerweb.com/ eric/css/edge/)
sites for examples of this technology.

Creating these interfaces is a two-step process. The latter step

is trickier and requires understanding how to chop images into

component parts and put them back together using a skinning

interface, often requiring knowledge of XML or some other text

file describing the position of those image pieces. The first part,

however, is a breeze: building the interface starting with nothing

more than a blank GIMP canvas and an active imagination.

In this tutorial we’ll take the steps outlined in The Complete

Adobe Photoshop Handbook, a compendium of tips and tutorials

for Photoshop users published by Linux Format’s sister

publication Computer Arts, and convert them into the equivalent

steps under The GIMP. In this way, you’ll not only get to see how

easy it is to create these mind-stretching designs, but also how

close in features Photoshop and The GIMP really are!

There aren’t many special tricks here that a default installation

of The GIMP couldn’t provide, but you will want to make sure you

can find the Lighting Effects plug-in (Filters>Light Effects>Lighting

Effects) and are very familiar with dragging Guides around the

canvas. We’ll be using many guides in this tutorial. We also

assume you know your way around The GIMP’s windows and

menus, know how to change foreground and background colours,

and know how to use selections. If you don’t have the Round

plugin (look for Selections>Round) then skip the part where we

round the edges of selections. You don’t have to round them to

complete this tutorial. Finally, we’ll be working with grey colours

for most of this tutorial. Color and texture can be added later as

separate layers composited with different layer blend modes.

MIs – better known as Skins – are all the rage with application
developers. Michael J Hammel wields the tools to create
fantastic interfaces, all you have to do is provide the creativity!

Multimedia interfaces

Designing a skin

The design is simple – an

imaginary handheld device

with a Palm Pilot-like

screen, handle grips on the

side and a hard-shelled

metal structure

underneath. We start by

creating a 3D metallic

plate on which the device

is built.

Create a new window that is 512 x 512 pixels in
size. Fill the background layer with black and then
create a new, transparent layer above it. Keeping in
step with the original tutorial, we’ll name this new
layer ‘Main Body’. Drag a vertical guide from the left
ruler into the canvas area and position it at x=20
pixels. See the lower left of the status bar to see the
guide position. Drag another vertical guide and place
it at x=492. Place horizontal guides at y=20 and
y=492. Make a circular selection by pressing the shift
key while you click where the left and top guide
meet and dragging to the opposite guides
intersection. Fill this selection with equal amounts of
Red, Green and Blue (RGB), each set to 175.

1

Add guides 85 pixels
from all four edges and
drag another circular
selection using these
guides. Use Ctrl-X to
cutout this selection from
the Main Body image.
Add vertical guides at 155
and 357 and a horizontal
guide at 380 to create a
rectangular box cutout at
the bottom of the Main
Body image. Use the
‘Alpha to Selection’
option for the Main Body
layer to create a selection
out of this upside down
horseshoe shape.

2

1

Change to the
Channels page of the
Layers and Channels
dialog. Add a new
channel and name it
‘Main Body Channel’. Set
its opacity to 100%. The
image should go to black
with the horseshoe
shaped selection still
active. Fill this selection
with white, then clear
the selection with Ctrl-
Shift-A. 

3
2 3

On the

CD and DVD
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MPlayer Skin Howto: http://mplayerhq.hu/DOCS/skin.html

XMMS supports WinAMP skins. A Howto for this can be found at www.markerrington.com/winampskins/howto/

This GIMP tutorial was inspired by the original work of Kraig Sederquist (www.sedergraphics.com) from a tutorial published
in The Complete Adobe Photoshop Handbook, published by Creative Arts Magazine, Future Publishing Ltd.

Resources

>>

Create a new layer below the Main
Body and call it ‘Metal Backing’,
making sure this layer is now the active
layer. Use the guides from step two to
create another circular selection and
fill the selection with red, green and
blue values of 200 each. Add vertical
guides at 120 and 392 and horizontal
guides at 170 and 450. Create a
rectangular selection from these guides
and round the corners using the
Selection>Round menu option, with
the roundness set to 30. Cutout this
selection from Metal Backing using
Ctrl-x. Create a selection of this layer
with the ‘Alpha to Selection’ option in
the Layers menu. 
In the Channels page of the Layers and
Channels dialog, add a new Channel
named ‘Metal Backing Channel’ set to
100% opacity and fill the selection
again, this time with white. Turn of the
visibility of this channel and clear the
selection. Change back to the Layers
page and make sure the ‘Metal
Backing’ layer is active. Apply the
Lighting Effects plug-in to this layer
just as in the previous step but this
time use the ‘Metal Backing Channel’
as the Bumpmap image.

6

With the ‘Main Body Channel’ still
active, apply a blur with Filters>Blur>
Gaussian Blur (IIR) with the horizontal
and vertical values set to 3. The blur
applied to this channel will be used to
create the bevelled edge of this part of
the design. The same technique (using
different channels) will be used later on
other components in the image to add a
3D feel to them as well. When the blur
is complete, click on the eye icon to
turn of the visibility of this channel (so
we can see the whole image again). Go
back to the Layers page in the Layer
and Channels dialog and click on the
“Main Body” layer to make it active.

4 4 5

Now we’ll give the Main Body a little 3D effect. Open the
Lighting Effects plug-in (Filters>Light Effects>Lighting Effects). Set
the Options to Enable Antialiasing with a depth of 3.0 and
threshold of 0.25. In the Light page set the Light Type to
Directional and the Color to white. Set the Direction Vector to x= -
0.60, y= -1.0 and z= 1.0. In the Material page set the Intensity
Ambient level to 0 and the diffuse level to 0.70. Set the
Reflectivity diffuse to 0.65, specular to 0.85 and the highlight to
27.00. Finally, in the Bumpmap page, enable bump mapping using
the Main Body Channel as the map and using the default values for
the rest of the options. The Environment mapping is not used here.
Apply this to the Main Body layer.

5
6

Make the screen Area
Now we’ll add an area in which we’ll later place

display screens. These screens will appear to be

encased by a metallic frame set within the empty

space formed by the ‘Metal Backing’ layer. The trick

to this part of the tutorial is to be creative with the

casing – make it fit in the empty space by drawing a

straight and angled edge selection using the Bezier

Selection tool, then round the corners with

Selection>Round again. The fancier you get with

your Bezier selection the more high-tech you can

make the casing appear.

After the casing is ready, we will spend some

time creating handles to hold our digital device.

Start by removing all the old guides. The existing

guides will just add unnecessary clutter and

confusion to our work. You can drag them out

manually or, if you have the script installed, use the

‘Guides>Remove Guides’ plug-in.

7
Add a new layer

above the Main Body
layer and call it ‘Screen
Casing’. Add horizontal
guides at 190, 355, 385
and 490. Add vertical
guides at 140, 170, 342,
and 372. Draw a Bezier
selection using these
guides to make straight
and angled lines that
cover much of the empty
space in the ‘Metal
Backing’ layer. Fill this
selection with RGB
values of 150.

7
8

Create another channel at 100%
opacity, this time named ‘Screen
Casing Channel’. Fill the selection in
this channel with white and turn off
visibility of the channel. Return to the
‘Screen Casing’ layer and apply the
Lighting Effects filter again using
‘Screen Casing Channel’ as Bumpmap.
To change the reflectivity on this
casing (making it a duller metal) you
can move the location of the light and
change the ambient intensity and the
specular value. Don’t forget to blur
your channels or the 3D effect will
not show up.

8
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The handles are almost complete. We need to add a little more
depth to them so they appear more round than flat. To do this, we
start with the handle selection once again (it should still be there if
you haven’t cleared it yet). Add another layer between the Handles
and Handle Lines layers and name it ‘Handle Shadows’. Select a
large, soft edged brush, perhaps ‘Circle Fuzzy 76’ if you have that
one. With the opacity of the airbrush tool set to 50 per cent, paint
black strokes along the left and right edges of the selection in this
layer. Your strokes should follow the curve of the handle selection.
Only add shadows along the outside at first, then add a little to
the inside. Just enough give the appearance of a rounded handle.
When you’re done, shrink the selection by 10 pixels, invert it, and
feather it by 7 pixels. Choose Image>Colours>Curves and adjust
the curve as shown. This keeps the edges of the original handles
while preserving the roundness of the shadows.

15

<<

12

Make the ‘Main Body’
layer the active layer.
Make a rectangular
selection through the
middle of this layer, then
copy and paste the
selection as a new layer.
Name this layer
‘Handles’. The new layer
will be cropped to the
edges of the selection,
but we need to grow the
selection, so you’ll need
to choose ‘Layer to
Imagesize’ in the Layers
menu to make room for
the larger selection.

9
9

Select ‘Alpha to
Selection’ in the Handles
layer – you now have a
selection of the two
handles we’re about to
create. Grow the
selection (Selection-
>Grow) by 8 pixels,
make sure the ‘Preserve
Transparency’ option for
this layer is turned off,
and fill with RGB = 112.
Keep the selection active
for the moment.

10
10

Make the screen Area (continued)

Create another 100%
opacity channel, this one
named ‘Handles Channel’.
Fill the selection with
white. Clear the selection
and blur the channel by
16 pixels. Switch back to
the layers page and make
the Handles layer active.

11 Apply the Lighting
Effect filter to the
Handles layer using the
Handles Channel as the
Bumpmap. Change the
Reflectivity and Intensity
options to change the
material appearance of
the handles. We’ll be
adding more texture to
them in a moment.

1211

13

15

14
Let’s add texture to

the handles. Create a
new, very small 4x4
image filled with white.
Fill the upper half with
black. Zooming in on this
image will make this
black fill easier. Save this
file in your .gimp-1.2/
patterns directory with
the filename ‘stripes.pat’.
When prompted, give the
description as ‘Simple
Stripes’. Once you’ve
saved the file, open the
patterns dialog and click
‘Refresh’. The new stripe
pattern should be listed
in the set of patterns.

13 Use ‘Alpha to
Selection’ on the Handles
layer, then create a new
layer above the Handles
layer. Name this layer
‘Handle Lines’. Select the
Simple Stripes pattern
from the patterns dialog
box, double click on the
Bucket Fill Tool to open
its Tool Options dialog.
Choose ‘Pattern Fill’ for
the Fill Type. Now click
inside the selection. The
stripes will fill the
selection in the new
layer. Change the layer
mode for this layer to
Overlay.

14
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You’ll doubtless have
a wealth of summer
holiday snaps to
tweak and catalogue
by the time the next
issue of LXF hits the
shops, so we’re going
to show you how The
GIMP can edit them to
make them look their
very best. LXF

NEXT MONTH

In glorious colour

Add the display screen

While there are many more features we

could add to this interface, so let’s turn

our attention to adding texture and colour

to it as an example.

This can be done in multiple pieces if you

want multiple display areas or as one big

screen over the Screen Casing layer. We’ll

use our light mapping trick to give the

appearance that the screen is recessed

into the metal casing.

Start with new vertical guides at
183 and 329 and horizontal guides at
233 and 470. These provide the outline
for our screen. Make a rectangular
selection with these guides. Create a
new layer just above the ‘Screen Casing’
layer and call it ‘Screen’. Fill the
selection with RGB values of 106, 120,
105 respectively. The screen resembles
the original Palm Pilot LCD screen.

16

16 17

18

Create a ‘Screen
Channel’ in the channels
page filled with white.
Clear the selection and
blur by 3 pixels. Return
to the Screen layer. Select
Filters>Map>Bump Map.
Set the azimuth to 130,
the elevation to 13, the
depth to 8 and choose
the Linear, Compensate
for Darkening and Invert
Bumpmap options. Make
sure the Bump Map
image is set to the
‘Screen Channel’. Apply
this to the Screen layer. 

17

You now have the appearance of a recessed screen. At this
stage, the basic unit is complete and we can get as creative as
we’d like. First we’ll make simple connections between the Screen
Casing and the Main Body. Add a transparent layer just above the
background and below the Main Body layer. Draw a rectangular
selection starting on the left inside the Main Body and through to
the right side of the Main Body. Set the Foreground to White and
Background to Black. In the Gradient Fill Tool Options dialog set
the Blend to ‘FG-to-BG (RGB)’ and the Gradient to ‘Bi-Linear’. Then
drag from top to bottom of the selection. The result will be simple
3D tubing between the Screen Casing and the Main Body. Repeat
this a few times along different horizontal lines in the image.
Notice that only the parts of the tubing that are not blocked by
higher level layers show through.

18

19

Choose the Main Body layer and
duplicate it. Get a selection with Alpha
to Selection. Fill this with a pattern -
we chose ‘Canyon 2’. Desaturate the
layer, set its blend mode to Multiply
and reduce its opacity to about 50%.
Duplicate this layer, alpha to selection
the new layer and fill with the Pink
Marble pattern. Set this marble layer’s
blend mode to Color.

19

Duplicate the Screen
Casing layer and Alpha
to Selection on it. Fill the
selection with a blood
red – RGB of 102, 9, 9
respectively. Set the
layer mode for the red
layer to Saturation.

20

Duplicate the Metal Backing layer
and Alpha to Selection it. Fill the
selection with the Lightning pattern.
Set the layer blend mode to Value and
the opacity to about 40%.

21

20

21
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