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BEZIER CURVES

ast month, we took our first look at Inkscape, the latest Open

Source graphics tool to sweep the Linux desktop

marketplace. Inkscape fills a long-standing void in this

arena: vector illustration. Vector design allows artists to

create at one resolution and easily scale – without distortion – to

any other resolution. This flexibility is extremely important in

many areas of graphical art, especially in logo design.

Logos are the focal point of a corporate or organisational

identity. A logo can be used on letterheads, envelopes, memo

pads, coffee cups, and pens in the office; it must also serve as a

location marker on conference banners or building signs and as

an identifying label on company vehicles. 

It would be a waste of energy (and a pain to boot) to have to

design multiple logos with a raster-based tool (like The GIMP) for

printing at different resolutions. Instead, logo artists use vector

illustration to design a single logo, and they then can scale it

appropriately for the intended use.

In this month’s tutorial, we’ll recreate the XNotesPlus logo

paying special attention to the use of Bezier curves. If you’ve ever

used Mac OS 9 or higher, you’ll probably have come across

Stickies – an application that lets you place Post-It
TM

-style notes

on your desktop. XNotesPlus is a sticky notes program that takes

this idea one step further into the domain of the PIM (Personal

Information Manager): with over a dozen features like email, text

search, printing, audio/visual alarms, date and calendar inserts,

categorisation by coloured projects, etc. It also includes an

interface to the 3Com Palm Pilot, allowing backups and syncing

of backups, uploading XNotes to the Pilot and downloading Pilot

Memos into XNotes, and a complete interface to the Pilot

Address Book, allowing you to use addresses from the Pilot to

print envelopes and email notes to your contacts. XNotesPlus

comes with support for both GTK and Motif/LessTif. For more

information about XNotesPlus, see www.graphics-
muse.com/xnotes/xnotes.html

Before we dive into the meat of the tutorial, we will first need

a little background on terminology.

Logo design is an art unto itself, and no professional graphic artist would entertain the idea of working
on a logo design project without the aid of a vector illustration tool. Michael J Hammel shows us how
Inkscape makes creating shapes a breeze, using a powerful and easy-to-use feature: Bezier curves.

Working with Beezers 

This month’s finished project: the XNotesPlus logo in Inkscape.

On the

CD and DVD

Inkscape
www.inkscape.org/
DAG repository
http://dag.wieers.com/ho
me-made/apt/
What are bowls and
counters?
www.philsfonts.com/
character.html

IMPORTANT
LINKS
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PART I - GET FAMILIAR WITH NODES AND HANDLES

What is a Bezier Curve?
My wife recently started work with Adobe Illustrator and was

having problems learning how to manipulate paths. Being self-

taught, she sometimes comes to me with questions about the

tools or terminology. One day, she came in frustrated and said

she would never be able to figure out those stupid Beezers.

“Beezers?” We still call them that for a laugh.

They’re actually pronounced beh-zee-AY, after Pierre Etienne

Bézier, the French mathematician and engineer who developed

this method of computer drawing in the late 1960s while working

for Renault, the car manufacturer. Logo design generally starts

with simple text or a standard shape such as a box or circle. These

objects are then converted to a path, which gives them nodes that

can be moved and manipulated to change the shape of the path.

A path and its nodes are collectively what make up a Bezier curve. 

Inkscape shows nodes as square boxes dispersed along a curve.

Two nodes make up a line segment and a line segment can be

manipulated by adjusting the handles for the two nodes. Handles

are shown as small circles attached to the node by a straight line. 

Activating and grouping
A Bezier curve with nodes and handles. Clicking on a node
makes it the active node. Holding the shift key down and
clicking on another temporarily groups the nodes together.
With two nodes selected, you can click on the Curve
Segment button to add handles between the two nodes. If
the nodes are very close together, zoom in a bit to have a
better chance of grabbing the handles instead of a node.

Node button bar
These buttons manage Bezier nodes and handles. If a node
already has handles, then they will be displayed when you
click on the node. Also, the handles for the nodes to either
side of the selected node will display their handles as well.
The handles allow a straight-line segment to be made into a
curved path. To convert the curve back to a straight-line
segment, click on the Line Segment button.

More often than not, you’ll find yourself removing
nodes from objects you convert to paths. You can do
this quickly with the Path>Simplify menu option, but if
you have to do it manually, you can use the Delete
Node button. The node buttons work with one or two
selected nodes. Selecting more than two nodes will
cause these buttons to simply ignore your request.

Simplify is a great tool for converting a scanned
object (converted to a path with the AutoTrace Tool,

which is a separate but important tool in itself) to a
path with only a few nodes. You can do this with text
too. Imaging converting a script font to a path – it will
have a jumble of nodes for all the curved segments.
Use simplify to reduce the node count and create a
personalised font of your own. Try typing “Hello World”
in any script font, convert the object to a path, click on
the node tool and then run Path>Simplify several times
to watch how the font changes. 

WORKING WITH NODES
Keep it Simplified, stupid!

Managing nodes
From left to right: Add, Delete, Merge two
nodes, Join two nodes with a line segment,
Split the segment between two nodes, Convert
a single node to two separate nodes.

A node can have a line segment or curve extending out from either
side. Each side that has a line segment or curve will have a handle.
You can drag the handles around to change the shape of a curve.
The behaviour of the curve with respect to the handle depends on
the mode of the handle. There are three handle mode buttons in
the node button bar: Corner, Smooth and Symmetric. Corner mode
allows you to move a node’s handles independently of each other.
Dragging the two handles toward each other will produce a sharp
corner in the curve at the node. This means the right-side handle
does not affect the left-side curve. 

Smooth also allows you to move the handles independently, but
the curve at the node remains smooth. This means the right-side
handle can affect the left-side curve in order to keep the curve at
the node smooth. Symmetric mode forces the two handles of a
node to act in unison. If you experiment with them, you will see
that they keep the same distance (but in opposite directions) from
the node and are always 180 degrees apart. 

There are other buttons in the button bar that you will want to
get familiar with later. The most important are the Line Segment
and Curve Segment mode buttons. The former will remove handles
from the selected nodes, while the latter will add them. When you
create an object and convert it to a path, the nodes initially may
not have handles. If they don’t, select the nodes and click on the
Curve Segment mode button to add handles. The Line Segment
mode will remove handles between two nodes and cause the
segment between those nodes to become straight. 

WORKING WITH HANDLES
Corner, Smooth and Symmetric

Handle buttons
From left to right: Corner Mode,
Smooth Mode and Symmetric
Mode.

Segment mode
buttons
Line Segment and
Curve Segment
mode buttons.
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<< PART II - RECREATING THE LOGO

Deform a square
We start with a simple square. Select ‘Path>Object to Path’ to

convert the object to a path. Click on the node tool, and you’ll

see nodes at each of the four corners of the square. The square

is tall and thin. Click on the left-side ruler and drag out a vertical

guideline to the middle of the page. Select the two nodes at the

top of the square and drag them to the right, effectively shearing

the rectangle. Drag until the top-left node snaps itself to the

guide. Now, select just the bottom two nodes and shear to the

left. Drag until the bottom-right node snaps to the guide. Remove

the guide by dragging it back into the left-side ruler.

Select the two left-side nodes. Click on the Curve Segment

mode button. Adjust the handles as shown. This creates the left-

side curve. The amount of adjustment is not easy to measure

with the current version of Inkscape, so you’ll just have to eyeball

it for now. Repeat this process for the right-side nodes. Finally,

select ‘Dialogs >Fill and Stroke’ and choose yellow for the fill

colour of the box. Set the stroke width to 1 pixel.

Drawing a pen
Creating the pen requires no handle changes, but does require

adding new nodes and repositioning them. Start with a long thin

horizontal box – this will be the pen’s shaft. Make it moderately

large – remember that you can easily resize objects in Inkscape

without distorting them. Add two vertical guides toward the left

side of the box and four horizontal guides evenly spaced with two

of the horizontal guides on the outside edges of the box. Convert

the box to a path and click on the node tool.

Add two nodes between the top nodes of the box. Drag the

two new top nodes to where the vertical guides meet the top

horizontal guide. Select the two nodes and add another node

between them. Drag this new node down to where the left

vertical guide meets the second horizontal guide. Select the new

node and its right-side neighbour node. Add a node between

these two and drag it to where the right vertical guide meets the

second horizontal guide. You now have one side of the stem

complete. Repeat this process for the bottom-side of the box to

create the other side of the stem.

To the right of the pen shaft, draw another box the same

height, but not as long. You can use the horizontal guides for this.

Convert the box to a path. Delete the top right node. Move the

bottom-right node up so that it is visually centred between the top

and bottom horizontal guides. This is the pointed part of the pen.

Using the Bezier tool, draw a straight line from the stem to

the right side of the pen shaft. From the ‘Dialogs>Fill and Stroke’

window, set the width of the stroke to 2 pixels and the stroke

colour to white. Draw a similar line from the left side of the pen

point to the right tip. These two lines act as reflected light from

the edge of the pen.

Select the Star tool. Click on the pen shaft where the star will

go, and drag to create a polygon shape. Hold down the right

mouse button on this shape to view an object menu, and choose

the Star Properties menu option.  Make sure the Flatsides option

is set to False. Set the number of sides to eight. The object

Sheared box with guide
The box has been

sheared when the nodes
snapped to the guide.

Sheared box with
curve-adjusted handles
The handles have been
adjusted to create the

curves on either side of
the box.

Pencil with stem nodes and guides
The stem on the pen has four nodes on each side.
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should have two nodes: one for the inner radius, and one for the

outer radius (switch to the node tool to see them). Drag the inner

radius toward the object centre to create longer, thinner spikes.

Change the stroke width to 0 and set the fill colour to white.

Finally, select all objects in the pen – including the white

reflections and star – and group them as a single object. Resize

so the pen is proportionate to the yellow shape. Rotate the object

-60 degrees (the amount is shown at the bottom of the window).

If you find the size of the pen is not right after the Rotate, undo

the rotation and resize again. Note: always do the resizing from

the horizontal position, not from an angled rotation.

Position the pen group so the pen acts as a ‘top-left to

bottom-right’ stroke of the letter X, with the modified square

shape acting as the other stroke. 

The swoosh
Draw a reverse-Z shape with the Bezier pen tool. Switch to the

node tool. Add handles as needed, and adjust them to make it a

smoother S shape. Draw a triangle on the top part of the S, again

with the Bezier pen tool. Zoom in to view the nodes’ intersection

with the S shape. Reposition the nodes to fit on the curve. Adjust

the handles for the triangles nodes so that two sides follow the S.

Delete the last node of the triangle – we just used it to keep part

of the path out of the S shape. Adjust the remaining handles so

that the segment follows the S closely, but doesn’t intersect it.

Set the fill for the triangle to match the S shape. Repeat this

process for the bottom part of S curve. This creates fat sections

on the S curves. Group all these components into a single object.

Text and shadows
The major pieces are complete. All that is left is to add some text

and shadows. For the text, set the stroke width to 1 and fill with

appropriate colours. Position the text as seen in the original logo. 

For the shadows, duplicate the original box we reshaped and

filled with yellow. Fill this duplicate with black and offset a small

amount to the right and down from the original shape. Then

lower the duplicate to the bottom (Object>Lower to Bottom).

Repeat this process with the pen shape. After you lower the pen

shadow to the bottom, raise it twice with Object >Raise. This puts

the pen shadow above the yellow shape, just as in the original

logo design.

Your final result may not look exactly like the original logo, but

fear not: this is a practice session. The work of learning a new

tool predominantly focuses on imitation of existing work. The

more you practise to imitate, the better you learn the tool. And

that will eventually lead to logo designs of your own… LXF

If there’s any aspect of
artwork production under
Linux – whether it’s using
The GIMP or other art apps
– that you would like to
see featured as a tutorial
in future issues, or if you
have any ideas about
particular tasks you would
like to see as a step-
through, please drop us a
line at linuxformat@
futurenet.co.uk with ‘Art
tutorial suggestions’ as the
subject line, and we’ll pick
the best for publication!

NEXT
MONTH

Reflective star
A reflection is made from a star shape with multiple points
and a small internal radius.

The swoosh with triangle nodes
The swoosh has a modified triangle to give it width.

Inkscape’s main motivation is to provide the Open Source
community with a fully XML, SVG, and CSS2 compliant SVG drawing
tool. Additional planned work includes conversion of the codebase
from C/GTK to C++/gtkmm; emphasising the use of a lightweight
core, with powerful features added through an extension
mechanism, and establishment of a friendly, open, community-
oriented development process.

The current release of Inkscape, version 0.38, does not support
layers. However, layer features are being added quickly and
extensive layer support is expected in the 0.39 release.

Inkscape is available for both Windows and Linux users: download
your copy from www.inkscape.org/download.php

INKSCAPE
www.inkscape.org/
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