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GREETINGS CARD DESIGN

hose of us who are known for our computing

predilection are often assumed by those close to us to

be able to turn our electronic box of tricks to any creative

subject. That’s fine and fair enough if you’re an enthusiastic

artsy type, but abilities to program in raw C++ and flair for visual

design are not always abilities that go hand-in-hand. We’re not all

artists, but we often have reason to try to be, especially when

hostage to the behest of our nearest and dearest.

The solution may be closer to your fingertips that you might

immediately think. Our saviour comes from The GIMP’s ability to

easily create, save and recall selections. The selections act as fill

areas that you shape with layer masks. Combining the layers in

the right order leads to a final image that designers will admire,

families will adore, and you will love – because it took you less

time than browsing in the local card shop! Not to mention the

crowds you avoided. And best of all – it comes from your heart!

This month, we’ll walk you through creating a image suitable

for printing on blank greeting cards. The goal here isn’t to

duplicate the design, but to see how you can apply the exact

same process to any stock clip art to create your cards.

We’ll be working with GIMP 2.0 and SANE for this project.

SANE for GIMP 2.0 may not be available for your distribution, so

you can either use SANE as a standalone application (and not a

GIMP plugin) as we do here; or you can use GIMP 1.2 and the

SANE plugin. See www.sane-project.org/ for more on scanners.

Clip art input
If you’re not an artist, don’t fret. We’re starting with clip art scanned

from one of the myriad clip art collections available for purchase.

The most famous of these is probably the Dover Clip art series of

books, from http://store.doverpublications.com/, each of which

provides pages of clip art which you can scan and use royalty-free. 

The art of colourizing clip art

TUTORIAL GIMP

The festive season is fast approaching, and you’re afraid that you’ll get stuck with the job of designing
family greetings card – what to do? Sit back, relax, and enjoy yourself, says Michael J Hammel, because
The GIMP can take you from clip art to seasonal storytelling in just a few minutes.
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Scanning
1/ Start with a preview of the artwork. This image is upside-down, but
that’s easily fixed in The GIMP. The alignment is off so we use the selection
tools in SANE to grab as much of the original image as possible. Set the
scan mode to gray. Colour isn’t necessary in the scan for this project. Set
the Scan Resolution to 200 DPI (which is what we’ll use for our print
resolution later on). Save the scan to a file. It will save time if you decide
to start over – scans take longer than opening a file. 
If you scanned directly into SANE as we did, then you’ll need to open the
file in The GIMP, otherwise the SANE plugin will have opened a GIMP
window automatically. 

Color Adjust
2/ The image will be grayscale and, in this case upside down. The
orientation is quickly fixed with the Flip tool. Adjust the white/black levels.
You can use the Curves dialog to make the image more crisp without
taking away too much details as well. The amount of adjustment is up to
you, but the key at this step is to make the background as white as
possible. Use the Color Picker to check that most of the background is the
same color. When you’re ready, convert the image to RGB using the
Image>Mode menu. If you’re planning on printing to card stock, this would
be the time to scale the image appropriately. Remember – multiply the
size of the card by the DPI to find out how big to make the image!

Selection
3/ The next part is quick but of crucial importance. Using the Select by
Color tool, select the background. In this image the white is easily pulled
from the background. Save this selection as a channel. We’ll be using it
again repeatedly. Click on the background layer again to make it active
and get rid of the selection. We’re now ready to colourize the image.
Start by creating a new layer. Make it the active layer. 

Colourize Sky
4/ Click on the saved channel and choose ‘Channel to Selection’. Fill the
selection top to bottom with the the Gradient tool, using the Horizon 2
gradient using a linear shape. Try to match the horizon in the image to the
horizon in the gradient. Use the Scale tool and stretch the image down or
up until the horizons match. This small amount of scaling also added a slight
appearance of snow on the trees in this image. Add a layer mask to mask
out the area in the foreground – the snowy ground in this image. A light
blur on this layer can also help soften the effects of the snow on the trees.
We duplicated the layer, stretched it, setting its opacity to 40%, and
applied a mask to the sky to add some color to the snow. 

1 2

3 4
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In the final image, we can adjust the sky colour to be more of

an early evening shade, with dark skies above and lighter toward

the horizon. We also adjust the cloud layer to use Grain Merge to

bring out the clouds using the colours of the sky. The final effect

is a little grainy through the trees. This is because of the initial

black/white adjustments and the selection we made from the

background that we saved to a channel. The initial black/white

adjustments could be modified and/or the selection feathered to

remove some of the grain. 

Printing this image is a bit of a task. You will need to know the

exact dimensions of your print area as well as any margins that

your printer will not print to. Fortunately, most modern inkjet

printers will print all the way to the edge of a card, making the

calculations less complex. In any case, the use of the GIMP-Print

plugin (available for both GIMP 1.2 and 2.0) and the CUPS printing

system (available for all major Linux distributions) will produce

high quality prints. LXF

TUTORIAL GIMP

<<

Colourize Trees
5/ Select the saved channel again and choose the Channel to Selection
option. Choose ‘Invert’ from the Selections menu. Click on the
background layer to make it active again. Use Ctrl-C to copy the trees
followed by Ctrl-V to paste the trees into a floating layer. Click on ‘New
Layer’ from the Layers menu. The Keep Transparency button for the new
layer should be checked, so its safe to select the entire layer (Ctrl-A) and
fill it with colour. Play with opacity and Mode settings for this layer, as
well as its position in the layer stack, to find the desired effect. We placed
this layer just above the background, set its opacity to 42%, set the layer
mode to Hard Light (which is new to The GIMP 2.0) and then duplicated it
to enhance the effect.

Clouds
6/ Generating some background clouds is very easy. Create a new layer.
Choose Filters>Render>Clouds>Plasma. Set the turbulence to 5 and use a
random seed. The pattern generated will be in full color. Choose
Layers>Colors>Desaturate (in The GIMP 1.2 this would be under Image-
>Colors-Desaturate). Adjust the layer using the Curves dialog to allow for
more black regions. The result will look more like smoke than clouds.
Choose Filters>Distorts>Wind. Set the Style to ‘Wind’, the Direction to
‘Right’ and the Edge Affected to ‘Both’. The amount of threshold and
Strength will be your choice – play with these settings. When you’re done,
apply Whirl and Pinch to the layer to make the clouds  more wispy. Add a
layer mask. Use the saved channel selection, invert it and fill the selection
in the mask with black. Then mask out the foreground area as well.

Texturized snow
7/ Duplicate the cloud layer and remove the mask for the
new layer. Add a new mask, fully white. Earlier, we created
a mask for the foreground in they sky layer. Click on that
mask and use the Fuzzy selection to create a selection of
the sky (the black region). Now click on the new mask and
fill with black. Scale or distort this new layer to generate
the snow’s rolling texture. Blur the layer if necessary and
adjust the opacity.
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Clip-art doesn’t have to be scanned in –
there’s lots available online too. Now that
The GIMP 2.0 can incorporate Inkscape’s
vector graphics facility natively as a plugin, it
opens up whole new areas of scalable art
resources that can be manipulated by Linux
users with The GIMP. If you are in the
position to favour the following projects,
please do so, as they are all Linux-friendly
organisations to a greater or lesser extent.

GIMP-savvy 
http://gimp-savvy.com/PHOTO-ARCHIVE/
has more than 2.5GB of free photos and
images, consisting of something like 27,000
images. You may spend a while browsing to
find what you want – full indexing of the
images is planned; at present images are
provided in an interactive environment
allowing the community to participate in the
labelling of archived photos. The eventual
expectation is that the resulting index will be
both richer and more robust than one
fashioned by any so-called master architect.
Why not lend a hand?

The images and photos in this archive come
from three main sources: the National
Aeronautics and Space Administration (NASA),
the National Oceanic and Atmospheric

Administration (NOAA), and the US Fish and
Wildlife Service (FWS). Each of these sites
clearly state that their photos and images are
in the public domain and give the conditions
for their use; please read their statements.
There’s also a clear and succinct explanation
of what constitutes ‘fair use’, at least from a
US perspective; so read it if you’ve ever been
bamboozled in the past by legalese. 

Open Clip Art Project
www.openclipart.org/index.php
This project has the goal of creating a free
archive of clip art that can be used with free
software. Much of the artwork is in SVG, hence
it can be both used and created in Scribus. The
concept is to have a ready made set of clip art

objects that can speed document and artwork
creation for a variety of uses. The project has
been launched by a couple of members of
Inkscape team, Jon Phillips and Bryce
Harrington, among others. A well-written FAQ
has been posted and Scribus users are
encouraged to support the project.

Free Foto
www.freefoto.com/index.jsp
The UK’s largest free photo resource.

Wikipedia Images
http://en.wikipedia.org/wiki/Public_domain
_image_resources
A great selection of links to Free photo and
clip-art resources of all kinds.

FREE CLIP-ART 
Online resources

Is there any aspect of
Linux-based art that you’d
like to see covered in a
future issue of Linux
Format? Whether you’d
like a more advanced
recap of the subjects that
we’ve already covered, or
there’s something that
you’d like clarified, or
think that there’s
something we’ve missed,
then please email us at
linuxformat@futurenet.
co.uk with ‘GIMP tutorial
suggestion’ as the subject-
line. The whole LXF GIMP
tutorial series will be
available soon on the
coverdiscs and online, so
watch this space!

NEXT
MONTH

The Open Clip Art Project is in its
nascent stages, so don’t expect too
much from it right now! 

Most clip-art sites have terms that
cover commercial use as well as free
non-profit use – please read them!

from only £49.95 / month

Let’s face it – if you’re building and testing your own web-based applications, designing & hosting your clients’ websites, or just own 
a very busy site – what you really want is your own server. But sometimes the cost of running a dedicated environment is just too 
prohibitive.
So wouldn’t it be great if you could share the cost of the server but not share the resources?
In other words, the full power of your own server - in a shared environment. 
Hostway’s new VPS solution has a proprietary partitioning system that allows multiple server set-ups on the same box, with the guaran-
teed CPU, Disk Space and Network resources that you wouldn’t get in a normal Shared Environment.
Together with full root or control panel access, choice of open source software at install, IP- table firewall, 24hr Roll-Back backup option 
and Hostway’s steadfast commitment to customer care, it adds up to a pretty unique solution. 

Hostway – Hosting the way you want it.

“The power of Dedicated Hosting, at the price of Shared.”

call us now on 0808 180 1880 • sales@hostway.co.uk • www.hostway.co.uk/virtual
Domain Registration • Web Hosting • Resellers • E-commerce • VPS • Dedicated Servers   |   Australia • Canada • Germany • Korea • Netherlands • United Kingdom • United States
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