
TUTORIAL Gimp

ILLUSTRATION & IMAGE EDITING

Gimp Transform 
humdrum images
If you fancy revitalising an old photo – or can’t afford to buy images from a stock library – 
try these Gimp techniques from Michael J Hammel and feel like a graphics god. 

Gimp users start many of their projects with an 
existing image, usually a scanned photograph. There 
are many places online to buy high-quality images. 

These stock image archives are made up of pictures taken by 
professional photographers and scanned at various resolutions 
using high-quality equipment, making them suitable for website 
thumbnails, large posters and everything in between. 

Unfortunately, most online archives charge an arm and a 
leg (though royalty-free options are more affordable, as we’ll 
see). Most are too expensive for the average user looking to 
create a modest poster for the junior football club or a flyer for 
the local dry-cleaning business. The average user, therefore, 
turns to a more mundane source: the family album. We all have 
our own collection of photos good enough to show grandma 
but among the blurred shots and red eye there may be 
promising images that, with a little Gimp tweakery, are worthy 
of a wider audience.

In this issue’s tutorial I’ll show you how to get the most out 
of average photos by merging a set of them into a collage. 
We’ll also be turning an ordinary picture into a stunning studio 
portrait, and creating a simple advert using low-cost stock 
imagery. As with all tutorials in this column we’ll be using Gimp 
2.0, though any variations in Gimp 2.2 will be noted as they 
crop up (pun intended).

 

In LXF67’s Gimp tutorial we 
explored 3D effects, creating 
realistic, metal-finished 
buttons. If you missed the 
issue, call 0870 8374722 or 
+44 1858 438794 for 
overseas orders.

There are many stock image archives online. Some are pricey, 
some aren’t. Here is list of sites that can fit the budgets of either 
the average user or the professional.
Low price stock images: Professional quality stock images:
www.bigstockphoto.com www.ablestock.com
www.istockphoto.com www.punchstock.com
www.canstockphoto.com www.creatas.com
 www.stockbyte.com

ONLINE STOCK 
IMAGE LIBRARIES

Removing amateur giveaways
It’s unlikely that you’ll have framed each of your own photographs 
perfectly, so don’t be afraid to crop your images to get rid of 
uninteresting features distracting from the subject. Another trick 
to remember is that many images look terrible in colour but fine 
in black and white, so consider converting them to mono. Play 
with the Levels and Curves of your pictures, improving their 
sharpness and contrast. And finally, try enhancing your photos 
with shadows, text and blocks of light and colour.

QUICK TIP
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1/ Choose your images
This montage is a simple collection of puppies. Three images will be used to 
show the process, but the final result is a collection of many images. Two photos 
show a puppy running and another is a head-on shot. The goal will be to merge 
the two running images into a single flowing image and then integrate the 
head-on shot with that double image. Substitute any other images you like for 
the puppies. The process, not the content, is what is important in this tutorial.

PART 1 – COLLAGES AND MONTAGES

Collages and montages are just collections of overlaid images. If you were making a collage by gluing material on to 
paper or canvas you might mix different types of fabric or paper, frayed or cut in different ways to add colour and texture. In 
Gimp, you can go a step further by using transparency to merge images together.

There are no hard and fast rules for creating a montage. The basic process is to copy the images into a single image 
window, position them in that window, and then add transparency, shadows or other effects to merge the images together. 
One tip for scanned images: be sure to scan each photograph at 150dpi or higher. You can always scale the image down 
later to fit the montage, but most print images need to be scanned at higher resolutions if you plan on printing them later.

2/ Pull the images into a single window
Use one of the images as the base on to which the other two images will be 
copied. In the Layers dialog, click and hold the left mouse button over the other 
images’ thumbnail preview and drag the thumbnail on to the base image. This is 
the fastest way to copy a layer from one image into another.

3/ Position and resize
The head-on shot is positioned in the middle of the image. The other two images 
are placed left and right of this and slightly below. In Gimp 2.0 the canvas must 
be resized manually (Image > Canvas Size) to allow the image window to enclose 
all three images. In Gimp 2.2 this can be done automatically using the Images > 
Fit Canvas To Layers menu option. Be sure to add an alpha channel (Layer > 
Transparency > Add Alpha Channel) to the original background layer. The canvas 
background should be left transparent until all images are added and positioned. 
Where photos have been taken with different quality film or in different light 
conditions you may get the same subject in three different shades. Avoid this by 
desaturating all the layers (Layer > Colours > Desaturate). Later, colour will be 
added back in using a gradient in a separate layer.

1

4/ Merge into a single image
Turn off the visibility of the original layer for 
now. This montage will merge the images of 
the two running puppies. Merging two layers 
requires only that a layer mask (Layer > Mask 
> Add Layer Mask) be added to the upper 
layer. Use the Airbrush tool to paint black into 
the mask where the two layers overlap until the 
two images appear to merge. Paint only along 
the edge and don’t paint in straight lines. Zoom 
in to see the effect a little better.

2

3 4
If you’re wondering why dogs 
are often used in my Gimp 
tutorials there is a simple 
answer: dogs don’t sue. The 
use of images of people is 
covered by various laws and 
in many cases requires 
consent from the individual. 
When doing tutorials showing 
how everyday photographs 
with living subjects can be 
used with Gimp it wouldn’t 
do to use stock images. We 
don’t all have perfect images 
from which to work. So 
using simple pictures of 
puppies helps bring home the 
point without requiring 
extensive legal clarifications. 
Plus, they have the cutest 
little wet noses.

WHY PUPPIES?

LXF68.tut_gimp   81LXF68.tut_gimp   81 11/5/05   8:03:43 pm11/5/05   8:03:43 pm



www.linuxformat.co.uk82 LXF68 JULY 2005

TUTORIAL Gimp

5/ Overlay the head-on shot
Add a layer mask to the other visible layer, and turn on the visibility of the 
head-on shot. Now paint in the two layer masks until the running puppies are 
merged into the middle image. Hold down the Alt key (the Shift key may also be 
necessary depending on how your system is configured) and click on a Layer 
Mask in the Layers dialog. This will make the mask visible in the canvas, allowing 
a better view of what is being masked. The layer mask will be outlined in green in 
the Layers dialog. Repeat the Alt+click to return to normal mode.

6/ Add colour
It becomes obvious at this point that a montage makes heavy use of layer masks 
to merge images. The use of a mask is important because it won’t destroy 
original image content. That means you can edit the montage at a later time to 
change its appearance by simply modifying or even removing the mask. To add 
colour back in to the image a transparent layer is added over all the other layers 
and filled with a colour gradient – from reddish-orange to white, top to bottom at 
a slight left-to-right angle. This layer is set to Overlay mode.
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PART 2 – VIGNETTES TO SOFTEN A PORTRAIT

1/ Clean up the original
The original image shows the puppy with highly 
detailed fur and a flower-filled background. There is 
also an out of focus flower obscuring the puppy’s 
lower jaw. This flower will be removed by using 
freehand selections of nearby areas, copying (Edit > 
Copy) and pasting (Edit > Paste) into new layers 
(Layer > New Layer). Layer masks are used to merge 
these copies into the original image and the entire 
set is then merged into a single layer.

2/ Isolate the subject
You’ll now need to isolate the subject using the 
Scissors tool. Drop anchor points by clicking around 
the edges of the subject. The Scissors tool chooses 
the line nearest the click point where the contrast is 
greatest to set the anchors. Where the subject 
touches the edge of the image, zoom out (View > 
Zoom > Zoom Out) and click outside the image area. 
Close the selection by making the last click in the 
first anchor point. Any anchor point can be moved by 
clicking and dragging it around the image window at 
any time. When all anchor points are set, click inside 
the selected area to convert them to a selection.
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3/ Add a backdrop
Adding a backdrop is the easiest step in this process. 
Add a layer above the original image but below the 
isolated subject layer. A simple gradient is all that you 
need, though variations on this are always possible. 
In this example a gradient running from #A71D2F 
(a blood red) to #000000 (black) is created in this 
new layer using a square shape. The gradient is 
created off centre to add a highlight behind the 
upper left of the subject. 

In traditional photography, vignettes are softening effects that use darkroom processes to project a blurred image on to 
photographic paper. In the digital realm this process is done with a mask of an image so an underlying texture can show through. 
Additionally, lighting and blur effects can be applied to the image to soften the subject. This part of the tutorial will take another puppy 
image, pull it from its background and overlay it on a studio backdrop. The subject is then softened using standard Gimp filters.
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NEXT 
MONTH

Merging two photos can produce 
some wild images. In LXF69 we’ll 

do just that then simulate the 
‘infinite reflection’ effect.

TUTORIAL Gimp

PART 3 – BACKSCREEN EFFECT

4/ Adjust the contrast
The next step requires adjusting the contrast of the subject layer. With the subject 
layer active, open the Brightness-Contrast filter (Layer > Colours > Brightness-
Contrast). Reduce the Contrast setting by sliding the bar to the left. Reducing the 
contrast softens the image, and the degree to which you use this option will 
depend on the subject. With Gimp 2.2 this effect can be significantly enhanced 
using the Softglow filter (Filters > Artistic > Softglow).

5/ Final blur
Final softening comes from creating an oval selection around the face and neck 
of the subject, feathering by anywhere between 10 and 30 pixels (Select > 
Feather), inverting (Select > Invert), and blurring by three to five pixels (Filters > 
Blur > Gaussian Blur) depending on the size of the original image. This adds a 
depth of field effect to the subject layer.

4 5

1 2 3

1/ Scale the original
The project goal is a flyer for a tennis tournament. 
A stock image of some tennis balls and a racket 
provides the starting point. Because the stock image 
is of such high quality, there is little work to do – not 
even levels adjustment. The original size of the 
image was reduced to fit a 4x3 inch card that will 
be printed at 150dpi.

2/ Create the backscreen
A backscreen is nothing more than contrast change 
in the image that allows you to show some other 
subject or, as in this case, text. To create the contrast, 
make a rectangular selection over the area of the 
image with the least amount of subject. In this case 
the rectangle is over the bottom part of the image so 
as not to interfere with the tennis balls. A new layer 
is created and the selection filled with white. The 
colour can also be tinted. Use the Colour Picker to 
pick a colour from the image and fill the selection 
with that colour, then reduce the saturation (Level > 
Colours > Hue Saturation).

3/ Add text
Reduce the opacity of the new layer – not by a great 
deal, but if too much of the image shows, it can 
interfere with the text message. Add text in white 
then use a drop shadow 
(Script Fu > Shadows > 
Drop Shadow) offset by 
three pixels and 
blurred by five 
without allowing 
resizing. The small 
offsets and blur let 
the shadow add 
more contrast for 
your message. LXF

Not all your graphics projects need rely on questionable quality photos. There are several websites where you can buy high quality photos for relatively 
low cost. These photos, referred to as royalty-free stock images, can add a professional look to everyday projects, making them well worth the nominal price.

In this part of the tutorial a stock image is used to provide a focal subject for the project. A backscreen effect is added to allow a text message to be more 
easily viewed over the busy background
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