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TUTORIAL Gimp

Gimp Work with transparency
ILLUSTRATION & IMAGE EDITING

Michael J Hammel reveals his surrealist side for this transparency workout.

Graphics artists often need to clean up photos for a project. It happened to me recently while I was helping my wife 
prepare some photos for an advertisement for a dentist client. The photos showed people smiling, but their teeth were not 
quite perfect. You’d expect people in a dentist’s ad to have perfect teeth. While the dentist had plenty of pictures of perfect 

teeth, he didn’t have photos suitable for the advert, which had to be full colour, nicely themed and properly lit. One of the photos 
also had a logo on a shirt that had to be removed. So we turned to Gimp.

Before we’re able to tackle a project like that (we’ll actually do so next month), we need to take simpler examples of merging two 
images. We introduced this concept last issue, but this time you’ll learn how to be far more precise with the technique, as well as 
getting more practice before diving into munging with teeth.

This month’s first project will cover fine merging (the example merges the head of a dog with a man’s body), while the second 
project will be a variation of the common ‘infinite reflection’ image, with a laptop displaying a laptop, displaying a laptop, ad infinitum.

This project starts with two stock images purchased from 
an inexpensive online stock photo collection (Fig 1). I searched 
for a man in a suit and a portrait of a dog and it took about an 
hour to find the best images. 

I chose images that were taken from roughly the same angle 
(ie head on) with similar lighting. Lighting qualities can be tested 
by desaturating the images (Image > Colours > Desaturate), 
adjusting the Value curve as shown in Fig 2 and looking at 
where the shadows fall on the faces. This shows the basic 

direction of lighting. Because both images are lit primarily from 
the front they have similar shadows and highlights. And that 
makes them a good fit for this project.

Make a selection of the dog by using the Fuzzy Select tool 
with the threshold set to 20.0 and clicking in the top-left corner 
(the white area). Invert this selection so that it encompasses the 
dog. The full body will be selected at this point (plus some 
background), but we only need the head so use the Free Select 
tool to subtract everything but the head, the neck and the collar 

PART 1 – SIMPLE MERGE 

Last month I showed you how 
any set of photos can be 
turned into a collage worthy 
of more than just the 
scrapbook. Those techniques 
extend to all kinds of 
projects, like those in this 
month’s column. If you missed 
the issue, call 0870 837 
4773 or +44 1858 438795 
for overseas orders.
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3/ The feathered head, neck and tags are pasted in. 4/ When you first position the pasted selection, don’t 
worry about things like the man’s exposed hair here – that 
can be fixed.

5/ Tools in the Gimp Toolbox help you scale and flip 
concealing patches. 

6/ The left patch is blended up to the neck and head so 
that the shadow behind it will show between the ear and 
head of the dog.
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1/ The white background for the dog will make it easier to 
create a selection from that photo, so the merge will be 
from the dog image on to the man.

2/ The man and the dog are both lit from roughly the 
front, so are a good fit for this project. Here I used the 
Curves dialog and desaturation to test their compatibility.

and tags. The selection isn’t exact along the neck and tags at this 
point – the excess is what we’ll use to merge with the other 
image later.

Shrink the selection by one pixel (Select > Shrink) and 
feather it by three (Select > Feather) before grabbing a copy of 
it (Ctrl+C or Edit > Copy) and pasting it into the image of the 
man (Fig 3).

Position the dog’s head over the man’s using the Move tool. 
Clicking the visibility icon (circled in red in Fig 4) of the dog layer 
on and off helps with positioning by letting you see the best 
position in relation to the man’s suit. I’ve positioned the dog’s 
nose over the man’s nose and mouth because that lets the dog’s 
collar align nicely with the shirt collar. The head was flipped 
horizontally using the Flip transform tool to let the tags better 
hang away from the tie. But because the dog’s head is 
proportioned differently from the man’s, it needs to be made 

thinner and shorter using the Scale Transform tool. Before 
finishing this step, add a layer mask to the dog layer.

Removing the hair
The man’s head is exposed above the dog’s, so we need to apply 
some patches to remove it. We’ll actually create two square 
patches, both with layer masks. To draw them, turn off the 
visibility of the dog layer, and create a rectangular selection over 
the right-hand side of the man’s head. With the Rectangular tool 
still active, hold down Shift (or possibly Alt+Shift depending on 
your desktop configuration) and drag the selection to the right. 
Copy the selection (Ctrl+C), then move the selection back over 
the head, paste the selection (Ctrl+V) and make it a new layer 
(Layer > New). 

Fig 5 shows the process in detail. Click on the Scale 
Transform tool [1] to make it active. Click on the layer and 

Transparency gems
■ Use layer masks instead of 
the Eraser tool – they allow 
you to undo changes long 
after you’ve saved them. 
■ Soft-edged brushes will 
smooth edges when 
merging layers. 
■ Use smaller brushes for 
finer detail when working 
with masks. 
■ Selecting odd-shaped 
objects in an image works 
best if the background is 
nearly uniform in colour. 
■ Reduce the opacity of a 
layer when merging with the 
layer below so that you can 
see where to paint in the 
layer mask.

QUICK TIP

>>

21
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>> drag to the right to stretch the width of the layer. Hit Enter to 
complete the scaling. Flip the layer horizontally with the Flip tool 
[2]. Repeat process for the left-hand side. 

You’ll have two layers of patches. Make sure the two patches 
overlap a bit. Blend the edge of the top patch with the other 
patch by adding a layer mask and airbrushing the edge in the 
mask. Do the same thing to all the other edges of both layers so 
they blend seamlessly with the background in the man’s layer 
(Fig 6, previous page). 

When the patches are blended cleanly, merge the patches 
and the man’s layer into a single layer (Layer > Merge Visible 
Layers). Remember: the dog layer should not be visible when 
you do this! After this the dog layer should be on top once again 
(if it wasn’t already).

Merging the collars
All that’s left is to merge the dog’s neck and collar with the 
background. This is done by using the Bucket, Paintbrush and 
Airbrush tools to spray black into the dog’s layer mask. This is a 
bit time-consuming and requires changing brushes often. 
Unfortunately it’s a manual task that cannot be made much 
simpler. But you can use one important trick: using any paint tool 

7/ When merging, start with a large brush – I used the Circle Fuzzy (76) brush here. Use 
smaller brushes for finer detail work in the mask.

8/ No dogs were harmed in the making of this image. We 
had to decapitate the male model, though.

 PART 2 – MULTIPLE MERGERS

This next project is a little easier. Again, we’re using 
transparency, and only one mask. In fact, I’m going to break one 
of my golden rules: don’t remove layer pixels. Normally I add 
transparency only using layer masks so that if I need to make 
changes later I just need to modify the mask – the layer content 
is still intact. But not this time. I want to create an image that 
shows a laptop whose screen shows the background (behind the 
laptop) and another laptop, which shows the background and 
another laptop, and so forth. For an added kick I’ll desaturate 
the background in alternating laptop screens.

I call this an ‘infinite reflection’ because it’s similar to holding 
one mirror in front of another, each reflecting the other off into 
infinity. Again, the original images (Fig 1) were bought online.

The first step is to scale the laptop to fit comfortably inside 
the background image. Select the white background (this project 
is made very simple by having the laptop on a nearly solid white 
background) using the Fuzzy Select tool. Grow the selection by 

two pixels (Select > Grow) and invert it (Select > Invert). Finally, 
feather the selection (Select > Feather) by three pixels. It’s now 
ready to be cut (Ctrl+X) and pasted (Ctrl+V) into the background 
image as a new layer (Layer > New) after you’ve pasted it.

Use layer guides to outline the laptop screen, and the 
Rectangular Selection tool to create a selection. Again, grow this 
selection by two pixels and feather it by three. Then – and here’s 
where I break my normal rules – cut the screen from the layer 
(Edit > Cut) (Fig 2). Remove the Guides (Image > Remove All 
Guides, assuming you’re using Gimp 2.2 or later).

I’ve centred the laptop and made it fit most of the height of 
the background. Now it’s time to add the ‘reflecting’ laptops. 
Duplicate the laptop layer (Layer > Duplicate Layer) and shrink 
by 60% (Layer > Scale). The Scale Layer dialog has a menu that 
defaults to pixels but can be changed to per cent, so you can 
enter ‘60’ in the width and height fields. Centre each layer inside 
the screen of the laptop on the previous layer (Fig 3).

you can click in one spot, move the mouse to another, hold the 
Shift key down and click again. This will draw a straight line 
between the two click points. This little trick can be used 
repeatedly along any edge – especially when used with soft-
edged brushes – to cleanly merge the current layer with those 
below it.

Remember to reduce the opacity of the dog layer while you 
paint in the mask. This makes it easier to see what you need to 
mask out. Once you’ve merged the collars, the masterpiece is 
complete (Fig 8).
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NEXT 
MONTH

In LXF70 we’ll take on that dentist’s 
project: clean up the teeth, fix 

alignment and improve the 
smile – all without 

painkillers! 
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3/ The amount that you scale each layer will depend on the 
size of your images and the number of laptop layers you 
add. Smaller percentages may be needed as you add layers.

4/ The desaturated, duplicate layer lives just above the 
background and is our default background. 

 5/ Masking a laptop screen. Use Ctrl+Shift+A to remove 
the selection.

6/ Finito! 
With careful 
cutting we 
have been 
able to use 
just one 
mask.

1/ The starting images. The idea for the project was 
suggested by another image I found in the image library. I 
decided it would be fun to try to reproduce it.

2/ Pasted in as a new layer, the laptop then has its 
screen removed.

The next step is the real trick in this project. I want to 
alternate colour and desaturated versions of the background 
with each laptop screen. To do this, we need add only one 
additional layer – a desaturated version of the colour 
background (Fig 4). This becomes the default background and 
we’ll punch holes in it using the layer mask to let the colour 
background show through. To this we add a layer mask.

Make the first laptop (the original laptop layer) active by 
clicking on its name in the Layers dialog. Click on the Fuzzy 
Select tool to make it the active tool. Make sure Select 
Transparent Areas is set, then click inside the laptop screen area. 
This creates a selection that can now be used in the desaturated 
layers mask. With the selection in place, click on the desaturated 
background layers mask in the Layers dialog. 

Fill the selection with black by dragging the default 
background colour (in other words, black) into the selection. This 
creates a hole in the desaturated area letting the colour 

background show (Fig 5). Repeat the 
selection process for the next laptop 
layer, this time filling the selection in 
the mask with white. This removes 
part of the hole. Alternate this 
process with each laptop layer. 

In the end, you have a single 
mask with multiple holes in it 
allowing the colour background to 
show through in selected laptop 
screens (Fig 6).

Kinda cool, eh? LXF
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