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реДаКтИрОваНИе ИллЮСтраЦИй И ИЗОБраЖеНИй

Gimp инструменты выделения
майкл Хэммел (Michael J Hammel) сравнивает новейшее средство Foreground Selection с достопочтенным quick Mask.

в мире свободного ПО свой отсчет времени; проект Gimp – 

не исключение. Недавно разнесся слух о скором выходе 

новейшей версии, Gimp 2.4.  Действительно ли грядет это 

событие, пока не ясно. Несомненно одно – в арсенале Gimp, среди про-

чих новинок, появится любопытный инструмент Foreground Selection – 

интегрированная версия сравнительно нового модуля SIOX для Gimp 

2.2. 

Проект SIOX (Simple Interactive Object eXtraction – Простая интерак-

тивная выемка объектов) предусматривает создание ПО для упроще-

ния процесса отделения объектов на рисунках от их окружения (графи-

ческой выборки). Gimp уже обладает средствами для решения этой 

весьма востребованной задачи – именно для нее был создан инстру-

мент Scissors, Ножницы. Действует он сравнительно неплохо, но 

быстрым его не назовешь: выборка сложных графических объектов 

требует назначения большого количества контрольных точек, а редак-

тировать эти точки не так-то просто. Зато, вооружившись терпением 

и временем, вы получите отменно точную вырезку.

Для той же цели предназначен еще один инструмент  – Quick 
Mask. точность вырезки при работе с ним ограничена единственно 

вашей способностью аккуратно очертить контур. Пользоваться Quick 
Mask проще, чем Scissors, поскольку можно переключаться между 

маской и вырезкой и уточнять ее. в принципе, очертить контур намного 

легче, чем назначать уйму контрольных точек.

Итак, инструментов для графической выборки хватает. Почему тог-

да мы говорим о появлении новых? Да потому, что разработчики Gimp 

постоянно ищут способы усовершенствования программы. вы спроси-

те, не станет ли Foreground Selection одним из таких улучшений? 

в процессе урока я как раз и собираюсь ответить на этот вопрос. 

Я буду сравнивать простоту использования Foreground Selection 

и Quick Mask и доступную для них точность вырезки при работе 

в комбинации с другими средствами Gimp. Объектами послужат 

несколько образцовых изображений. Следуя за мной, шаг за шагом, 

вы незаметно для себя освоите ценные технологии графической 

выборки! 

From a wormhole in deep space 

(well, LXF73), I showed you how to 

create animated fractals. If you 

missed the issue, call 0870 8374773 

or +44 1858 438795.
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ЧасТь 1 - ПросТое ВыДеление на оДноТонном Фоне
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Чтобы сравнить инструменты Foreground Select и Fuzzy Select из инструментария Gimp 2.2,  поработаем с изображением розы на белом фоне.

повышение порога
решив подобраться к розе поближе, я отменил выделение (Ctrl+Z) и по-

высил порог до 75,0. Затем оценил результат. Последняя попытка с по-

рогом 105,0 дала отличную вырезку – вот уж поистине метод проб 

и ошибок! Чтобы вместо фона выделить розу, я инвертировал выделе-

ние (Select > Invert – выделение > Инвертировать).

делаем приблизительное выделение
При выборке с помощью Foreground Selection нужно предварительно 

очертить мышью выбираемый объект в окне программы. Указатель 

мыши будет выглядеть точно так же, как в инструменте Free Select – 

Свободное выделение. Щелкаем и обводим рукой контур вокруг нуж-

ного нам объекта – разрешается выходить за пределы окна изображе-

ния, чтобы руке было удобнее.

• Пользуясь Quick Mask, можно 

сколько угодно раз переключаться 

между маской и вырезкой для под-

чистки. Ни один известный инстру-

мент не дает такой простоты и сво-

боды для этой операции, даже 

новейший Foreground Select.

• Для отмены сделанной вами 

выборки воспользуйтесь стандарт-

ным откатом [Ctrl]+[Z], попробуй-

те изменить настройку инструмен-

та, затем начните сначала. такая 

возможность есть у любого средс-

тва выборки, исключая Quick 

Mask (которому для подчистки 

просто не нужна настройка 

параметров).

• Когда вы отпустите кнопку мыши, 

Foreground Select немедленно 

обновит вашу вырезку. Поэтому не 

отпускайте кнопку, пока не закра-

сите большую часть нужного вам 

объекта. Для подчистки можно 

неоднократно возобновлять 

закрашивание.

• Когда вы закрасите вырезку, 

поместите курсор в окно изображе-

ния и нажмите клавишу ввода. 

Синее пространство превратится 

в реальную выборку.

ПоДсКазКа

Как работает Fuzzy Select
Инструмент Fuzzy Select (по виду напоминающий волшебную палочку) 

выделяет смежные точки, попадающие в определенный диапазон. 

Превосходный способ отделить от рисунка практически 

монотонный фон!

параметры Fuzzy Select
Параметр Threshold – Порог – в диалоговом окне настройки определяет 

предварительный контур. Чем выше порог, тем точнее вырезка. 

в нашем примере было установлено значение порога 25,0. После щелч-

ка мышью на фоновом участке получилась приличная, хотя и не иде-

альная, вырезка.

Как работает Foreground Selection
Значок Foreground Selection на панели инструментов Gimp имеет вид 

человеческой фигурки, окаймленной контуром из точек. в диалоговом 

окне Tool Options – Параметры инструмента – есть два интересующих 

нас элемента управления: кнопки смены выделения объекта/фона 

(Mark Foreground/Background) и ползунок изменения размера кисти. 
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ЧасТь 2 – ВыДеление изоБражения на сложном Фоне

уточнение выделения
По умолчанию кнопка смены выделения объекта/фона стоит в положе-

нии Mark Foreground – Выделение объекта, я не стал его менять. 

Кисть не должна быть толще стебелька розы внизу изображения. Цвет 

кисти я выбрал зеленым, для большей наглядности следующего шага. 

теперь закрасим кистью розу вместе со стеблем.

вторая попытка с Mark Background
Я не сумел захватить весь стебель розы! Однако я попробовал выбрать 

розу непосредственно с помощью Foreground Select, выделив фон 

инструментом Fuzzy Select. во второй попытке после проведения Free 
Select (Свободной выборки) я включил выделение фона (Mark 
Background), потом закрашивал только белые участки.

Берем Quick Mask
Картинка здесь посложнее, зато мячи проще вырезать. На успех Fuzzy 
Select рассчитывать не приходится: мячи лежат чересчур близко друг 

к другу. вдобавок они не очень-то отличаются по цвету от фона и от 

ракетки. вероятно, Quick Mask из набора инструментов версии 

2.2 будет лучшим выбором.

Закрашиваем вырезку
Нажмите кнопку Quick Mask. ваше изображение примет красный отте-

нок, кнопка тоже покраснеет. Красное пространство в выделение не 

попадет. Перекрасьте кистью (Paintbrush) участок, который хотите 

выделить, предварительно сделав цвет краски (Foreground) белым – 

нажмите [D] (цвета по умолчанию) и [X] (инвертировать цвета).

Настройка чувствительности
Понятно, что результат обязан быть значительно лучше, поэтому я про-

бовал снова и снова, при помощи ручной выборки и выделения фона 

(Mark Background). Затем я включил параметр Feather – 

Сглаживание – и сдвинул все три ползунка регулировки чувствитель-

ности (Sensitivity) до отказа вправо. Как видите, качество вырезки 

значительно повысилось, но можно улучшить и этот результат, сузив 

выделение на 1-2 пикселя перед вырезанием и вставкой.

результат для этого конкретного изображения нельзя признать хоро-

шим. Быстрая и грубая работа с Foreground Select давала некачест-

венное выделение, пока я не взялся за настройку чувствительности. 

Для такого простого случая Fuzzy Select следует признать более быст-

рым и точным средством.

С простой задачей Fuzzy Select справился лучше. теперь посмотрим, кто победит при работе с более сложным изображением.
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проба SIOX
Foreground Select в Gimp 2.4 работает немного лучше, но постоянно 

прихватывает лишние участки. рисунок запечатлел четыре разные 

попытки работы с этим инструментом. в последней из них удалось 

показать ворс на мячике – для Quick Mask подобное почти 

невозможно.

играем с картинками
Перебрав еще несколько изображений, я нашел то, в котором, на мой 

взгляд, Foreground Select проявил себя очень неплохо. Однако раз-

работчики SIOX говорят, что при работе в режиме Mark Foreground, 

нежелательно, чтобы пиксели фона и вырезки имели сходные цвета. 

в случае выделения кофе в чашке могут возникнуть проблемы.

выделение фона
Как обычно, выбираемый объект очерчивается по контуру от руки. 

Я провел черту, начав ее вне окна изображения, снизу вправо, и вывел 

ее снова в окно справа наверху. Затем я закрасил чашку широкой кис-

тью со сглаживающим фактором четыре. в вырезку попал только 

маленький кусочек фона, слева внизу.

уточнение выделения
включите выделение фона (Mark Background) и закрасьте нежела-

тельные участки фона для их удаления. Quick Mask могла бы сгла-

дить ободок чашки так же быстро.
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Images used in this tutorial are from 

BigStockPhoto.com and the free 

collection at PDPhoto.org.

CREDIT TO...

вставляем в другой слой
Оценим выделение, скопировав объект и вставив его в новый слой. На 

контрастном черном фоне виднее контур мяча. Для редактирования 

выделения вернем маску на место (Layer > Alpha To Selection – 

Слой > Прозрачность в выделение), возвратимся в первоначаль-

ный слой, включим Quick Mask и закрасим заново.

подведем итоги
Итак, что же дает сравнение двух средств, старого и нового? 

в нынешнем виде Foreground Selection не особо упрощает задачу 

извлечения объекта из изображения, по сравнению с существующими 

инструментами. С другой стороны, изображения бывают разные, 

и иметь несколько инструментов для разных задач отнюдь не 

повредит.

Поймите меня правильно, я не отрицаю, что Foreground Select 
имеет значительный потенциал. Обратите внимание, что в случае 

с изображением чашки кофе (там, где программа смогла блеснуть спо-

собностями) я сделал вырезку меньше чем за минуту. Но отнюдь не 

очевидно, где почва для наилучшего применения программы. 

Инструмент может делать хотя и не идеальную, но очень хорошую 

выборку. весьма способствует результату работа над параметрами. 

И не забудьте, что ко времени официального выхода версии 2.4 инстру-

мент Foreground Selection может реально измениться (я пользовался 

версией Gimp 2.3.4 для разработчиков) – не спешите соглашаться с мо-

ей критикой. LXF
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реДаКтИрОваНИе ИллЮСтраЦИй И ИЗОБраЖеНИй

Gimp создание трехмерной упаковки
Хотите красиво упаковать товар? майкл Хэммел (Michael J Hammel),пользуясь инструментом Perspective, 
укажет путь от замысла до опытного образца.

Не сомневаюсь, что, прочитав предыдущий номер журнала, 

вы собрали собственный дистрибутив Linux и уже подумы-

ваете, как бы завалить им полки компьютерных магазинов 

по всему миру. Но как убедить магазин в том, что продажи обеспече-

ны? Поможет  3D-портрет коробки для вашего продукта, да не простой, 

а созданный в Gimp, – прекрасное средство убеждения.

в Gimp существует несколько способов создания иллюзии объема. 

Чаще всего это отбрасывание предметами теней. тени предполагают 

освещение, что и придает изображению глубину. Но глубина  имитиру-

ется только за счет помещения одной плоскости над другой: тени не 

придают объема самой плоскости.

К счастью, имитация освещения – не единственный доступный 

способ. Другой вариант – использование перспективы. Инструментом 

Perspective из набора Gimp вы можете изменить угол зрения таким 

образом, что объект будет выглядеть продолжающимся вглубь экрана 

или повернутым на некоторый угол.

Изменения перспективы – ключ к созданию объемных объектов в 

Gimp. в процессе урока я продемонстрирую создание трехмерного 

изображения упаковочной коробки. Сделаем ее пока для мобильного 

телефона, а не для нового дистрибутива (главным образом потому, 

что надпись «КрутойДистрибутивMichaelJHammelCoolLinux» на такой 

коробке не поместится). Я покажу вам, как, взяв стопку обычных кар-

тинок, разместить их на передней и боковых сторонах коробки, 

выровнять боковые стороны и установить коробку под углом к наблю-

дателю. Как и во многих проектах, львиная доля работы – это поиск 

подходящих изображений, а перспектива – всего лишь трюк для их 

оживления.

в этом учебнике я займусь лишь фазой создания прототипа объ-

емного предмета, поэтому в результате получится изображение с web-

разрешением (72 dpi). Gimp способен создать и версию для печати, 

нужно только подобрать план-раскладку. Не вдаваясь в детали, упомя-

ну только, что основа печатной версии – именно план: боковые сторо-

ны, верх/низ, передняя/задняя стороны, как одно большое изображе-

ние. его можно сделать с помощью направляющей сетки и контуров 

всех картинок – контуры помещаются на прозрачные слои, чтобы было 

видно, куда какая картинка попадает. Не забудьте предварительно уста-

новить правильное разрешение (разрешение по умолчанию в 72 dpi 

годится только для просмотра на компьютерном мониторе!).
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выравнивание изображений
Подыщите изображения для своего продукта: лично я  купил их у BigStockPhoto.com. 

Откройте новое окно изображения (холст), используя шаблон US Letter, только разреше-

ние смените на 72 dpi. Подгоните размеры картинок так, чтобы ширина каждой составля-

ла примерно половину нового холста. Скопируйте стопку изображений на холст как новые 

слои, расположив телефон слева, а девушку справа – вручную или через меню Layers > 
Align Visible Layers (Слои > Выровнять видимые слои).

Затем выделите фоновый слой в диалоговом окне Layers (Слои) и добавьте вертикаль-

ную направляющую высотой 50% – Image > Guides > New Guide By Percent 
(Изображение > Направляющие > Новая направляющая в процентах). выделите 

слой телефона, добавьте белую маску слоя, затем  инструментом прямоугольного выде-

ления создайте вырезку, справа от направляющей, на высоту изображения телефона, как 

показано на рисунке.

Центровка изображений
Находясь на холсте, нажмите “D” для смены цветов фона и изображения на черный и 

белый соответственно. Перетащите цвет изображения (черный) в вырезку – заполнится 

секция в слое телефона. Нашей целью было оставить одинаковые просветы с обеих сто-

рон телефона во время его центровки в своей половине окна. фото с девушкой центриру-

ется в другой половине.

подчистка
Белая бретелька бюстгальтера девушки явно отвлекает внимание. Можно ее закрасить, но 

мы пойдем другим путем – прикроем ее прядью волос девушки. Щелкните мышью в слое 

девушки для его активации, увеличьте изображение, затем инструментом Free Select 
(Свободное Выделение) захватите прядку побольше. растушуйте вырезку на 3 пикселя, 

скопируйте и вставьте как новый слой. Перемещайте его в стопке, пока он не окажется 

прямо над слоем с девушкой и не прикроет бретельку. Добавьте маску слоя и поработайте 

аэрографом, для маскировки места соединения. в завершение, объедините оба слоя 

Layer > Merge Down (Слой > Объединить видимые слои).

выбор цвета коробки
Щелкните на белом фоновом слое, затем в квадрате Foreground Color (Цвет передне-
го плана) на Панели инструментов, – открoeтся диалоговое окно Выбор цвета 
переднего плана. в HTML-поле введите “06069b” и нажмите OK для принятия измене-

ний. Перетащите квадратик «Цвет переднего плана» на новый слой. вы получите 

синюю полосу по верху коробки. Синий цвет мы назначили, введя шестнадцатеричный 

код HTML: в коде “06069b” 06 отведено для красного, другое 06 – для зеленого и 9b – 

для синего. Здесь 0 означает наименьшую насыщенность, а F – наивысшую. Чтобы 

узнать об этом больше и выбрать собственные цвета, посетите www.htmlhelpcentral.
com/hexcolors.php.
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добавим название продукта
Щелкните на текстовом инструменте в панели. Находясь на холсте, нажмите “D” и “X” для 

переключения цветов фона и переднего плана. выберите подходящий шрифт и кегль –  в 

моем заголовке это Nimbus Roman №9 L полужирный, 72 пункта. Щелкните на холсте, 

чтобы открыть окно редактора текста и введите название продукта – ”Nekioba VXS-1756” 

(правда, броско?) перед центровкой слоя текста вручную инструментом перемещения. 

Добавьте еще один текстовый слой с пояснительным текстом помельче. Сохраните это 

изображение как front.xcf, затем растушуйте его – Image > Flatten Image 

(Изображение > Растушевать).

создание боковых сторон
Нашей коробке нужны боковые стороны, поэтому откройте новый холст, тоже по шаблону 

US Letter с разрешением 72 dpi. Уменьшите холст до 3 дюймов в ширину, а высоту 

оставьте прежней (11 дюймов). Щелкните на квадратике «Цвет переднего плана» в 

Панели инструментов и выберите синий цвет, назначенный нами для лицевой стороны. 

Закройте диалоговое окно и перетащите цвет изображения на новый холст. При желании, 

для большего эффекта добавьте еще одну картинку внизу, как это сделал я.  

Закончим работу с текстом
Нажмите “D” и “X” для переустановки цвета изображения на белый. вызовите с Панели 

текстовый инструмент. Снова выберите шрифт для своей надписи. Я взял Nimbus 
Roman №9 L полужирный, 25 пунктов. введите тот же текст, что на лицевой стороне 

(или любой другой по вашему вкусу). Поверните текст на 90 градусов против часовой 

стрелки – Layer > Transform > Rotate 90 CCW (Слои > Преобразование > 
Повернуть на 90 градусов [против часовой стрелки]). Инструментом перемеще-

ния, вручную передвиньте текст на синее пространство холста. Сохраните изображение 

как side.xcf. Сделайте его матовым (Image > Flatten – Изображение > Матовость), 

затем уменьшите до 80%.

сборка коробки
введите “D” в Панели инструментов для переустановки фонового цвета на белый, затем 

откройте новый белый холст по шаблону US Letter. Скопируйте и вставьте боковую и лице-

вую стороны коробки в этот новый холст как новые слои – Layer > New (Слои > Новый). 

теперь совместите их: передвиньте вертикальную направляющую левой линейки вправо на 

три дюйма, а горизонтальную с верхней линейки опустите вниз на один дюйм. теперь 

выровняйте верхний и левый края лицевой стороны по пересечению направляющих. то же 

самое, но зеркально, выполните для боковой стороны. если боковая или лицевая стороны 

не помещаются на холсте – пускай, пока это не страшно. Просто нажмите один раз клавишу 

[минус] – изображение уменьшится – для упрощения работы с холстом.
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инструмент «перспектива»
Магия начинается! Передвиньте вторую вертикальную направляющую слева направо на 8 

дюймов – здесь будет правый край лицевой стороны. Убедитесь, что лицевая сторона 

активна, щелкнув на ее слое в диалоговом окне Слои. выберите инструмент  Perspective 

(Перспектива) в Панели инструментов, затем щелкните на холсте. Сдвиньте контроль-

ные точки правого края внутрь, к 8-дюймовой направляющей и слегка к середине гори-

зонтальной оси холста, как показано на рисунке. Для закрепления изменений нажмите 

кнопку Transform (Преобразовать) в информационном диалоговом окне инструмента 

Перспектива.

повторим…
Получилась естественно уходящая вдаль лицевая сторона;  сделаем то же самое с боко-

вой стороной. Для изменения левого края боковой стороны сдвинем вертикальную 

направляющую от левой линейки вправо на 1,5 дюйма. активируем слой боковой стороны 

в диалоговом окне слоев. Затем снова выберем инструмент Перспектива в Панели 
инструментов и щелкнем на холсте. Передвинем контрольные точки левого края боко-

вой стороны внутрь, к 1,5-дюймовой направляющей и слегка к середине горизонтальной 

оси холста, как показано на рисунке.

9 10

размывание краев
в диалоговом окне слоев выберите слой лицевой стороны (кнопка Keep Transparency – 

Сохранить прозрачность – должна быть отжата). Для выравнивания зазубренного ниж-

него края лицевой стороны инструментом прямоугольного выделения проведите черту от 

средней направляющей до правой. выберите инструмент Shear (Отсечь) и в диалоговом 

окне его настройки установите Affect (Воздействовать) на выборку. Щелкните на холсте 

и поднимайте мышью правый край линии выделения, пока линия не станет параллельной 

нижнему краю лицевой стороны. Нажмите Shear (Отсечь) в информационном окне инс-

трумента. теперь поднимайте выборку инструментом Перемещение, пока она не пере-

кроет нижний край лицевой стороны. в фильтре Gaussian Blur установите для выборки 

размытие RLE 4,5 пикселя. Повторите процесс для остальных краев.
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череЗ 
месЯЦ

Мы сделаем постер в стиле научно-
фантастических фильмов – пригла-

шение на университетский вечер 
с родителями. 

добавим тень
Удалите направляющие – Image > Guides > Remove All Guides (Изображение > 
Направляющие  > Удалить все направляющие). выделите вер-

хний слой и объедините его со следующим – изображения 

лицевой и боковой сторон совместятся в одном слое, а 

фоновый останется отдельным. Последний штрих – 

добавление тени (Script-Fu > Shadow > Drop 
Shadow – Скрипт-Фу > Тень > Падающая тень) с 

параметрами 0 пикселей по оси X и 12 пикселей по 

оси Y (то есть тень падает прямо вниз).

Ну как, впечатляет? LXF




