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TUTORIAL First Steps: Kino

FIRST STEPS VIDEO EDITING SERIES

Kino Burning video to DVD
 PART 3  The end is in sight. After ripping and editing his film, Andy Channelle works up to the final 
presentation of Sports Day: The Director’s Cut to a ravenously expectant public.

In the last two issues of Linux Format we covered the 
process of grabbing raw digital video via FireWire, 
cleaning up the start and end points of individual clips, 

assembling a selection of scenes and adding transitions, effects 
and a few titles. Now comes the difficult bit: exporting the entire 
project from Kino – the open-source editing package – and 
burning a DVD that you can watch on the telly.

Unfortunately, free software in this sector isn’t very mature, 
so some of the procedures here will be a little more complicated 
than previous tutorials, and some will even require you to use 
the command line – but where a graphical tool exists, we’ll use it.

In LXF65 we mentioned some of the tools needed to put 
the package together, and it’s worth our while to revisit these 
requirements and ensure that we have the latest stable versions. 
First on the list is Kino itself, which has been updated since the 
beginning of our tutorial and now stands at version 0.75-5. This 
is mainly a bugfix release, but does include a few cosmetic 
refinements. You will also need the package dvdauthor – which 
is included in most distributions – for creating a DVD structure; 
and a package called mjpegtools, which provides the options for 
encoding the video and audio to the correct format. It’s also 

worthwhile making sure you have LAME (the MP3 encoding 
package) installed in case you need to do some audio encoding. 

We’ll be using K3b to burn the final CDs and DVD and we’ll 
need to augment this with the VCDImager package for burning 
video to (S)VCD, and dvd+rw-tools, which will burn to DVD.

DV output
We have assembled our sports day production, rendered effects 
and transitions and watched the final project through in Kino’s 
Edit tab to make sure there are no glitches. It’s finally time to 
output everything for wider distribution. Most of the options 
available in the Export tab rely on the mjpegtools package, so 
either install it from your distribution’s discs or download the 
RPM from http://sourceforge.net/projects/mjpeg. 

There are a number of options available: you can output 
video to send back to your DV camera (if the hardware 
supports it); create a new DV file for email or web use; or burn 
it on to VCD (Video CD) or DVD. Writing the project back to DV 
tape might be an option for those without CD/DVD burners or 
who need to record on to standard video. If the FireWire system 
is working correctly it should simply be a case of plugging 

The First Steps tutorial in 
LXF66 used Kino to trim video 
footage and sort the running 
order of sports-day scenes. 
If you missed the issue, call 
0870 8374722 or +44 1858 
438794 for overseas orders.
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everything in, hitting the export button and watching the result as 
it steams to the camera, but check your camera’s documentation 
before trying to do this. There are a couple of options to play 
with, but we’ve had perfectly acceptable results with the defaults. 
However, we want to output files suitable for playback on 
domestic DVD players, and that means VCD (or SuperVCD, 
SVCD) for those with CD burners and DVD for DVD burners.

VCD is an intermediary format that allows for playback of 
video from CDs (hence the name) on DVD players. Not all 
players support the format, so check yours before taking the 
time – and it does take some time – to transcode the file. A 
conservative estimate would be to allow at least twice the 
length of your movie for the transcoding process – and this on 
a fairly recent CPU. VCD provides facilities to burn about 70 to 
80 minutes of video and stereo sound to a plain old CD-R, and 
the quality is comparable with VHS. By using SVCD we can 
improve the quality (resolution is 480x576 pixels as opposed to 
VCD’s 352x288) almost as far as DVD standard – but this 
reduces the available time to around 35 minutes. SVCD is also 
capable of rendering menus, subtitles and two independent 
stereo audio tracks, but that is all a little beyond our 
requirements at the moment. 

Our production lasts just 12 minutes and so is perfectly 
suited to SVCD – and that’s what we’ll be using. Again, the 
defaults should be adequate for our needs (and changing them 
would require a deeper understanding of the capabilities of 
mjpegtools) so we will be leaving them as they stand.

Once the video is encoded, we have to burn it on to a CD for 
playback, so launch K3b and select File > New Project > New 
Video CD Project. We can now simply drag our MPEG file into 
the Project window and hit Burn. Play the file back using either 
Xine or MPlayer before you get to the burning stage – just to 
make sure you won’t be making shiny coasters instead of movie 
magic. Just do File > Open and navigate to the correct file.

The next step up in quality means outputting to DVD, and 
we start this process by selecting 8 – DVD from the file format 
drop-down in Kino’s Export tab. There is also an extra option for 
DVD output in this dialog – Output Dvdauthor XML – which will 
render an XML file that dvdauthor will be able to read and that 
can be used to build up the correct file format for burning.

Set the location for the final file, hit the Export button and 
sit back. Creating this file will take longer than the SVCD, which 
took just over half an hour to process our 12-minute-long video.

At its simplest, we can create a playable DVD by navigating 
to the location of the file we just created using the command 
line – cd /disks/D/Edited/Sports – and using the command

dvdauthor -o sportsday -x sportsday-dvdauthor.xml

Outputting to SVCD in Kino took just over half an hour.

Xine is useful 
for checking 
your video 
before and after 
burning the disc.

>>
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>> to create the files needed to add to a new DVD Video project in 
K3b. Don’t be alarmed if you don’t have anything in the folder 
AUDIO_TS: it just means that the file was ripped with an 
integrated audio stream. Again you can check the status of the 
process before the all-important burn by launching Xine and 
opening up the vts_x_
xx.vob (where x represents 
numbers relating to the 
chapters in your movie), or 
even by burning to a 
rewritable disc.

It is also possible to 
compile the necessary ISO 
file, which is the DVD image 
that is burnt to disc, using 
the command line. Just type
mkisofs -dvd-video -o 
sportsday.iso
where sportsday.iso is the 
name of your project, and 
prepare for a wait.

From Varsha with love
It’s no secret that the command line is not the most user-
friendly interface known to man. As we have just seen, it can be 
useful – but once we get beyond making a very basic DVD, 
working the command strings and configuration files can 
become more a feat of memory than of design skill. Though 
the standard of Linux DVD applications isn’t mind-blowing, 
there are a couple that are workable; one of which is Varsha. 
This is a Java-based front-end for many of the tools we have 
already used – dvdauthor, mjpegtools, etc – that lets you build 
up a menu visually.

The latest version of Varsha is available under the GPL from 
http://varsha.sourceforge.net as a very small downloadable 
JAR file. As an added bonus it also works as a front-end to a 
small application called dvd-slideshow (http://dvd-slideshow.
sourceforge.net), which allows for the creation of disc-based 
slideshows of your digital photos. Once the dependencies are 
satisfied – these are Java plus the programs specified over the 
last three tutorials – you can run Varsha by opening a terminal, 
navigating to the directory where it was downloaded or saved 
and typing java -jar varsha.jar. Jump quickly to the 
application by making a new shortcut and providing a full path to 
the JAR file. On my system, for example, the command string is 
java -jar/home/andy/applications/varsha.jar.

The stated aim of Varsha’s sole developer, Ram Mallappa, 
was to create an open-source application that would take 
MPEGs edited and encoded in Kino and burn them to CD 
or DVD – which, coincidentally, makes it just about perfect for 
our purposes.

Varsha sets up a blank 
project with the interface 
window divided into two 
panes. On the left should 
be a single folder icon 
labelled Disc; this is the 
root file of the DVD. On 
the right is a file browser, 
which we can use to locate 
the MPEG we recorded 
earlier. Simply dragging and 
dropping this file on to the 
Disc icon will cause Varsha 
to set up the most basic 
file structure necessary for 
playing back your 
production. You could then, 

in theory, hit the Write DVD button and wait for the result. In 
practice, though, there are a few things we need to sort out first.

Do Edit > Preferences to check everything is as it should be. 
There are four tabs in the dialog box:
∆ General Define project and temporary directories in here, 
and also set the correct device for the system’s DVD burner.
∆ Tools This is where you can tell Varsha where the various 
under-the-hood applications such as dvd+rw-tools and 
dvdauthor are. As standard they should all be in the /usr/bin 
directory, so if you deviate from this, make sure the correct path 
is next to each application.
∆ Video A nice simple option: 
NTSC or PAL. In the UK we use 
the PAL system, so select this. 
Countries using the NTSC 
system include the USA 
and Canada. 
∆ Diagnostics 
Handily, Mallappa 
has included a 
small utility that will 
check the status of 
your system to make 
sure the things that 

The price drop of DVD-writing machines over the past year has 
been simply astonishing. A device that just 12 months ago might 
have cost £200 can now be acquired for under £50. And the best 
thing is that device support is now just a case of installing it and 
booting Linux. As is becoming a habit, we picked up a dirt-cheap 
generic model for testing purposes, installed it and could burn a 
disc through Xandros’s file manager and K3b within minutes of 
rebooting the PC. Smart.

Here’s a quick rundown of the formats to look out for.
■ DVD+R/DVD+RW
The big backers of this format are Philips, Sony, HP and Dell. As 
with recordable CDs, media can be writable or rewritable – 
meaning that discs can be either burnt only once or overwritten 
several times. 

This is the best supported of the formats, and discs made using 
it (remember you have to buy specific discs for each format) are 
readable on most domestic DVD players and, of course, on your 
Linux box. Current standard capacity is 4.7GB.

■ DVD-R/DVD-RW
Technology thrives on competing ‘standards’, and this seems to be 
the reason that Panasonic, Toshiba, Apple, Hitachi, NEC, Pioneer, 
Samsung and Sharp would all like us to use this ‘minus’ format. 
Again, discs can either be written once or rewritable, and should 
play in most home players. Choosing between + and – isn’t too 
difficult as most devices work with both. However, on our last trip to 
the local disc emporium, DVD-R(W) was slightly more expensive 
than its positively monikered cousin. Standard capacity is 4.7GB.
■ DVD-RAM
The runt of the litter. Usually housed in a cartridge – which is so 
1980s – DVD RAM discs are rewritable, but only on special 
DVD-RAM drives. The advantage of the format is that discs (which 
technologically are closer to hard disks than CDs) can be used as 
though they were floppies or hard disks, and can be written to 
more than 100,000 times. The big disadvantage is that you have to 
buy a special device for both reading and writing, so your 
productions won’t be viewable on DVD players.

DVD BURNERS AND LINUX

Nick Veitch will be pleased 
to see us using the console 
to compile the ISO image.
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need installing are where they should be. Just hit Test and look 
for ‘OK’ listed against all the required apps.

Once this is done, you can drag and drop a Kino-created 
MPEG on to Disc, hit Write CD and Marty Scorsese’s your uncle.

Adding DVD extras
While ‘play and go’ is OK, Varsha can create quite complex 
DVD interfaces with static or animated backgrounds, menus 
for selecting different videos (once you have edited and 
exported more than one) and chapters for jumping 
back and forth through your work.

The easiest additions you can make to a single 
video are chapter points at specific intervals – you 
use this function when you jump backwards or 
forwards using the Skip Forward/Back buttons on 
the DVD remote. To put chapters into your movie, 
drop an MPEG file into your project, select it and open 
the Properties tab. Now just add a figure into the Chapter Every 
X Minutes option and hit Apply. 

You should be getting an idea of the file structure of DVDs 
by now. At the top is the disc; below this are titlesets and titles, 

and within titlesets are also menu 
elements. As an example of how this 

might be organised, imagine that in 
addition to Sports Day we also have 

The Making of Sports Day as a 
featurette. Both of these 

elements would be titles 
within the first titleset. We 
could do them as individual 

titlesets but if the project 
includes a menu, Varsha will 
not be able to handle more 

than one titleset.
To start, right-click the Disc 

icon and select Add Title. Now right-click on the new Titleset 1 
icon and select Add Title; do it again so that you have Titleset 1, 
Title 1 and Title 2. Now right-click on Titleset 1 again and select 
Add Menu. The final elements of the structure are menu items, 
so right-click on the Menu element and select Add Menu Item: 
repeat to create a second. Varsha’s project window should look 
like the grab to the right.

There are tons of ways that we can work with this very 
simple structure to make a decent-looking DVD front-end. The 
first thing we will do is add a pretty background (downloaded 
from www.digitalblasphemy.com). Select the Menu element 
and open the Properties tab. The first option here will let you 
set an animated background – which can be any MPEG2 file – 
but be careful of the file size and remember to set it to loop 

using the Loop Radio button on the bottom left. We’re going to 
use a non-animated backdrop, so we hit the Browse button and 
locate the file.

Next we edit the Menu Item elements to make them more 
meaningful. The two buttons we have will both be titled Menu 
Item by default, and they will overlap on the main window. 
Select each one in turn, use the Menu Item Text box to add a 
decent label (setting the font, size and style) and then position 
the text in a sensible, artistically-pleasing place on the screen 
with the keyboard’s arrow keys. You could also use an image 
here (think back to the Capture Still Image option in Kino for the 
creation of thumbnails) and choosing this will launch tools for 
selecting an image and positioning or scaling it to fit the design.

A menu obviously needs to point somewhere, so we can 
right-click on the Menu Item icons in the tree structure, select 
Jump To... and choose either of the two titles. Selecting either of 
these elements in the final DVD will cause the player to skip 
ahead to either Sports Day or The Making of....

First we need to configure each title. Right-click on Title 1 
and select Add Video. This will launch a standard file browser 
that you can use to navigate to the correct file. Do the same for 
Title 2. By the way, if you have dvd-slideshow installed, you 
could simply drag a folder full of photos on to a title and it 
would organise them into a slideshow automatically.

If you had a compilation of home videos, you 
could put each one in a separate title and add a thumbnail 
button for each one to the menu.

The final burn
We have a couple of options for output: either create an ISO 
file for later burning using K3b, in which case select DVD > 
Make DVD ISO Image (and you could burn said ISO from 
Varsha using DVD > Burn DVD Image To Disc) or, if you’re 
feeling adventurous, simply do DVD > Burn DVD! to do it all in 
one step. Varsha’s developer recommends doing test burns to a 
rewritable disc: you can also format the media from within the 
application using the Format DVD RW Disc option.

Over the last three issues, we have covered quite a lot of 
ground, capturing video from a DV camera, editing it into a 
good-looking production complete with effects and transitions, 
outputting the footage into a useable format and building up a 
decent DVD package. Though we’ve really only scratched the 
surface, the tools available are capable of quite sophisticated 
results – this is especially true of Kino. And though the Linux 
world is yet to get a DVD authoring package that will compete 
with iDVD on Mac or MySonic DVD on Windows, Varsha shows 
great promise. LXF

NEXT 
MONTH
Linux software can be 
updated quite often. And 
though there is something to 
be said for keeping an old, 
reliable edition of some 
software lying around on your 
hard disk, it’s much more fun 
to be running the latest, 
greatest version. Next issue, 
First Steps will look at a few 
of the ways you can keep on 
top of the situation by taking 
the fear out of upgrading.

When the Kino test page looks like this, you know you’re 
going in the right direction.

This is what your disc structure should look like before you add any content with Varsha.

“DRAG AN MPEG TO DISC, 
HIT ‘WRITE CD’ AND MARTY 
SCORSESE’S YOUR UNCLE.”
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