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TUTORIAL First Steps: Word processing

FIRST STEPS LINUX BEGINNERS SERIES

OpenOffice.org Word processing
Andy Channelle explores one-touch text formatting, image editing and more in OOo’s Writer. 

Most people use their machine for a very limited 
range of functions: web browsing, email and word 
processing are really the core computer activities. 

Linux is blessed with a good selection of excellent packages for 
all three of these. Late October saw the release of 
OpenOffice.org 2.0, the long awaited, feature-packed office suite 
that is one of Linux’s flagship applications. We’ll be looking at 
how to get the best out of OO.o 2.0 over the next few issues, 
starting with the word processing package, OO.o Writer. This has 
a vast number of features designed to make it easy to create 
simple pages or complex, good-looking documents. 

To show you as many of its features as possible, I will go 
through the process of writing an academic essay, but the 
methods used are equally valid for the creation of letters, 
reports, novels or ransom notes. We’ll also look at the file 
format options available and show you what to do if and when 
you’re forced to open and save documents in other formats, 
including the MS Word format. 

Page-ism
Before we can start our tutorial, we’d better select our page 
format. Writer can deal with a large number of page formats, 
ranging from the UK standard A4 and A5 to more esoteric 
sizes such as tabloid, letter, legal and various envelope sizes. 
These terms dictate the physical size of your document and 
must relate to the capabilities of your printer. While it is possible 

to design a page in letter size and print it to A4 paper, it sort of 
defeats the object of having a WYSIWYG word processor. 

Access the Page Format dialog via Format > Page, and 
select the option for the format you want from the Paper 
Format drop-down list. We’ll use A4 for our document. This 
dialog also has options for setting the orientation of a page (ie 
landscape or portrait), its borders and several other document 
elements. For now we just need to configure the page size (A4), 
orientation (portrait) and borders (2.54cm or 1 inch all round) 
before hitting the OK button.

Many word or desktop processing projects have some text 
elements that appear on every page; these include the title, 
author and page number. Traditionally, these are located at the 
top and/or bottom of each page. To add a header to the 
document, go into the Insert menu and select Header > 
Standard. On the image of the page, the main text frame will 
now have a single line at the top of the page. Anything added 
to this line will be repeated on each page. I’m going to add the 
title of the document and my name to the header and centre it 
on the page.

The equivalent of a header at the bottom of the page is 
called a footer. To add one, choose Insert > Footer > Standard. 
This, again, will create a new blank line at the base of the page, 
which is the ideal place to add page numbers. Click anywhere 
in the box, hit the Centre icon in the icon bar and then click 
through Insert > Fields > Page Number.

A tough-sounding topic was 
made easy as we created 
perfect partitions for a 
well-organised desktop. If you 
missed the issue, call 0870 
8374773 or +44 1858 
438795 for overseas orders.
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It’s perfectly feasible to start writing the document now, 
but we’re not going to. First, we’re going to set up a series of 
styles, which can be applied to common textual elements such 

as footnotes, quotations, headings, subheadings and plain old 
body text. It is with this last elements that we’ll start, as it will 
form the basic style from which the others will flow.
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PARAGRAPH STYLES

Create a paragraph style
Go into the Format menu and select Styles And Formatting (or just hit the F11 
key) to open up the Styles And Formatting (S&F) palette. There should be a 
range of styles already defined, and you can use or edit any of these; but we’re 
going to create our own so that we’ll have a finer degree of control. To start with 
a blank sheet, open the drop-down list at the bottom of the S&F palette and 
select Custom Styles. Right-click anywhere in the S&F window and select New to 
open the big styles dialog-box.

Choose your Next Style
The Organizer tab is where we define the new style’s name. Selecting the 
AutoUpdate option will cause changes made to a style to be cascaded through 
the document without manual intervention. The Next Style drop-down is quite 
clever, because it allows us to set what style the next paragraph (after the one 
that a style has been applied to) should adopt. For example, if we make the Next 
Style for Essay – Heading to be Essay – Body, after you’ve typed a heading and 
hit Return, Writer will automatically select the Essay – Body style.

Apply indentation and spacing
Next up is the Indents & Spacing tab, where we can set the line spacing (double 
in this example) and left, right and first-line indents. We’re setting up the main 
body text with no universal indents, but the beginning of the first line will be 
shifted over by one centimetre. The Register-True option in Format > Page > 
Page dialog snaps each line on to a invisible grid on the page. It’s very useful if, 
for example, you are printing on both sides of a page and don’t want to be able 
to see text from the front when reading the back, and vice versa.

Pick a font
The next option we need to be concerned with is the Font tab, which is where 
we define the font that will be used for each particular paragraph style. 
Importantly, this is also where you can set the language for each style – by 
default it will be set to the local language that was selected when OO.o was 
installed on your machine.

1 2

3 4

>> 
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>> 

Apply font effects
Other options in this dialog box include font effects, such as colour, underline 
style, weight and ‘relief’. Once you’ve gone through these options, hit the main 
OK button to save the style, then build styles for other recurring elements of 
your document. If you base one style on another, it will inherit changes made in 
the original style. To apply a style, insert the cursor into a paragraph and double-
click on the appropriate style in the Styles And Formatting palette.

Save the template
Once you’ve defined the paragraph styles and the headers/footers, we’ll have a 
single document that can be used as a template. Go to File > Templates > Save... 
and save the document in a sensible place with a suitably descriptive name. 
Then, to create a new document using this template, go to New > Templates And 
Documents and navigate to its location. Once opened it will have all the styles, 
headers/footers and any other extra details you added.

5 6

TABLES, IMAGES & FILE FORMATS

A good essay has a table or two to show off the writer’s 
brilliant data, and there are a number of ways to add tables to a 
document in OO.o Writer. The quickest is to use the table tool, 
the small ‘down’ arrow next to the table icon on Writer’s top 
toolbar. Hitting this button will display a small drop-down that 
enables us to pick the number of rows or columns needed in 
our table. Using this method will create a table (to our 
specifications) that will cover the width of the whole page; it will 
also launch the excellent Table palette to provide quick access 
to all the tools we might need. 

First and foremost on this palette is the Autoformat tool (the 
magic wand icon), which lets you create good-looking tables for 
a number of purposes with just a few mouse clicks. You can, by 
the way, make small adjustments to these Autoformat styles by 
hitting the More button, and choosing just how much of the 
style you’d like to adopt and how much you want to keep under 
your own control.

Once a table has been created there are tons of things that 
can be changed using just the Table palette. Add or remove 
rows and columns, change the background colour of the whole 
table or individual cells or even treat the whole thing as a basic 
embedded spreadsheet by hitting the SUM button.

You may notice, if you go into Table > Table Properties, that 
the width option is greyed out (the traditional sign that a tool is 
unusable). However, if you first left-click on the left or right edge 
of the table in question and change its position slightly, and 
then go into the Properties dialog box, the width option will be 
available and allow accurate control of the table size.

You can change the width and height of columns and rows 
respectively by right-clicking somewhere in one of the cells and 
doing Row > Height or Column > Width.

For the first time OO.o is capable of reliably using nested 
tables (tables within tables), which means that it can be used as 
a pretty good web editing application. This is especially useful if 
you need to write content for printing and viewing online. To 

create a nested table, simply select the cell you’d like to contain 
a table, then use the table tool mentioned above to insert the 
object. This can contain any content that OO.o is capable of 
importing (including more nested tables), and has all the usual 
table options available.

Picture perfect
On top of its excellent illustration tools, in version 2.0 
OpenOffice.org now boasts a capable and, crucially, intuitive set 
of bitmap editing facilities, as well as some new ways of working 
with pictures once they have been edited to perfection.

Writer imports pictures through the Insert > Picture > From 
File... or Scan options, and once the picture is on the page (it 
initially embeds it where the cursor was), it can be clicked and 
dragged anywhere. Each picture on a page, when selected, will 
display eight green handles for resizing. Clicking and dragging 
any of these will change the size of the image, and you can 
keep it in the same proportions (constrain its aspect ration) by 

■ For added security, save 
documents with a password. 
In the Save As... dialog, make 
sure the File Types option is 
open and a supported format 
selected (all of OO.o’s native 
file formats are fine). Then hit 
Save With Password.

■ OO.o has a gallery of 
objects such as backgrounds, 
sounds and icons for use on a 
website. See what’s available 
at Tools > Gallery, and drag/
drop items to your page.

■ You’re not restricted to a 
single cut/paste operation. 
The Paste dropdown (the 
little arrow next to the paste 
board icon) retains a long list 
of the most recently cut or 
copied items.

■ You can email a document 
using your default mail client 
simply by hitting the Envelope 
icon on the toolbar.

■ Almost any part of an OO.o 
document can be made into a 
hyperlink. Just select it, hit 
the Hyperlink icon (with the 
picture of the globe on it), 
and input the details.

■ Hyperlinks are not 
restricted to the web. Links in 
documents can go to anchors 
within the same document or 
completely different ones.  

QUICK TIPS

OO.o is a good option if you do a little 
web editing on the side.
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NEXT 
MONTH

Next time we’ll delve into OO.o 
Impress with some pointers on 

preparing the perfect 
presentation.
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holding down the Shift key as you move the handle.If, when you 
select an image, the Picture palette doesn’t appear, do View > 
Toolbars > Picture to open it.

Select an image in the document and hit the Properties 
button to launch the full image dialog. This has a wide range of 
editable options including links and borders, but all we’re going 
to go through here is making sure that the picture fits nicely into 
the page and is easy to work with.

The first port of call is the Type tab, in which we should 
choose the Keep Ratio option. This will ensure that when we 
come to move the picture around, we won’t inadvertently 
change its shape. We could also make some fine adjustments to 
the size of the picture if necessary, or to its position on the 
page. In the Options tab we could go one step further, and 
prevent any accidental changes being made to the image at all 
by using the Protect options, which can be set to protect any 
combination of Contents, Position or Size.

Like AbiWord (see our review on page 28) OO.o Writer has 
seen some serious attention put into its text wrapping 
capabilities. The Wrap tab is where you define how the text in 
your document flows around graphical elements (which can be 
either images or other frames). In previous versions of the 
software this was limited to very simple shapes, but now there is 
a new Contour option. Select this and the text will follow the 
contours of your image. 

What contours you say? Well, you need to add one – 
actually this involves changing the default contour, which is a 
rectangle that conforms to the dimensions of the image. Right-
click on the image and select Wrap > Edit Contour. This will 
open the image in a larger window with a ton of icons across 
the top. To get rid of the default contour, select the Workspace 
icon on the far left and then select the image. 

It’s now possible to define your own shape using the 
available tools, and these are Rectangle, Ellipse and Polygon. 
Once you have a basic shape, you can fine tune it by hitting the 
Edit Points icon about halfway along. There are options here to 
add, take away or move control points. 

If the image has a well-defined outline (if you’ve done a 
cutout in Gimp, for example), it’s possible to get a good contour 
using the Autocontour option, which is the fourth icon from the 
right in the dialog box. This will examine the shape of your 
picture and (to a certain, adjustable colour tolerance) make a 
bespoke contour. When you’re satisfied, hit the Apply button 
(furthest left) and set the Spacing in the regular contour box. 

These options are great for print productions, but the web 
side of the story has not been forgotten. Right-click on an 
image and select Image Map to launch the image map tool. 

Creating a client side image map – one in which all the 
hyperlink information is embedded within the image itself – 
involves selecting areas of the picture using the shape tools 
available, then assigning a link, frame reference (which frame or 
window the link should open in) and a text string that will 
become the tooltip. 

When viewed on the internet (or by another OO.o user) 
each pre-defined part of the image could link to different web 
pages. These links can also be associated with Java-based 
macros, but you – and any other reader – will need the Java 
Runtime Environment installed to make use of them.

Picking the file format
For some people, distributing or receiving documents in .doc 
format is a part of the job, and while sending stuff out in .odt or 
even .rtf might be desirable, sometimes (for now at least) it’s just 
not allowed. Fortunately, we can set OpenOffice.org to 
automatically save documents in any supported format, 
including the ubiquitous MS Office ones.

To set this up we have to venture into the rather complex 
Options dialog, which can be accessed through the Tools menu. 
The section we need is labelled Load/Save > General, and this 

also contains the options for automatically backing files 
up, setting timed ‘recovery points’ and also for controlling 
the way in which OO.o saves website addresses. 

However, the bit we’re interested is at the bottom of 
the screen, headed Default File Format. In the left drop-
down list, select Text Document and choose the 
appropriate file type in the list on the right-hand side.

While it might be tempting to use .doc format, I’d 
always recommend the .rtf option: this offers the best 
compromise between almost universal access and 
document formatting options – most people will be able 
to open the file and it will retain features such as bold, 
italic and justification. We might not like it, but not 
everyone is using open file formats – yet.

1   Opens an extensive properties dialog (see 
BELOW).

2   Offers up a range of image filters such as 
noise reduction, colour invert, and smooth 
or sharpen. 

3    Changes the default colourspace (which is 
RGB) to black and white, greyscale or the 
faded-out ‘watermark’. 

4   Provides a selection of tools to change 
the brightness, contrast and gamma 
(lightness) values of an image, as well as 
the individual red, green or blue values.

5   The transparency option adjusts how 
much of the underlying page is visible 
through an image. This is useful for 
overlaying one picture on another. The 
percentage represents the transparency 
value, so 0% is completely opaque and 
100% is completely see-through.

6   This pair of icons will flip the picture either 
horizontally or vertically.

7   This icon is saved for those times when a 
picture is in a frame of its own, and opens 
the frames dialog.

MANAGING EMBEDDED PICTURES IN OO.O WRITER
This toolbar gives you plenty of options for formatting images:  

1 2 3 4 5 67

Writer now boasts great text runaround features, 
including a path/contour editor.

“WITH NESTED TABLES, WRITER 
CAN BE USED AS A PRETTY GOOD  
WEB EDITING APPLICATION.”

7

LXF
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