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OpenOffice.org Presentations
With trepidation, Andy Channelle stepped out on to the stage with only a laptop between 
him and his audience. Fortunately, the laptop was loaded with OpenOffice.org Impress... 

Many of us will, at some point in our lives, be asked to 
‘do a presentation’. This request is often the trigger for 
butterflies in tummies, anxiety dreams and genuine 

terror. I can’t help with that, but the free software community 
has given us a tool to ensure that, when the moment arises, 
the audience will spend at least some of the time looking at a 
big screen, which means less time looking expectantly at you.

This tool is, of course, OpenOffice.org’s excellent 
presentation application, Impress. At the top of Impress’s 
feature list is the ability to output MS PowerPoint-compatible 
files, and though we don’t usually recommend using proprietary 
formats over open ones, in this case it is a sensible precaution 
to save your finished presentation as a native file, and then 
export it as a PPT.

This is simply to help reduce performance anxiety. If you are 
relying on someone else’s equipment, there’s a possibility that 
they won’t have OOo installed; and as PowerPoint doesn’t like 
non-PPT files, it would be sensible to make sure you’re able to 
work with whatever is available. Either that, or print your 
presentation out on OHP sheets and go for 1984 nostalgia.

When you launch Impress for the first time, you will be 
taken through a wizard interface to begin defining the 
presentation. There are options for the presentation style 
(limited) and output medium (paper, screen, etc) and for setting 
the default transition effect and a display period for each slide. 

In this tutorial, we’re going to start with a blank presentation 
and build up images, text and animation settings.

The first thing to do is add a background image that will be 
used on every slide in the presentation. Impress comes with a 
selection of background images that can be tiled easily – these 
are accessible by doing Format > Page... > Background and 
selecting the Bitmap option. This is good, but not so great if 
you have a single image – say a company logo – that needs to 
occupy the same space on each slide or as a background. In 
this case it’s best to create a new master page which can then 
be applied to each slide in the presentation. The advantage of 
this is that the master page can later be edited and the 
changes will propagate through every slide that uses it. 

Masterful performance
Using master pages in a presentation makes for a more 
consistent experience for people watching and – even better – 
makes it much quicker to actually design and build the 
presentation. It’s similar, in fact, to the way that desktop 
publishing works. The idea is that there are elements that are 
replicated on each slide – such as default font sizes, 
backgrounds and headers and footers – in the same way that 
magazines create a consistent feel across all the different pages. 
Impress has these options hidden away under View > Master > 
Slide Master. Let’s look at them now.

We did some cool things with 
OpenOffice.org’s word 
processing program, Writer. 
If you missed the issue, call 
0870 8374773 or +44 1858 
438795 for overseas orders.

LXF76.tut_begin   68LXF76.tut_begin   68 19/12/05   5:44:49 pm19/12/05   5:44:49 pm



www.linuxformat.co.uk LXF76 FEBRUARY 2006 69

TUTORIAL First Steps: Presentations

PART 1 – CREATE MASTER PAGES

Start her up
The main interface is where most of the work takes place. In the centre is a 
workspace set to the dimensions of a standard computer screen. This is flanked 
by a slide browser on the left – populated with a single blank icon at present – 
and a Task browser on the right. At launch, the Task browser will show a selection 
of slide layouts, which can be dragged and dropped on to the main screen to set 
up automatic text and image boxes. At the top of the window is the usual array of 
menu and toolbars, and also a tab bar for selecting the various views available for 
a presentation. Mostly we’ll be staying in the Normal view, but the Slide Sorter 
view, which makes adjusting presentation order very simple, is worth a look.

Create a master
Rather than write over the default master page, select the New Master icon (far 
left) from the Master View toolbox to create a duplicate of it. This has all of the 
standard elements you might need for a basic presentation. Rename it using the 
Rename Master tool (third from left). On the master page you should see fonts for 
different levels of outline, and space for the inclusion of a slide number, footer and 
the date. Putting text into the footer box will see it added to every slide, and we 
can add date and slide information by closing down the master slides box and 
selecting Insert > Page Number... and selecting the appropriate options.

Add an image
Once you’ve selected the fonts and set up the footer information, you’re ready to 
insert a background image. Calling in an image is the same in Impress as is it is in 
Writer (or anything in OOo). Simply do Insert > Picture > From File... then browse 
to the location of your picture. Once added to the page, the picture can be 
resized using the green handles (remember to hold down the Shift key to 
preserve its aspect ratio) or changed in any of the ways we discussed last issue. As 
this is a background image, we’ve increased the transparency to 70%, and pushed 
it to the back of the page by right-clicking on the image and selecting Alignment 
> Send To Back.

Try a second master
A master page can contain any element that a regular slide can, including text 
blocks and any other graphical devices OOo has at its disposal. It’s also possible to 
create more than one master page per document, so you might decide to have, 
for example, different master designs for the various sections of a presentation, or 
designs dependent on the content of a slide – perhaps a quotation, chart or 
bulleted list. Once the slide masters are all set up, close the Master View toolbox 
to get back to the main editing screen. As we did last issue, it’s possible to save 
this document now as a template to use again in the future (File > Save > 
OpenOffice Presentation Template).

1 2

3 4

>> 
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>> 

Set up the series
To apply a new master page, first create a new slide by doing Insert > Slide or 
right-clicking in the Slide pane and selecting New Slide. With the slide selected, 
click on the master page you’d like to apply and watch as the page is updated 
instantly. It’s possible to apply a master page to every slide in a presentation by 
right-clicking on the master page in question and selecting Apply To All Slides. 
You can also make a selection of slides – use Shift+click to choose a continuous 
range or Ctrl+click for a non-continuous range – then use the Apply To Selected 
Slides option to alter just those.

Easy amendments
The intention behind master pages is to save you work. So, if you’ve lovingly set up 
50 slides with a footer saying ‘Bringing the past to life’ using master pages and 
your boss decides she wants it to say ‘Bringing life to the past’, you’ll only need to 
change one master page, rather than edit 50 individual slides. And once that’s all 
done, you can get on with the process of putting the slides themselves together – 
divorcing content from presentation is always a good idea!

5 6

PART 2 – ADDING THE CONTENT AND ANIMATION

We now have a blank canvas on which to paint a dazzling 
presentation. Only the point of a presentation is not to dazzle, 
but to put across an idea or argument clearly and concisely. 
Presentation software such as Impress has rightly been criticised 
for its ability to confuse and distract from what users are trying 
to get across. I do not endorse this sort of behaviour.

A presentation consists of a series of slides, which are 
displayed one after the other either at a timed interval or, more 
usually, by the click of the mouse or a button push. Each slide 
can contain text, images, sounds, animations and even links to 
web pages and, thanks to the modular design of OOo, pretty 
much every tool and option available in the word processor and 
spreadsheet is also accessible from within Impress. We will set 
up a couple of slides, add some animation on elements within a 
slide and then create simple transitions between the slides that 
can add finesse without overdoing things.

Remember we have a couple of master pages to work with, 
and they provide a background and some common features. 
We need to add some information, starting with the title of the 
presentation which, ordinarily, will be on the first slide. So, the 
first thing needed is a text box – this can be added by selecting 

the ‘Text’ icon from the toolbar at the base of the window (this 
has a big T on it) and drawing a box on the page. The resulting 
box will acquire the ‘width’ you have drawn but its depth will be 
the depth of the currently selected font. Once the box is on the 
slide, just start typing.

Just like in a DTP package, it’s possible to click the mouse in 
the rulers on the left and top edge of the screen and drag a 
ruler out on to the page. If you can’t see the guides, do View > 
Guides > Display Guides. It is also possible to display a faint grid 
(View > Grid > Display Grid) to make designing and positioning 
objects within a slide more consistent.

If this sounds unnecessarily complex, we can simplify things 
by using one of Impress’s pre-designed Layouts. These are 
available via the Layouts task pane on the right of the screen. 
Before adding any content, select a slide (or series of slides), 

Simplicity makes for a better presentation, and 
minimises the risk of translation issues if you run 
it through PowerPoint. Here are some pointers.

■ Bullet points and striking images are better 
than big blocks of text.

■ Keep effects to a minimum for stylistic and 
practical reasons.

■ Stick to two legible typefaces throughout.

■ Avoid timed transitions – it’s better to stay in 
control yourself.

■ Use colour wisely. Light text on a dark 
background looks good when projected.

■ Head up your notes with the slide names so 
you don’t lose your way.

■ Don’t bury your content under four tons of 
pretty packaging.

KEEP IT SIMPLE

Stay consistent in your slide design by using the grids and 
guides available for creating pages.

LXF76.tut_begin   70LXF76.tut_begin   70 19/12/05   5:45:03 pm19/12/05   5:45:03 pm



www.linuxformat.co.uk LXF76 FEBRUARY 2006 71

NEXT 
MONTH
Make the most of blogs, 
social bookmarking and 

the new breed of 
photo-sharing websites.
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right-click on the Layout required and choose Apply To Selected 
Slide(s). It’s also possible to create a new slide based on one of 
these layouts by right-clicking on the one you want and 
selecting Insert Slide. A new slide will be added immediately 
after the one selected in the slide browser on the left.

There are a variety of presentation layouts, including simple 
lists, images, objects and more, but if none of them fits the bill 
it’s possible to make adjustments to the elements after a layout 
has been applied. This new slide could then be duplicated or 
saved as a template for later use.

We’re starting with a simple layout featuring a title at the top 
of the slide and some text below for introducing the subject of 
the presentation; the Title Slide layout is ideal for this. Once it’s 
applied, we can click in any of the boxes on the screen and start 
adding text. The text will conform to the styles we defined 
earlier in our master pages.

Our next page will again include the title, but will also have a 
list of points that highlight the structure of the presentation 
itself. For this purpose we’ll use the ‘Title, Text’ layout, which has 
the title at the top and an area set up to display a bulleted list.

It is possible, once the text has been added, to right-click on 
the text, select Text and control the way that it’s displayed, but 
the options in here should be used sparingly, if at all. Effects 
include the hated Blink and some scrolling options, and there 
are controls for the duration and speed of the effect.

Animate your audience
Much more effective is the animation available for introducing 
textual – or visual – elements of the presentation. Again, it’s 
easy to go overboard, but judicious use of an effect can really 
enhance a performance. We have five lines on our Agenda 
slide, and these need to be revealed one at a time with a 
mouse click. Again, turn to the Tasks pane on the right, and 
select Custom Animation. Now select the first line of text – it’s 
important to select the whole line of text, rather than simply 
clicking the mouse in it. Doing the former defines that line as a 
single element, while doing the latter assumes that the entire 
text box is the element that should be animated. 

With the first line selected, hit the Add button in the Task 
pane and select the type of animation you’d like to use. A handy 
preview will demonstrate what the finished product will look like, 
and you can either OK it to apply the effect or choose another 
one. We’re sticking to the basics here – all we’re doing is making 
a textual element appear on the click of the mouse button – 
but there are options for emphasising or de-emphasising 
elements, exiting in interesting ways, and changing various 
parameters, and it’s worth experimenting once you are 
comfortable with the concept of animating in this way. Again, 
simplicity is often the best policy – even though Impress gives 
you the option of being wacky – so use just enough motion to 
suggest dynamism.

Select and edit
Once each of the lines has been ‘effected’, they will appear as a 
list in the task pane. They can be edited by selecting and then 
hitting the Change button. More extensive edits, including 
adding sound-effects and making the text appear letter by letter 
are available by double-clicking on an entry in the list. 
Auditioning effects are accomplished by selecting a line from 
the list and hitting the Play button (you can also make and 
audition multiple selections with the Shift+click method 
mentioned above) or test the whole slide by selecting the Slide 
Show button.

Once the slides are finished, it’s time to set up transitions – 
that is, the visual style in which one slide disappears and the 
next is presented. By default, the transition will be a sharp 

change with no effect, and for many occasions this will be 
adequate. However, some gentle, non-intrusive transitions can 
give the presentation a little extra polish.

Transitions are applied using the Slide Transition task pane 
on the right, and it’s important to remember that any selected 
transition will be applied to the current slide – that is, we are 
talking about the way the currently selected slide appears, so 
there’s very little point in having a transition on the first slide in 
the presentation. So, select the second slide, then start to 
experiment with the transitions on offer. If you like, select a 
single transition then apply this to the entire presentation using 
the Apply To All Slides button at the base of the task pane. It’s 
also possible to audition transitions with the Play button.
As with in-slide effects, don’t go mad or you’ll just annoy your 

audience; find a transition (or two, but never more) that fits what 
you’re trying to say and use it throughout. Adding a sound to a 
transition can be effective if it adds something to the 
presentation – but it should be used sparingly. Impress has 
options to play the sound once, or loop it until another sound 
interrupts it. The latter is a bad idea.

Finally, we can set the slide to switch automatically after a 
period of time using the Automatically After <time> option but, 
again, you may prefer to retain more control of the 
presentation by using the On Mouse Click setting (this 
also allows the use of the space bar or Enter key to 
advance a slide).

Once the presentation is complete, you can save it in 
the standard OOo OpenDocument format, which has a 
.odp extension, or export it in PPT format, which will work 
with PowerPoint. Impress will also export slides as a 
series of HTML pages for putting on the web, or as PDFs, 
JPEGs or other graphical (but non-editable) formats. 
Although we didn’t experience any issues moving a 
slideshow from Impress to PowerPoint, it’s only sensible 
to test the presentation (and make any adjustments) 
before you introduce yourself to the audience. LXF

“JUDICIOUS USE OF AN 
ANIMATION EFFECT CAN REALLY 
ENHANCE A PERFORMANCE.”

There are a range of 
transitions on offer – 
some better than others. 
This is Dissolve...
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