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TIME

FIRST STEPS LINUX BEGINNERS SERIES

Web 2.0 The new web tools
Make the most of blogs, image sites and more with Andy Channelle.

The world wide web is heading into adolescence and 
there are big changes on the horizon that will change 
the way we use it. Though the technology that 

underpins the whole edifice has evolved to provide faster 
speeds, more reliable connections and better ways of finding 
information, the same can’t be said at the user end. Scratch 
the surface of your browser and you’ll find a pretty similar 
application to the first Mosaic browser that came out of the 
National Center for Supercomputing Applications in March 
1993. Despite many refinements, the web browser still basically 
displays pages formatted in HTML and stores the addresses of 
websites for later recall. But that is changing as developers start 
to toy with the possibilities – and original promises – of the 
internet as a true read/write medium.

This tutorial is all about accessing and using second 
generation, or Web 2.0 applications that run on the internet 
rather than a local machine. They can be apps designed for 
displaying images, saving bookmarks or jotting down your 
thoughts for the world (or just yourself) to see. 

Of course, anyone who’s used Yahoo Mail, Hotmail or 
some other webmail system will have been doing this for years, 
but the latest innovations in online apps are far more 
sophisticated. And it’s testament to the perceived future value 
of these things that the biggest names on the internet have 
been buying up Web 2.0 companies as though the dotcom 
bubble had never burst. Perversely, we’ll be concentrating a bit 
on established local apps that can interact with these marvels 
of Web 2.0 loveliness.

We conquered our stage 
fright with Impress, the 
presentation package in 
OpenOffice.org. If you missed 
the issue, call 0870 8374773 
or +44 1858 438795 for 
overseas orders. 

TUTORIAL First Steps: Web 2.0

Personal web homepages have been available for ages, 
but it’s only with the advent of services such as Blogger and 
LiveJournal that it has become simple enough for anyone with a 
PC to publish their ideas to the rest of the computer-owning 
world. Setting up an account with either of these services (or 
any other one just a quick web search away) is incredibly simple. 

But what we’re concerned with here are applications that 
allow you to post content to a blog without having to log into 
the actual account. The simplest option is the Blog This 
extension for Firefox, which works with Google’s Blogger service. 

You can get it from Tools > Extensions > Get More Extensions in 
Firefox or from https://addons.mozilla.org/extensions/ under 
the Blogging header. You may need to add this site to the list of 
URLs allowed to install software if you haven’t installed any 
extensions before, and this can be done from the yellow bar 
that appears at the top of the Firefox window when any attempt 
is made to install something from the web.

As its name suggests, Blog This is ideal if you’re making 
notes on websites. To launch it when you’re at a comment-
provoking site, double-click anywhere on the page and select 

PART 1 – WEB-BASED BLOGGING
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the appropriate menu entry to launch the applet. Once you 
have logged in with the applet, a new window opens with a 
toolbar across the top and a large text area for your rant. This 
toolbar contains a decent set of text formatting tools and a 
drop-down list of active accounts, so if you’re maintaining a 
number of blogs under the same username, it’s easy to select 
which one you’re posting to. Once the missive has been written, 
hit Publish to have the text, plus a link to the original article sent 
to your blog. It’s possible to save a post as a draft for later 
editing too. Cancel a post just by closing the window. 

Going deeper
There doesn’t seem to be an equivalent of Blog This for 
LiveJournal; however, there is a complete Firefox/Mozilla-based 
application that will do the job called Deepest Sender (http://
deepestsender.mozdev.org/). Again, this will install into the 
latest version of Firefox, but this time is available via the Tools 
menu. The big difference here is that once you’re logged in, 
Deepest Sender provides almost all of the functionality of a Live 
Journal desktop blogging client. Users can update their music or 
how they describe their mood, post images, set user/community 
tags and define the public/private status of a post. It’s the sort of 
web-enabled application that Firefox (and before that Mozilla 
and Netscape) users and developers have been looking forward 
to for ages. And as with Blog This, there are options for 
selecting from different LiveJournal accounts for posting.

For complete integration, Deepest Sender will slot nicely into 
a Firefox or Mozilla browser sidebar – for instant access while 
browsing – and the latest version makes a decent stab at 
providing access to Blogger and WordPress (another blogging 
service) too. To add it to a sidebar, select View > Sidebar > 
Deepest Sender. If you install only one browser-based blog tool, 
make sure it’s this one. 

Direct mail
Of course there’s nothing to say that a user must launch a web 
browser in order to post to a weblog, and thanks to broad 
availability of many blog hosters’ APIs – that is, the software that 
hooks into the engines running the system – anyone can build 
an application capable of posting content to Blogger or 
LiveJournal. Oddly, there doesn’t seem to be a native KDE 
application or applet available for the former, though KLuje (who 
comes up with these names?) does a good job of hooking into 
the latter. 

In contrast, the Gnome desktop has at least three usable 
applications – including a system tray applet – that are happy 
dealing with most of the prominent blog engines. I’ve chosen 
Drivel for two reasons: firstly, it’s widely available on most distros 

For ‘always on’ blogging, shoving Deepest Sender into a sidebar is pretty hard to beat.

Great name, great app. Drivel is an all-round good egg.

and covers Blogger, LiveJournal, Advogato and Movable Type; 
and secondly, it has the best name ever for blogging app! The 
downside is that the developer has opted to secrete every single 
tool in menus, so it might take a little getting used to.

When you launch Drivel it’s distressingly blank: just a menu 
bar, subject line and huge, intimidating expanse of white space 
waiting to be filled. You can just throw in a subject title and then 
start typing, but if you want to add some style or post to a 
different blog, you may need to hunt around a bit. Font options, 
as well as link and image tools, are in the Format menu, while 
the Active Journal option – which enables you to choose which 
of your many blogs to post to – is (non-obviously) under the 
Edit menu. This menu is also where you’ll find the preferences 
where it’s possible to set up spellchecking, and also ensure that 
blog-tracking service Technorati is notified whenever your blog is 
updated. It’s well worth exploring the interface.

The next generation internet needs a next 
generation browser, and that’s just what the 
leaders of the Flock project are attempting to 
produce. Taking the guts of the Firefox browser, 
the Flock team have bolted on a new theme and 
extras that take advantage of web services such 
as Delicious, Flickr and Blogger. The Bookmark 
utility, for example, doesn’t store bookmarks 
locally, opting instead to send them to your 
Delicious account, complete with descriptions 
and tags if necessary.

The new top bar can optionally display the 
contents of your, or someone else’s, Flickr 
photostream, or a list of active blogs, which you 
are able to access with a click of the mouse. 
The Blogger Top Bar also has a Drag Stuff To 
Blog It feature, which allows users to simply 
drag a link, page or image into a space and 
launch a blog editor (much like Firefox’s Blog 
This extension) with the links formatted and 
ready to go. 

There’s also a very useful Shelf utility, which 
lives in a separate window. URLs, images and 
snatches of text can be dragged and dropped 

into this shelf for later use. The great thing is that 
whatever you drop in here is persistent and will 
only go away when explicitly deleted – it’s great 
for online research, shopping and everything else. 
Finally Flock has some great RSS features such as 
live bookmarks and ‘on the fly’ aggregation. 

The big ‘but’ is that this is software in the early 
stages of development, and so may be a little 
flaky in use. The very cautious might sit back and 
wait for some of these features to be added to a 
more mainstream offering such as Firefox. 
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Ever since Sun started blowing the Java trumpet, 
online office applications have been “almost 
here”. Any chance to lower IT costs, lighten the 
grunt work of client computers and improve 
control and security would appeal to business, 
but the waiting games has continued since the 
nineties, although in the Web 2.0 world, the buzz 
is more likely to be about Ajax (Asymmetric 
JavaScript and XML) than Java. There has also 
been a lot of talk about Google throwing money 
at OpenOffice.org to pull the entire suite online.

While there are interesting Ajax products out 
there that cover the whole gamut of productivity 
work, webmail applications have been growing in 
stature so that something like Gmail works as a 
pretty effective, if basic, word processor. It has 
an array of text formatting options, highlighting, 
automatic linking for web addresses, spell 

checker and works brilliantly with Firefox (and 
other browsers) on any platform. A recent 
addition is an autosave feature which puts a copy 
of a document/email being worked on in the 
drafts folder and saves it every couple of 
minutes. Once a document is completed, it can 
simply be emailed to its destination (it’s fantastic 
for collaboration) or printed directly from within 
the mail client. When working with other people, 
each draft is automatically saved in the Sent Mail 
box too, so there’s never any danger of losing a 
precious document, and everything is searchable 
and can be labelled using the Gmail interface. 

So while we’ve all been watching 
developments in OpenOffice.org, Google has 
released a cool, cross-platform text editor, with 
email and backup facilities built in. Let’s just pray 
they add a word count soon...

WHAT ABOUT ONLINE OFFICE APPS? 

F-Spot is a cool Mono application that is gaining favour 
among distro vendors.

TUTORIAL First Steps: Web 2.0

A picture is, apparently, worth a thousand words, and if 
you’re pictorally-minded Flickr (or some other image-sharing 
service) is a good alternative to text-heavy blog services. As with 
blog websites, you will need to set up an account before you 
can do anything on Flickr. Fortunately the company, which has 
been bought by Yahoo, has a free account which limits users to 
20MB of uploading per month. This is adequate for most of us, 
but if you start going mad and taking photos of road signs, 
spiders and so on, you may want to think about buying the Pro 
account for $24.95 a year. 

Flickr gives everyone a space to store and display photos, 
but it also allows users to set privacy levels – you could grant 
access to family photos only to other members of your family, 
say. The software also has the facility to ‘tag’ every image you 
upload, so that it’s easy to search, for example, for pictures of 
the Eden Project, London or Spiders. As I often mention in this 
series, though, you only get decent results from this type of 
software if you put in the effort. 

Other facilities of Flickr include slideshows, group/pool 
photos (so that lots of members can contribute pics from the 
same event such as a wedding) and an Organizr, which allows 
you to move photos around, rotate them and create sets but 
doesn’t yet allow any actual editing of pictures. As with blogging, 
above, for this tutorial I’m interested in the ways we can get 
pictures on to the site, rather than what we can do once they 
get there. 

Emailing images
The most cross-platform-friendly way of uploading pictures is to  
email them and this, inevitably, is done through your regular 
email application. 

When you sign up to Flickr, you’re given an email address 
which will have the format ‘wordnumberword@photos.flickr.
com’, ie linux77format@photos.flickr.com. This is the 
address you send a picture to, and like magic it will appear in 
your collection. However, it will inherit the account’s default 
settings, so we need to change a few things. 

The first thing to change is the privacy settings. In addition to 
the Private setting, which ensures that the photos are only 
visible to the account owner, Flickr has Family, Friends and 
Public settings too. To give your photos different privacy settings, 
you need to append the first part of the email address. So, 
linux77format+friends@photos.flickr.com will send the 

photo to Flickr and allow people within your Friends group to 
see it. Similarly, you might type linux77format+family@
photos.flickr.com for designate a picture as accessible to users 
within your Family group. To set it to Family and Friends, use ff; 
to keep the image to yourself, add private.

It’s also possible to add titles, descriptions and tags to a 
photo being sent by email. The title of an image is defined in 
the subject line of the email, while the description is added from 
the body of the message. It’s possible to add tags to either the 
subject or body, and have them appended to the image. Simply 
type ‘tags: tagnames’ in either space. You might email a picture 
of your new Linux computer to your account:

To: linux77format+family@photos .flickr.com
Subject: My lovely new computer tags: computer 
Christmas “Linux Box” Linux PC
Body: I can’t believe my husband got me a new, beautiful 
Linux PC for Christmas.

Attach the picture, hit Send and then wait as it is forwarded and 
processed for inclusion in your collection.

From the desktop
The next good cross-platform method of uploading is to use 
Flickr’s own online Uploadr. This is similar to the tools used to 
add attachments to emails in webmail apps and is very simple 
to use. However, for the most elegant solution, nothing beats 
uploading photos from the same desktop application you use 
for managing images. It makes sense to have one app that will 
take images from your camera, allow some editing and then 
send the final result to your online service. The two best Linux 
applications for this are F-Spot and DigiKam. F-Spot is a Mono 
application that has quite a lot of dependencies but is becoming 
a standard feature in many distributions, while DigiKam is an 
established part of KDE and should be available in all of the 
mainstream distros. 

Both of these applications are very smart utilities in their 
own right, but I’m most interested in their ability to tag pictures 
and upload to Flickr. We’ll start with F-Spot, which has had Flickr 
integration from its earliest versions. Images within this 
application can be tagged and categorised with a variety of pre-
made or bespoke tags, and the cool thing is, these can be 
exported as native Flickr tags with no editing required. F-Spot 
follows the convention of selecting multiple images using either 
the Shift key (for continuous selection) and the Control key (for 
non-continuous). Once you’ve made a selection, it can be 
exported using the File > Export > Export to Flickr option. This 
will launch a new dialog box with some options for you to select 
before connecting to the service. It’s possible in here to strip out 
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NEXT 
MONTH

We’ll turn the OpenSUSE distro 
into a fully-fledged, 

multimedia desktop system.

Last-minute checks
Once all adjustments have been made, go back to the 
browser with the new album selected and then do Album 
> Export > Export To Flickr. It’s important to define tags, 
set the privacy options, and any resize command before 
selecting the images. Now hit the Add Photos button and 
select the entire contents of the export directory. When 
you click on the OK button, the upload begins, so make 
sure all the settings are correct before doing this. If it’s 
the first time you’ve connected the app to Flickr, it will 
launch Konqueror in order to set up the account to 
receive photos. LXF

TUTORIAL First Steps: Web 2.0

  PART 3 – UPLOADING WITH DIGIKAM

metadata from the picture, that is information such as the focal 
length of the shot, date, time and so on, and also to resize the 
pictures. This dialog is also where you would set whether the 
application will convert F-Spot tags into Flickr ones. If the F-Spot 
tags don’t correspond with a pre-existing Flickr tag, a new one 
will be added to the list. Then it’s simply a case of adding some 
login details and hitting the Export button. 

Now to DigiKam, currently the most fully-featured photo 
management application for KDE. Thanks to its use of Kipi 
plugins, it has a decent Flickr export option. However, unlike F-
Spot, this app doesn’t attempt to use its own tagging system to 
interact with the web service, which means possibly having to 
tag images twice. But it does make up for this by having options 
to set the privacy level of photos as you upload them.

The DigiKam interface
For those with a penchant for KDE-flavoured applications, 
DigiKam offers the best combination of style and substance, and 
though it looks a little more complex than F-Spot, in use its 
Flickr integration is very easy to get to grips with. It’s obvious, 
though, that the Flickr facilities come in the form of a plugin 
rather than a native feature, because you’ll find it’s impossible to 
just select a couple of images from the main browser and 
upload them. 

Gather the images
Due to the way DigiKam works with exports, it’s best to select 
the images that are going to be sent to Flickr and then drop 
them into a new ‘album’. To do this, select Album > New Album 
and give it an appropriate name. If you’re super-organised you 
might like to make a catchall album called Export or Flickr and 
just copy and delete pictures as and when they were needed. 
Once the album has been created, drag and drop images into it 
in the usual manner, selecting Copy rather than Move when 
prompted. Then select that album.

Edit and label them
Once you have navigated to the correct album, DigiKam has a 
selection of effects and edits that can be applied. To put an 
image into ‘edit mode’, double-click on it in the browser window, 
and a selection of adjustments can be made via the menu bar. 
To add app-specific tags, right-click on the main image and 
select Assign Tag > Add New Tag (or choose an existing tag). 
I’ve found it quicker to resize images in this section too, rather 
than wait for the export dialog to do the job. Do Transform > 
Resize and select the appropriate size, keeping the Aspect Ratio 
option checked.
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