TUTORIAL First Steps: Email groups

FIRST STEPS LINUX BEGINNERS SERIES

Evolution Manage your email .-

If you have email to organise, contact details to store or projects to manage, this simple tutorial of
Evolution hacks will make a big difference. Your life coach Andy Channelle is ready at the whiteboard...

Y Is it just me, or does the work involved in any given job  of contacts in Evolution, then use it to have all their related
1 grow in inverse proportion to the actual time available emails shepherded into one place and invite them all to group
7

to do it? | think that's why people planning to build a meetings and the like through an online calendar. Don't be
house in three weeks on television end up taking three years thinking that this functionality is only useful for professionals or
(and go 330 times over budget). What is usually missing from part-time Linux projecteers - it certainly can be used for formal
We travelled through blogs, . - h . , ) Lo .
X e these projects is adequate planning. That’s what we're project management, but it will also make a big difference for
Flock, Flickr and DigiKam to . o ) ) : ) )
. . concentrating on in this installment, and the tool of choice for people who simply get a lot of email, while anyone with even a
pick up some Web 2.0 skills. o . . . .
If you missed the issue, call the job is Evo/ut/or?. o . sniff of anal retentlvg abguﬁ them WI.|| be happy here.
0870 8374773 or +44 1858 Most people will encounter Evolution simply as a superior For the sake of simplicity, I'm going to assume you have
438795 for overseas orders. email client, but it is capable of so much more. Its true strength Evolution set up for email (you'll find it on our coverdisc), then
lies in its ability to bring together a ton of information within a start bringing the rest of the system together. If you don't, the
single application and then enable the user to create links application has a great startup wizard that will hold your hand
between different parts. For example, if you add an important through the configuration stage the first time it's launched.

a“ ) Create the group
TH IS FU NCTIONALITY ISN T J UST The first step on the path to decent project management is to
USEFU L FOR PRO FESSION ALS OR define members of your team. This might be members of a
department, contributors to a university project or even just your
P ART_TI " E PROJ ECTEERS ” family (if you're ruthlessly planning a couple of weeks in Butlins),
d and Evolution makes it simple to corral people into groups for

this purpose.

deadline to a calendar on Evolution it can be communicated to I'll set up a small group for this example (three people plus
everyone who needs to know about it a few days before the me) and will assume | have recently received email from them,
event is due without intervention from a forgetful human. which means their details will already be partially in the

Planning, see? In this tutorial I'll show you how to create a group  application. To add them fully, I'll have to enter the details into
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Evolution's Contact Book, which can contain several address
books divided into categories. The easiest way to do this is to
right-click on each of the names in turn in the ‘From:” section of
an email and select Add To Address Book. This will offer the
options of simply adding the name to the address book or going
for the full editing screen. Select the latter and add the
necessary detail for your contact. It is here that we begin to
move away from standard PIM territory.

Evolution has just one contact book set up for personal
details by default, so we need to add a second . In the right-
hand pane of the main Evolution window (with the Contacts tab
selected), right-click just below where it says On This Computer
and choose New Address Book. The ‘type’ should be On This
Computer and the name can be anything you like, such as Work
Linux Launch. Now select the Contact Editor again (the window
should still be active in the task bar at the bottom of the screen)
and change the Where: drop-down list to the address book
you've just created.

That’s the first division sorted, but if you work with lots of
people you might want to refine the data a little. In this case, the
Categories option is very useful (see image, right). As standard it
comes with the usual choices for arranging your data such as
Birthday and Holiday, but it’s easy to add new categories. Just hit
the Categories button to open the dialog box, select New,
provide a name and, optionally, a category colour and/or icon
('m choosing orange) for highlighting any notes or meetings
involving members of the group. Creating groups and categories
just makes it easier to find things later, so it's worth taking the
time to do it right!

Sorting the mail

We're now going to start labelling the emails concerning this
project to distinguish them from the rest of our messages.
Evolution provides two excellent ways of doing it, both of which
are based on the concept of filters. As the name suggests, a filter
can be used to let through only emails that meet certain criteria,
thus ensuring you only get bothered with what you need.

The first way to sort the mail is to create a new mailbox (right-
click on the On This Computer text in the left pane of the Mail
tab, select New and offer a name), and set the application to file
messages in there when they arrive. To start, select Tools >
Filters and then hit the Add button. If you're running the latest
version of Evolution (2.4) you'll find the same option under Edit
> Message Filters. Once we've given the filter a name (let’s say

QUICK TIPS

M In my experience, even small projects
tend to end up accumulating lots of files, so
it’s sensible to add a sub-folder to your
main documents folder to house these. As
well as making backups easy, this also
means you won't have to spend 35 minutes
looking for a file you're certain you saved to
the desktop.

M Use the calendar in Evolution to make
staged backups of important documents.
Create appointments for each stage of the
document creation — outline, first draft and
so on — and drag the actual file from the
file manager into the Attachment Bar. You'll
have a complete record of the creation
process. Just remember that if you delete
an event, meeting or task, its associated
attachments will also swan off into the
ether, never to return!

different tasks.
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H Add more columns to the Task
section. Right-click on the column
headings and select Add A Column.
Essential columns are Due Date and %
Complete. The latter can be updated
as the project progresses using the
drop down list, so you can prioritise

M Subscribe to remote calendars

using the Web Calendar feature. Do
New > Calendar, select On The Web
from the drop-down list and add a
URL. There is a large selection of freely
available calendars covering a variety of
uses at www.icalshare.com.

M Make your own web calendars. Once
you’ve assembled the required data (this
could be public events, or just personal
stuff), right-click on the calendar in the left
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Sorting data into categories always makes it easier to search through it later.

Work again), we can begin defining what it will let through by
using a combination of drop-down lists and entered factors to
determine where a message ends up or if some action should
be performed upon it.

For this project all of the participants have email addresses
that end with ‘futurenet.co.uk’ So let’s stipulate that, for this
project, the message sender’s address should contain that
domain ending by selecting the first two drop-down lists, Sender
and Contains, and adding ‘futurenet.co.uk! However, | don't want
to filter messages from everyone from Future Publishing into the
same mailbox, just people from Linux Format. Knowing that each
of the editorial staff has the magazine’s name in their email
signature, | can exclude, for instance, anyone from Mac Format
by adding another rule and selecting Message Body > Does Not
Contain and then inputting ‘Mac Format. These are all called If
statements and they set the filter criteria.

The second section is the Then statements, which set the
action of the filter. There are quite a number of actions we can
perform here, from sending the project messages into a mailbox ))

pane of the Evolution window and select
Save To Disk. The calendar will be saved in
the .ics (Internet Calendaring and
Scheduling) format, which can be submitted
to places like www.icalshare.com or sent to
friends running iCalendar-compatible
software - instant synchronisation.
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of their own (which has the advantage of removing them from

the main inbox completely) to something less drastic such as
changing the colour of the text. As we've assigned a common
orange colour to the group we set up before, it would make
sense to do the same to emails from people within that group.
It's even possible to set rules so that messages that conform to
a particular criterion can trigger a different sound when they
arrive, just like a personal ringtone on a phone.
Whatever you get the filters to do, the standard procedure is
that they'll then be applied to subsequent incoming messages.
However, you can apply them retrospectively by selecting all of

“VIRTUAL FOLDERS SORT MAIL
INTO CATEGORIES WITHOUT
MOVING IT FROM THE INBOX.”

the messages in the top pane (Ctrl+A) and then doing Messages
> Apply Filters or hitting Ctrl+Y.
In addition to the filters, Evolution has really smart virtual
folders. These are called vFolders in older versions of the
application, and Search Folders in 2.4. Regardless of the name,
these folders allow you to sort mail into categories, much as we
did above but without moving it from the main inbox. In effect,

Evolution’s rules-based
filters for email are

Search Folders apply a set of rules to incoming mail and, if a
message satisfies the rule, creates a link to it within the virtual

incredibly flexible. folder. The smart thing is they are dynamic so the rules can be
= (=) &3
Rule name:
If
|E| Execute actions | if all criteria are met 3 |
I| Sender =] | | contains :I [futurenet.co.uk |ﬁemove|
| Message Body & | | does not contain 3 | iMac Format |_ﬁemove|
Then
Add|
| Assign Colour - | |E| |ﬂem0ve|
Cancel | | oK |

A A A »

e € 80INg g€ Toug € 1oug
When working towards a particular event,
it often helps to break tasks down into
more manageable sections. Evolution’s
way of doing this is based on a
technology that has been around since
the Babylonians: you write a list!

The section of Evolution that we're
looking at here is the Task Manager.
Essentially this is just a very good to do
list; you create an entry, give it a start
date, a completion date and a status
dependent on the task’s importance.
Tasks are displayed in the list and can be
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sorted dependent on the priority you've
assigned them, the percentage completed
or the due date.

As with other sections we've
mentioned, it’s possible to group tasks
using colour, for easy identification, and
we can also assign the task to someone
within our contacts group and have the
details (and any attachment from the
Attachment Bar) automatically sent to
them via email. To do this, right-click a
task, select Assign Task and add the
necessary details.

= New Search Folder.

Rule name: [umvers'\ty ‘

hig

4P Add Include threads‘ None ~ | Execute actions| if all criteria are met "

"Hacuk| |

‘ Sender |'H ends with ‘— Eemuve‘

Search Folder Sources

1t

Search Folders can pull everything from particular
addresses or domain names into one folder.

defined and redefined without affecting the physical location (if
such a thing were possible on a computer) of the message.

To create a new search folder, right-click on the Search
Folders text in the left pane and select New Folder. You'll be
presented with a dialog box very similar to the Filters one, except
there is no ‘Then’ section; instead, everything that fits the If
statements you set will be linked in the Search Folder. It's like a
brilliant way of saving searches. To edit a folder, right-click on its
name and select the Properties option. The great thing about
this method of working is that Search Folders react in exactly
the same way as ordinary folders to incoming messages, so if
you have an unread message from someone you have
designated ‘important’ (and you've set up one with the
important’ criteria), the name of the folder will be emboldened
and you'll know you have something worth looking at.

One other thing that doesn'’t tend to get mentioned often is
Evolution's Mark For Follow Up feature, which enables you to
add a note to a mail, along with a date and time, to remind you
that a follow-up is required. Simply right-click on a message in
the top part of Evolution’s mail client, select Mark For Follow Up
and add a date and time. This text string will now be at the top
of the message next time you look at it. There are also other
flags available in this section such as Do Not Forward, Call or No
Response Needed. Similarly, you can right-click on a message
and convert it into a task, which is then added to the
application’s Tasks tab to have date, time and other details
added: this is especially useful for deadline reminders.

These are the sort of tools that can really help make a
project run smoothly, but now we've looked at setting up
contacts and managing mail, it’s time to turn to the place where
these elements come together: the calendar.
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SE A GROUP CALENDAR IN EVOLUTI

Evolution is capable of managing many calendars at once. base for a Project Calendar. To create a new one, select

You can ‘switch’ them on or off on the left pane of the Calendar File > New > Calendar or do Ctrl+Shift+N and give the calendar
section. Earlier we defined a particular colour for each member a name and colour, preferably the same one as other elements
of our project group, so it’s sensible to use this colour as the of the project.

i Appolntent SARRCEeting BELE
Al Recurrence| A | Recurrence| Scheduling | Invitations
1 2 ) ndy Channelle <andy@channelle.co.uk> -]
Al
Y IAHRC Hecling ] Attendee Type Role. RSVP |Status A [ #auw |
Location: [St. Matthias l Andy Channelle Individual Required Participant Yes Accepted | ‘m‘
Classfication: | Public || calendar: | university - [ Cortacts.. |
Categories... | [University ] |
Description: ‘
|
|
Date and Time :
Start time: [m/nz/znuﬁ ﬁ”u 00 E\ ‘E (] All day event i
Endtime: [01/02/2006 B[Lam -] @ % Show time as busy =
X Alarm [ H [Xcmtamlse... ‘ Attachment Bar (drop attachments here)
This appointment has customized alarms
Attachment Bar (drop attachments here)
o
Add an event Create a meeting
The simplest way to use the calendar is to right-click on a day/ The next step is to set up a meeting within Evolution. Right-click
date and select New Appointment. You'll then be able to fill in on the appropriate date and select New Meeting. The dialog box
details of important dates and set alarms to go off in time to is similar to the Appointment one, with spaces available for

remind you of the impending deadlines. A custom alarm — it can  setting the time, date and location of the meeting and also
be a pop-up, a sound or an email alert — can be set to go off at  defining alarms. However, there are some additions for inviting

any point before the appointment. The entered date will then be  other participants. Select the Invitations tab at the top of the
@ displayed on the calendar and will be readily visible thanks to the  window. You will automatically be selected as the Organiser of
colour choice you made earlier. This is fine, but project the meeting, and each meeting can only have one of these. The
management depends upon the effective management of not main part of the window is a list called Attendees and,
just your own time, but other people’s too. unsurprisingly, it is here where we define who will be attending
the meeting.
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Set roles Invitations and paperwork
By hitting the Contacts button, we can add people from any of One final touch is the ability to drop documents, images
the Address Books set up on the computer. It is here that we or other files into the Attachment Bar at the base of the y
also define the roles expected of each attendee by selecting a window and have them forwarded to each participant in NEXT 4
name and then using the Add and Remove arrows on each the list. Invitations are sent as iCal attachments and so, if a y
designated role. Click on OK to see the list now populated with respondent accepts an invite, it should automatically be M NTH P
names. There are some qthgr things we ;an change herg too, added to thglr calendar (if they're are usmg Evolution or We'll be editing and processing <
such as the status of the invite (whether it has been declined, some other iCal capable calendar) and their response audio for a range of purposes, _
accepted or whatever) and the expected role of the participant. ~ sent back to you. Changes you make to the meeting — or including podcasting and
its cancellation — in Evolution will also now be sent to P video soundtracks. .
each participant via email so they can stay up to date. 43 P )
4 )
‘Y
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