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Last month We built an entire database from scratch with OpenOffice.org Base.

Last issue I exposed my white goods shopping habits to the 
world in the interests of showing you how to build a simple 
home inventory database. To recap, we used the wizards in  

OpenOffice.org Base to define the data we’d be working with (the 
Table wizard) and create a simple form for data entry (Form 
Wizard), then used the Table interface to enter, sort and filter data. 
At the end we had one table and one form. Our table had several 
‘fields’ as column headings such as Item and Serial Number, and 
we had manually entered some data into the cells. This time we’re 
going to add some space for notes and category information to 
the table, play with an interactive widget for the form and 
introduce queries and reports as ways to reorganise the database.

Our first job is to edit the database table to add a place for 
notes and an ItemType option. The latter will enable users to find 
all items relating to, for example, ‘computers’ or ‘kitchen’. To do this, 
launch OOo Base and open your database from last time. Enter 
the Tables part of the database by clicking on the appropriate 
entry in the left-hand pane of the Base main window, then right-
click on the table we created. 

Now select the Edit option from the context menu to enter the 
table edit screen. This screen is, like the table itself, very 

spreadsheet-like, 
but this time there 
will only be three 
columns named 
Field Name, Field 
Type and 
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 Right-click on the far-left column to pop up the context 
sensitive menu with the usual options. Note the data types.

 In your database form, double-click on any element to 
launch this configuration dialog box for tweaks.

Description (see image below). The Name and Type columns 
should be populated with the fields you set up using the Table 
wizard last time. Adding a new data field is as simple as clicking in 
one of the vacant Field Name cells, providing a name and defining 
the correct data type. Our new ItemType field can be set to the 
usual Text [VARCHAR] data type, but the new Notes field, which 
potentially will contain more information, is best set to the Memo 
[LONGVARCHAR] data type.  Don’t let this bamboozle you – the 

’VARCHAR’ element just means ’variable character’, so 
LONGVARCHAR is the same but with space for longer text strings. 

Take a look at the image below again. If you wanted to change 
the order of the fields in the table, it’s not possible to simply move 
fields up and down the list – but you can cut and paste rows by 
clicking on the left-most cell where the little green arrow appears, 
then right-clicking to get the context-sensitive menu. When you do 
this, everything below the cut row(s) will shift up to the first vacant 
row, and any paste operation will deposit the cut row(s) at the 
bottom of the table. It can be a bit of a fiddly procedure, but you’ll 

“Forms make viewing 
individual data entries a 
lot easier on the brain.”
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If you missed last issue Call 0870 8374773 or +44 1858 438795.

your database
quickly get used to it! When you have added the new fields and 
their location is right, you can – optionally – enter a description, 
then hit the disk icon on the toolbar at the top of the window to 
save the table. 

Once the Edit window is closed down, double-click on the table 
in the main OOo Base window to open it up ready for you to add 
some data. Note that if you already have data entered into the 
table, it won’t be destroyed by editing the table structure, but you 
will have to go over previous entries and update the new fields – 
it’s always easier to get it right first time.

Modifying the form
Though it’s entirely possible to use the table for data entry, it’s 
much nicer to do it through the form we created (see image right). 
Forms also make viewing individual entries a lot easier on the 
brain, because each record is displayed on its own screen. Anyway, 
we built a form last time using the Form wizard, and we’re now 
going to add the Notes and ItemType space that we just added to 
the table, and also improve the design by adding a date widget. 

To start, click on the Forms icon on the left and then right-click 
on the Household Inventory form (or whatever you chose to call it) 
and select Edit to launch the main edit screen. If the Form Design 
toolbar and Form Controls toolbox are not on the screen, activate 
them from the View > Toolbars menu.

The first job is to make a space for the new ItemType field. 
Fortunately, OOo’s Form wizard automatically groups fields by 
their labels, which means that it’s easy to just click on a field and 

drag it to a new location. Of course, if you want to move the label 
and field separately, you can ungroup them by selecting the 
required field and doing Format > Group > Ungroup – use the click, 
Shift-click method to select multiple page elements and then do 
Format > Group > Group to lasso them back together. We have 
clicked and dragged things around to create a space in the top 

You can always find 
the latest version of 
OOo at www.
openoffice.org. If 
you’re working with 
the version that 
came with your 
distro, an upgrade 
might be in order...

Quick
tip

 Not all forms have to be as grim as a P45. When it 
comes to our database, butterflies, silly fonts and 
profound quotes are definitely the way to go. Or not.

It’s not a crime to be good-looking!
If you take more than a cursory glance at the form designer in OOo 
Base, you’ll notice that it is, in fact, just OOo Writer. And this is great, 
because it means that each tool available in the word processor is 
on hand for the purposes of designing beautiful forms. Of course, 
forms are meant to be grey, nondescript and utilitarian – it’s 
something to do with the British institutional image of the form filler 
– but any follower of John Keats understands that we find truth in 
beauty and in beauty, truth. Anyhoo, let’s make things prettier.

To start, open up a previously-made form by right-clicking on its 
name and selecting Edit. Ours has a very prison-like background 
colour called Teal, and I’ll get rid of that first. Do Format > Page and 
then select the Background tab. In this section it’s possible to 
change the colour of the page or, even better, drop in a lovely 
picture. To do the latter, select Graphic in the ‘As’ drop-down list, hit 
the Browse button and find a suitable picture. The control at the 
bottom of the window has options for forcing the image to take up 
the whole space, tiling it or placing it in a particular position. 

Some images are not particularly suited for a form background, 
but you could lighten them up in Gimp so that the text of the form’s 
boxes remains visible. You might also move things around a bit to 
make them more aesthetically pleasing, drop in a transparent box 
with some suitably philosophical quote, or change the form title to 
something less, ahem, local government.

 Entering data into a form is far more sensible than using 
tables, and it’s easier to see a product’s details.
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OOo Base offers a 
multi-line text box 
option with full 
formatting facilities, 
which is especially 
good for long notes. 
It’s a bit buggy 
though, so I suggest 
you use it carefully.

Quick
tip

1  Defi ne search criteria
The first step in sending a query to your database 
is to select the Query option on the left of the 
main window and then choose the Use Wizard To 
Create Query... option to start a familiar-looking 
wizard. The idea here is to define which particular 
elements of the database you want to display. Hit 
the Next button and then choose how the results 
will be ordered – in my bibliography example, I’ve 
chosen to sort by author, then by year, then by 
title. Hit the Next button again to go to the Search 
Conditions section. This is really important 
because it allows us to include or exclude 
particular records, and fortunately the search 
conditions don’t necessarily need to include those 
fields we have opted to display.

Step by step: Running a query in OOo Base

2  Set the fi eld condition
My bibliographic database contains references 
from each course I have been on over the last 
couple of years, but I’m only interested in looking 
at those used for my dissertation. In this case, I 
can set the Field, Condition and Value options to 
’Books.Module’, ’Is Equal To’ and ’Dissertation’ 
respectively, which will only show results that 
have been linked to the Dissertation in the Module 
field. In the final dialog box, select the Modify 
Query option to open the query in Design view 
before running it. Design view has two main 
panes – showing each active table and the query 
criteria – and the usual array of toolbars and 
menus. I just want to deselect the Module column 
in the bottom pane so that the module name is 
not displayed in the final results. 

3  Submit the query
You can test the query by hitting the Run Query 
icon in the toolbar, and the resulting table will be 
displayed in a third pane of the window. Queries 
can be run at any time from the Queries window, 
and it is easy to edit them by right-clicking on the 
query in question and selecting the Edit option. 
You can, of course, build as many queries as you 
like, which means that it’s possible to look at the 
same database in a number of different ways for 
various purposes. 

 A calendar widget makes entering dates a bit easier. 

right of the form ready to receive the ItemType field.
We now need to insert a new ItemType box on the form. From 

the Form Controls toolbox, select the Text Box icon and draw a 
new text box in the right location. This is exactly the same as 
drawing a square in an illustration package, so you can resize the 
box by clicking and dragging any of the control points on the 
corners or edges of the box. If you need a little more precision 
than your eye can provide, right-click on the box and select 
Position and Size from the context-sensitive menu. In this box you 
can change – surprise, surprise! – the position and size of the 
selected element.

With the box sized and positioned correctly, we can now define 
how the database will ’see’ it. Double-click on the element and 
then, in the resulting Properties dialog box, select the Data tab. 
The salient option here is Datafield and it really needs to tie up 
with the database table label, which in this case is ItemType. It’s 
worth, as we’re here, having a quick scout around this dialog box, 
because there’s a lot that can be done here. Under the General tab, 
for example, are options for adding a 3D look to the form (as 
sported in this tutorial’s screenshots); changing the tab order of 
the box (that is, the order in which a user can navigate form 
elements using the Tab key; and setting some default text in each 
box or making a box read-only. More ambitiously, the Events tab 
can associate complex macros with a range of mouse or keyboard 
events – but that’s a little beyond the scope of this tutorial.

Once the box is configured to your liking, select Label Field, 
draw a space above (or alongside) the previously made box, then 
type the desired label into the space – I’ve labelled it ItemType to 
keep it simple. Once this is done, click, shift-click both elements 

and group them together. We’ll now do the same for the Notes 
element, but this time make the much box bigger (there will 
probably be more information in it) and, in the Properties dialog 
box, select Multi-Line in the Text type option under the General tab.

While we’re in the Form Editor, we can also add a calendar 
widget to the Date Purchased field, which might make filling in the 
form a little easier. Double-click on the field and, in the General tab, 
locate the entry labelled Dropdown and select Yes. And that’s it. 
Hit the Save button and we’re ready to enter some data. You can 
close the Form Designer window using either the File > Quit menu 
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Next month Like Google, we’ll be getting some Windows apps to run with Wine.

Most operations that 
you do with a mouse 
in OOo can also be 
accomplished with 
keystrokes, usually 
using a combination 
of the control key 
(Ctrl) and a letter. 
For example Ctrl+C 
and Crtl+V will cut 
and paste any 
selected text or 
object. The key 
needed for a 
particular task is 
usually underlined in 
OOo’s menus.

Quick
tip

 Don’t waste time flitting between screen views – you can 
see both the form and its table on the same screen. 

When you get back to the main UI window, double-click on the 
Household Inventory form to open it ready for data. There’s a little 
bit of a quirk in that when you do this, the database form may 
have a read-only suffix on the title bar, but don’t be concerned; 
entries are saved in the normal manner when input this way. 
Depending on the way that OOo has been set up on your machine, 
you may have the right toolbars enabled already. If the navigation 
toolbar is not positioned along the bottom of the window (it has 
Back, Forward, Save, Undo, etc buttons on it), do View > Toolbars > 
Form Navigation to put it there.

Get typing
We put some data into the database last time using the table 
option, so some records will already be filled out. You can navigate 
through these by using the Back and Forward buttons on the 
navigation toolbar; or to get inputting right away, hit the New 
Record button, which is at the far right of the first section of icons 
(it has an arrow and a little star on it). You should now be faced 
with a blank record complete with a cursor blinking expectantly in 
the first field, which would usually be the ID field. You can now 
begin typing the data into the various fields, tabbing between 
them – which was where the Tab Order option came in earlier – or 
selecting each field in turn with the mouse. Once a record is 
finished, hit the New Record button again. This will save the 
current record and offer up a new blank one ready for data.

The navigation bar along the bottom holds tools such as filters 
and sort options, an undo button, a Delete Record option and, at 
the far right of the toolbar, an icon that displays both the database 
table and the form, which is very useful for examining the detail of 
an item and its relationship to other data within the database.

Turning data into information
So far we’ve worked on the structure of the database and getting 
data into tables. Both of these are vital to get right, but the thing 
that databases are really good at is turning data into usable 
information – and this means using queries. Don’t panic: whether 
you know it or not, it’s likely that you’re already very familiar with 
the concept of database queries, as every time you visit Google 
and enter a search string you’re creating a query. The internet can 
be regarded as a massive database, and the reliability of Google’s 
search results are based on the way it has categorised that 
database. As an example, let’s think about a standard search for 

Linux Format. From the front page, we enter the search string 
‘Linux Format’ and hit the Search button. Google is actually going 
to search for ’Linux’ and ’Format’, and so a page with both those 
words in will be 
closer to the top of 
the list of results 
than pages that 
feature only one of 
the words. Now 
imagine the table 
that this search is using. One column might be labelled ’Linux’ and 
one might be labelled ’Format’ and the database would give 
priority to pages that were included in both columns.

In database terminology, a query is simply a way of filtering 
your data to look at a subset of the entire database. We looked at 
filters last issue, and the idea of queries is basically the same – 
except that with a query we can save these criteria and run it at 
any time, or refine it as needs change. Let’s look at an example.

This example will move on from the Household Inventory 
database (which is a bit small for meaningful querying – I need to 
buy more stuff!) and on to another real-world project, an essay-
specific bibliography created from a list of books and journals 
referenced throughout the university year. This can be tailored to 
any database – your fields will just have different names. For the 
HOWTO, read the Step By Step on the opposite page.

The other side of the search coin is reports. These do the same 
job as queries, with the added advantage that the results are 
output as a table in OOo Writer that can be printed and distributed 
in the usual manner. The process of creating a report is very 
similar to that of building a query, but with an extra section in 
which we can choose a style appropriate to the data being 
presented. Again, OOo Base saves the report criteria under the 
Reports tab, which means a report can be run on the same 
database a number of times as the data changes.

OOo Base is capable of managing a larger projects such as 
membership lists and stock inventories as well as small data sets. 
I’ve covered the basics over the past two issues, but the elements 
are applicable across the whole range of applications. Always 
remember that a useful database depends on your getting the 
structure right, so spend as much time as possible refining it from 
the ground up, and you’ll find it much easier to get to the data. LXF

Linux desktop environments and applications feature a standard 
way to select icons or files with the mouse: the left mouse button. 
Once an item has been clicked on, some visual change will occur 
to tell you that the icon, option, file, whatever, has been selected – 
usually the icon will be enclosed in a border, or the background 
colour of a text label will change.

Sometimes, though, we need to select more than one item in a 
folder, and to do this we can use either Shift+click or Ctrl+click. 
The former is for selecting a range of files that are adjacent in a 
file manager or file browser list, while the latter is for selecting 
non-adjacent items in a list.

Shift+click involves clicking on the first option with the mouse 
button, holding down either of the Shift keys on the keyboard and 
then clicking on a second file on the screen. Everything between 
the two clicked items will be selected and can be edited, cut, 
copied or dragged to a different location. Ctrl+click involves 
clicking a first object, holding down the Control key and clicking 
again – this will select only those files that you have clicked, and 
you can select as many files as you like.

Object selection tips

“Every time you visit 
Google and enter a search 
you’re creating a query.”
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