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Organise your office
 with OpenOffice.org
Learn your way around this stylish and effective alternative to MS Office.

IF YOU’RE using Linux as your primary 
desktop, sooner or later you’ll want to use 
OpenOffice.org. It competes directly with 

Microsoft Office, and comes with so many features 
that it would take months to truly master it. If you’re 
like most people, though, you’ll only ever use a tiny 
fraction of the features that come with this office 
suite – word counts, charts, animations and the like 

– for which the learning curve is nice and gentle.
OpenOffice.org (usually referred to as just OOo) is 

made up of several individual components:
■ Base Database.
■ Calc Spreadsheet.
■ Draw Art tool.
■ Impress Presentation creator.
■ Math Formula tool.
■ Writer Word processor.

In practice, only four of these see much use. 
Draw is really little more than a cut-down version of 
Impress, and there are other art programs for Linux 
that are far more useful (notably Gimp). Math, 
meanwhile, offers far more power than anyone 
needs unless they are doing a degree in 
mathematics! That leaves Base, Calc, Impress and 
Writer : database, spreadsheet, presentation tool and 
word processor. Each shares the same look and feel, 
and if you’ve used Microsoft Office you’ll already be a 
long way towards understanding how they work.

BEFORE YOU START
OOo is perfectly happy working with Microsoft Office 
file formats, so you don’t need to worry about 
opening Word documents and so on. But it also has 
its own file formats, which save just as much 
information and are frequently less than half the size 
of Office formats. The downside is that Office does 
not support OOo documents, which means you need 
to use the Office formats if you want to retain 
compatibility with Microsoft users. The first time you 
run each OpenOffice.org program you’ll see a box 
similar to the one shown at left, where you get to 
choose the default format for each program.

The OpenOffice.org user interface is slightly 
different from its Office equivalent, particularly in 

Impress. Part of this is because of differences in 
naming (Office and OOo have wizards to help you 
work, but OOo calls them AutoPilot), and part is 
differences in positioning of menu items and buttons. 
If you’re having problems, be sure to look up OOo’s 
comprehensive documentation from the Help menu.

Finally, you should know that OOo has several 
great features that either are missing in Microsoft 
Office or come as paid-for additions. For example, 
Writer comes with a built-in PDF writer; and you can 
save your Impress presentations as Macromedia 
Flash movies – great for working on the web.

OpenOffice.org lets you select whether you want 
Microsoft Office or OOo file formats.

OOo shares many of its keyboard shortcuts with 
Office, which means you should be able to jump right 
in and get started straight away. Here are some of the 
most common OOo shortcuts:

WHAT YOU KNOW ALREADY

Tool Shortcut
Cut ....................... Ctrl+X
Copy .................... Ctrl+C
Paste ................... Ctrl+V
New ..................... Ctrl+N
Open ................... Ctrl+O
Close .................. Ctrl+W

Save ......................Ctrl+S
Print .................... Ctrl+P
Undo ....................Ctrl+Z
Redo .................... Ctrl+Y
Find ......................Ctrl+F
Spellcheck ................. F7
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 BASE FOR DATABASES
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This context-sensitive 
Help briefly explains the 
options to the left.

If you set this option to 
Document you’ll get to 
see a preview of the 
currently selected table.

The status bar shows 
the type of database 
engine you’re using to 
store your data.

As we’re in the Tables 
tab, our tables are 
listed here. Double-
click to open them.

Switch between 
Tables, Query, Form 
and Reports view 
using these tabs.

These quick links 
vary depending on 
the tab you have 
selected on the left.

The top toolbar lets 
you link to other 
OOo documents, and 
create new Base 
objects (eg Tables).

BASE AT A GLANCE

If you have ever used Microsoft Access, you’ll 
know that sometimes it’s very helpful to be able to 
create a basic database system by yourself – 
perhaps something to store your CD collection, or 
some very basic business information. This is where 
Base steps in for Linux: it’s a graphical database 
designer that makes a very complex problem into 
something anyone can solve.

There are three main ways to use Base:
■ As a table designer and data store. This is where 
you design tables and insert data, then retrieve that 
data later on either through the same table access 
or some other program.
■ As a reports system. This is where you create 
queries on your data, such as ‘Print the names of 
everyone who has a dog.’
■ As a forms system. This is where you use Base as 
a graphical user interface development system: you 
can create GUI dialogs to display your data and allow 
people to change it through them.

Whichever you choose – and you might choose 
all of them – you’ll find that Base is quick and easy 
to learn, so let’s get started!

CREATING A TABLE
When you first start Base you’ll be asked whether 
you want to create a new database or open an 
existing one. For now, make sure that Create New is 
selected and click Next, then select Create Tables 
Using The Table Wizard and click Finish.

The Table Wizard works by offering various types 
of pre-made fields. For example, if you select ‘CD-
Collection’ from the Sample Tables list you can add 
things like Album Title or Artist. Use the Business or 

Personal radio button to choose what types of fields 
you want to add. When you find fields you want to 
use, click the > button to add them to the Select 
Fields list, or use the >> button to add all the fields 
in the Available Fields list. To remove fields, click <, 
or << to remove all of them.

When you click Next you’ll be asked to specify 
the field types for your table: should Artist hold text, 
or do you want it to hold a number that references a 
different table? As we’re using the Table Wizard, Base 
will insert sensible defaults for us here.

The last step before you create the new table is 
to assign a primary key (PK). A PK is designed to 
uniquely identify each row in your table, which 
means that even if you have two friends called 
Richard Hartis in your address book you will still be 
able to differentiate between them. Base can (and is 
set by default to) create a PK for you, so you can just 
click Next on this screen, then click Finish to go 
ahead and create the table.

INSERTING DATA
With a database and table created, you can now 
insert your data into Base. The main window of Base 
shows you all the tables, queries, reports and forms 
you have available; under Tables should be your new 
table, so double-click on it to open it for editing.

The default table-editing view looks a lot like a 
spreadsheet: along the top you’ll see the names of 
your fields (ID, Name, Address etc). Each new row 
you insert is a new row in your table, and you can 
supply values for it according to the fields. Be sure to 
follow the field types you defined when you created 
the table: if a field only holds integers, you won’t be 

able to type ‘Paul’ in 
there. Insert a few 
rows into your table, 
then close it to get 
back to the main 
window. You can if 
you want change your table structure 
after you have inserted data – fields with 
data in will be destroyed, and fields you add will 
have default values entered (usually blank or 0).

GETTING GRAPHICAL
With the data in place, we can perform our finale: 
presenting it in a graphical user interface so that 
everyone can view and edit it.

As with table design, creating a form (a GUI 
window) is done through a wizard. Click the Forms 
tab from the main window, then select Use Wizard To 
Create Form. Base uses Writer for its form design 
and viewing, so this will appear beneath the wizard.

To create a basic form, click the >> button to add 
all your fields to the form. Click Next twice, and you’ll 
come to the screen asking you which layout you 
want. You can change all this later, but for now a 
good option is In Blocks – Labels Above rather than 
As Data Sheet.

Click Next twice more and you’ll come to the 
Styles window. These are very basic options, but 
again you can change these later. For now, choose 
Bright Blue, then click Next. Enter a name for your 
form, then click Finish to bring it up. Along the 
bottom of the form you’ll see navigation buttons, plus 
search options and save/undo controls – these are 
all provided for you by Base. ●
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 CALC FOR SPREADSHEETS
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Keeping track of large data sets isn’t easy, so 
it’s no wonder that most of us turn to spreadsheets 
to help us, be it for an informal job such as 
organising our finances for the next month or a task 
in a business environment such as auditing our 
company’s accounts. 

Fortunately, spreadsheets are easy to learn: if 
you’ve ever used Excel, you will immediately feel at 
home in Calc, simply because the two look almost 
identical. Furthermore, the only real differences in 
the way the two work lie in the look and feel, and if 
you’ve tried your hand at Writer you’ll already be 
familiar with the way OOo works.

As with Writer, Calc does a great job of 
importing Microsoft Office documents, but it also 
has problems importing documents that have 

passwords attached. If you want to import protected 
documents, you will need to remove the password 
using Excel beforehand.

BASIC CALCULATIONS
Like most spreadsheets, the main focus of Calc is its 
data grid. Along the top are the columns, labelled 
A to Z, then AA, AB, AC, and so on. Along the side 
are the rows, numbered 1 to 32,000. Each box in 
the grid is called a cell, and is usually referred to by 
its column and row positions (A3, B9). 

And again, as with other spreadsheets, the real 
power in Calc is being able to program cells to 
contain an equation, so that it displays the result of a 
sum based on other cells. To see this at work, let’s 
enter 100 in A1, 200 in A2, 300 in A3, and 400 in 

A4. In A5, enter =SUM(A1+A2+A3+A4). 
This will add up all four cells, and place the 
result (1,000) into A5. If you now change the 
value of A1 to 50, A5 will also update to read 950.

There are quite a few different types of 
calculations you can use in your equations. Adding 
A1 to A4 can be done with three plus signs, as in the 
previous example, but a much smarter route is to 
specify a range of cells to add using a colon. So, 
rather than =SUM(A1+A2+A3+A4), you can use 
=SUM(A1:A4) to add up everything from A1 to A4. 
You can also multiply, using an asterisk; and divide, 
using a forward slash, so =SUM(A1/A2) would divide 
the first cell by the second.

More advanced calculations can be done using 
more brackets. For example, if you want to add A1 
and A2, multiply by A3, then divide by A4, you 
would use =SUM(((A1+A2) * A3) / A4). You can also 
use different kinds of mathematical functions; SUM 
itself is a simple function, but you can use MOD to 
calculate modulus, AVERAGE to calculate the mean 
average, or MAX to display the maximum number in 
a range. For example, =AVERAGE(A1:A4) will add up 
A1, A2, A3, and A4, then divide by four (the number 
of cells added).

FILTERING AND SORTING
Once your data is inserted, you’ll want to be able to 
manipulate your view of it so that 
you can read it more easily. There are two ways of 
doing this: sorting rearranges the rows in the order 
you specify, and filtering selectively hides fields by 
removing the ones that don’t match your criteria. 

The most basic filter is AutoFilter. It’s easy, and it 
works like this: select the rows and columns you 
want to filter (including the title of that row, such as 

HOWTO… ADD A GRAPH

Select the fields from which you want 
to make a chart, then go to the Insert 

menu and select Chart.

Click Next on the first screen that 
appears, and you’ll be prompted for a 

chart type. Just click Next for a bar chart.

Click Next again to choose the default 
bar chart variant, then enter your chart 

title and any axis titles on the next screen.

You can sort by up to three fields in Calc, which should be enough even for complex spreadsheets.
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Linux has two popular alternatives to Calc: KSpread 
and Gnumeric. Both have advantages over Calc in 
terms of their features, but neither is quite so good at 
importing Excel documents. If you’re looking for a tool 
to help you enter complicated mathematical formulas, 
try OOo Math.

OR TRY: KSPREAD & GNUMERIC

Name or Age), and go to the Data menu, select 
Filter, then AutoFilter. This adds clickable arrows to 

your column headers that you can click to select 
types of filter. For example, in the picture at left, 
we’ve placed a filter on Name and Score; if we click 
the button next to Score it will show a list of all 
distinct Score values – clicking on one of them will 

set the filter to show only rows that have that score. 
The others haven’t been deleted; they’re just 

invisible. To bring them back, click the button again 
and select All For Score.

Sorting is just as easy. Again, select the rows you 
want to sort (including the column header), then 
click Data > Sort. This brings up the window shown 
in the picture, which allows you to select how you 
want the data to be sorted. In the picture, there are 
names and scores, but neither is sorted; ideally we 
want to sort it by Score ascending (so a score of 1 
would come before a score of 2), and for any scores 
that are the same it should sort by name. 

To do this you’d set the Sort By field to Score, 
and the Then By field to Name. Unlike filtering, 
sorting is destructive: it rearranges the cells 
according to your criteria, and there’s no way to go 
back to the original except by hitting Undo to reverse 
the sort.

FORMATTING YOUR CELLS
Looking at a long list of numbers isn’t easy on the 
eye, but Calc allows you to add colours, borders, 
shading, fonts and other such bells and whistles in 
order to emphasise certain fields and to make 
reading your data easier. As in OOo Writer, Calc 
presents the basic font tools in a toolbar at the top; 

you can use these to change the font name and size, 
set it in bold, italics or underline, and also change 
the alignment. However, it comes into its own in the 
Format menu, particularly in the Cells option. Here 
you can choose how the cell should be treated (does 
it contain currency? Is it a date?), whether you want 
a thousands separator, how many decimal places you 
want and so on.

Along the tabs at the top of the Format Cells 
window, you can also find options to change the style 
of the cell. Under the Font and Font Effects tabs you 
can select the name, size, weight and colour of the 
text, as well as add shadowing and underlining. 
Under the Alignment tab you can choose the angle 
of the lines of text, how much space there should be 
between the text and the grid lines around it, as well 
as whether you want it left-, centre-, or right-aligned.

The Borders tab lets you select the size and 
position of the lines around each cell. To do this, first 
specify the thickness of the line you want, then click 
on the diagram to the left where you want your 
borders to appear. If you’re really feeling artistic, you 
can add shadows to the borders around your boxes 
– if you find yourself doing this, try to remember that 
no matter what you do to your spreadsheet, it will 
still be a big long list of numbers! ●

What do you do if you know what the 
result of an equation should be, but you 
don’t know what input to give it to get that 
result? The answer is Goal Seek (under the 
Tools menu). To use this, select the cell 
with the equation, and click the Goal Seek 
menu item. This prompts you for the target 
value (what you want the equation result 
to be), and the variable cell (the cell you 
want to change to get the result). When 
you click OK, Calc will try all possible 
values for the variable cell until it finds the 
result you’re after, and if it finds a suitable 
number it will prompt you to accept it.

GOAL SEEK

Goal Seek is the fastest way 
to get the result you want from 

your equations.

  

Click Create to create the graph and 
embed it into your worksheet. You can 

then resize it and edit it all you want.

“Looking at a long list of numbers isn’t 
easy on the eye, but Calc allows you to 
add colours, borders and shading.”
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The only thing worse than listening to an 
hour-long lecture is listening to an hour-long lecture 
accompanied by a really bad slideshow presentation. 
And Linux hasn’t escaped this. As good as the 
PowerPoint-like Impress is, it’s still easy to churn out 
dull presentations by overusing animations and font 
styles, so we recommend you read this carefully!

As you’ll have come to expect by now, Impress 
looks and works just like its Office counterpart. When 
you start it up, you’ll see a blank slide ready for you 
to add content to, and also a control window where 
you can add new slides. To get started, click on the T 
icon in the bottom toolbar, and drag a text box on to 
your slide. Enter the title, ‘50 Tips for Better Photos’, 

and give it a nice large font using the font selection 
tools above. Put another line of text beneath it, 
giving your name and the date, again in fairly large 
type so it’s easy to read. If you want to change the 
colour of the text or add any effects to it, select it 
and right-click, then choose Character. If you have 
more than one line of text, you can choose 
Paragraph from the same menu to change how the 
lines fit together.

That’s enough for the text: now let’s add a 
background. From the Insert menu, click Graphics. 
This brings up a filesystem dialog where you can pick 
which picture to import. There are lots of good 

backgrounds bundled 
with Linux; these are 
stored in the /usr/
share/wallpapers 
folder, and you 
should be able to find 
something that suits your taste in 
there (hint: click the Preview checkbox at the 
bottom of the dialog to have OOo show you the 
picture before you open it). We’ve used 
Blue Bend, which is a nice and natural background 
for the text. 

When you click Open, Impress will place the 
picture on your slide, but the chances are it won’t fit. 
If not, just right-click on it once, then use the 
handles at the edges of the picture to resize it to 
your needs.

Although the slide probably looks OK, we can do 
a bit more to spice it up. Draw another rectangle to 
the left of your text, from the top to the bottom of 
the slide. From the toolbar choose a colour that 
works well with your background – in the example at 
left we’ve used Blue 2, which is a fairly dark, 
purplish colour. Now the magic: right-click on your 
new rectangle and select Area from the menu – this 
is where you can customise how your box will be 
filled. Go to the Transparency tab and set the 
transparency of your box to 50% to make it see-
through, but not invisible. When you click OK, you’ll 
be back at your slide and it should look quite 
respectable – well done!

MAKING A MOVE
You probably can’t wait to start making individual 
letters fly in from the side of the screen as in all the 
best PowerPoint presentations, so let’s look at some 
animation tricks. Select the main title of your slide, 
and choose Effects from the Slide Show menu. Here 
you can apply animation effects to the object (the 
text container) and the text itself, add sounds to Some text, a background picture and a little transparency are all it takes to inject a bit of style.

IMPRESS WORKSPACES EXPLAINED

There are five ways of looking at your 
presentation, and you’ve already seen one: the 
Drawing view. Shown above is the Outline 
view, which gives you a basic list of the 
content in your slides as well as a preview. 
Drag and drop things to move them around.

The Slides view lets you see all your slides in 
miniature, so you can see how the presentation 
fits together and reorder it if need be. If you 
right-click on a slide you can set slide 
transitions, and also temporarily hide the slide if 
you have last-minute changes.

The Notes view acts as a prompt for you if you 
forget your lines, but also as a quick and easy 
print-out for your audience. Each slide note 
prints to a page of A4, and includes the slide 
itself plus your accompanying text.

OUTLINE SLIDES NOTES
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The standout feature of OOo Impress is its ability to 
export presentations, complete with animations, to 
Macromedia Flash format. Flash is popular on the 
web, and most web browsers come with a Flash 
plugin so that people can view Flash movies through 
their browser. Although you can save in Microsoft 
PowerPoint format, using Flash for your final export 
means that you can build your presentation into your 
website rather than having to make it available as a 
separate download. To export as Flash, go to the File 
menu and click Export, then select Macromedia Flash 
from the File Format drop-down box.

HOWTO… EXPORT TO FLASH

coincide with the effects and also order the effects 
so they happen when you want them to. As we’re 
working with the title, we should apply the effects to 
the text rather than its container, so click Add from 
the Custom Animations window on the left. There are 
quite a few effects to choose from – you can make 
the text slide around, appear in a dissolve, spiral 
around or, inevitably, fly in letter by letter. To do that, 
select the Laser effect and choose where you want 
the letters to appear from.

Still in the Custom Animation window, you can 
select other objects in your slide and assign 
animations to them. When you’ve animated 
everything you want to, click the last button in the 
window (it has the text ‘1…9’ on it) to order the 
effects as you want them. For example, if you want 
the title to animate after the subtitle, just drag the 
title object (it will be called something like ‘Object 1 
(Text Frame ‘50 Tips’)’) under the subtitle object.

TEXT BOXES COME ALIVE!
It’s also very easy to transform your text boxes and 
graphics into clickable buttons that you can use while 
giving the presentation. As an example, let’s create a 
small exit button we can put at the bottom-right 
corner of our slide, which will take us out of our 
presentation when clicked. 

Click the T button from the bottom bar, and 
create a small text box in the bottom-right corner. 
Type the word EXIT in there, then select a nice bold 
font. Right-click on the text and select Character, 
then choose the colour white for it as well as any 
extra text effects you want. Click OK, then go to the 
Format menu and select Area. By default, the Fill is 
set to None, but you should change that to Color, 
and pick something bold like red. Now go to the 
Shadow tab, tick the Use Shadow box, then set the 
shadow 0.06 inches away from the box, coloured 
black, with a transparency of 50%. Click OK again, 
and you should have a small graphic button, ready to 
be clicked on to exit. 

Of course, we haven’t attached the exit action 
itself yet. To do that, go to the Slide Show menu and 
select Interaction. From the window that pops up, 

choose Exit Presentation for the Action At Mouse 
Click option, and click OK one last time – and 
you’re done!

To try out all these animations and interactions, 
you need to actually run the slide show. Hit F9 to 
view the slide show, and try clicking your new 
Exit button.

TEMPLATES AND MASTERS
So far we’ve been working only on one slide, but 
when you have a whole presentation to create it will 
save time and lead to a more professional document 
if you can make each slide look consistent without 
having to design them all from scratch. The easiest 
way to get uniformity is by using a slide master, which 
is where you put together the basic design of the 
page without any of the text or graphics that change 
from slide to slide. In our case, that’s the picture 
background, the blue box and the Exit button. 
Moving these to our master slide has the advantage 
that all new slides will have these elements on 
automatically. Furthermore, when you’re editing 
slides, you aren’t able to move or otherwise adjust 
any of the master elements by accident.

To set up a master slide, select the elements you 
want to move to the master and cut them to the 
clipboard by pressing Ctrl+X. Now select the View 
menu, then Master, then Drawing to bring up the 
master drawing slide. It’s probably largely blank at 
this point, and you should see a small Preview 
window appear, which shows you how the first slide 
looks given the current master. Hit Ctrl+V here to 
paste the elements in, and you should see the 

preview update to reflect the new master. To get 
back to your slides, click View > Slide.

The other option is to use a stock layout for your 
slides, and Impress has a number of these templates 
to choose from. With your slide selected, click the 
Modify Slide Layout from the helper window (where 
you insert new slides), and it will bring up a window 
where you can choose from a list of AutoLayout 
options – pre-made text layouts that include text 
boxes, pictures, bulleted lists, and a host of others. ●

Finally, the Handouts view fits several slides on 
to one A4 page so that you can easily give 
printed copies of your slides to your audience. 
Right-click on the Default tab near the bottom 
of the screen and select Modify Slide to change 
the arrangement of slides per page.

Keep your layout consistent by using a stock slide design for all your slides.

The KDE KOffice suite (responsible for KWord and 
KSpread) also comes with KPresenter, which performs 
many of the same functions as OOo Impress – and 
many people find it easier to use.

“It’s very easy to transform your text 
boxes and graphics into clickable 
buttons to use in the presentation.”

HANDOUTS

OR TRY: KPRESENTER
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OOo Writer is a powerful word processor that 
offers really helpful features such as spellchecking, 
change tracking, mail merging and lots more. On the 
surface it looks similar to Microsoft Word, so if you’re 
a former Word user you should be able to pick it up 
quite easily. Things like the font selection tools and 
the text formatting buttons (bold, italics, underline 
and alignment) are all by default in the place you’d 
expect them to be – just above the document 
window. The icons are a little different, but follow the 
same theme as in Word. 

Each button that has a small blue arrow next to it 
holds a drop-down menu – if you click on it briefly, it 
will take a default action, but if you click and hold 
you will get a menu with more options. Some 
buttons, such as the font and background colour 
buttons, bring up miniature windows when you click 
and hold. If you drag the background colour window 
away from the button it will stay visible even after you 
choose a colour.

One notable difference from Word is that Writer 
pops up a Paragraph Styles window when you start. 
This underlines the fact that Writer places far 
greater emphasis on predefined ‘styles’ for different 
parts of text than Word does. For example, to make 
headings stand out in Word, most people just change 
the font size and weight in the Formatting toolbar, 
but in Writer you’re encouraged to use the Paragraph 

Styles window to accomplish the same thing. If you 
need to bring the Paragraph Styles window back up, 
press F11 or click the Stylist button from the toolbar 
(it’s the one next to the gold star). To style text up, 
just select it with your mouse, then click the style 
you want to assign it. 

These styles are about more than just formatting. 
Writer considers a heading style not only to be larger 
and bolder than normal text, but also to have special 
responsibilities when it comes to generating a table 
of contents or index.

OPEN AND SAVE
As in Word, documents are opened and saved 
through the File menu. In OpenOffice.org, each of 
these dialogs is capable of opening any type of file – 
if you’re in Writer and open a Calc document, say, 
OOo will just fire up Calc and load it in there. The 
default format for opening files will depend on what 
you chose when you first started Writer, but you 
should find both OpenOffice.org Writer and 
Microsoft Word, be it 97, 2000 or XP, in the File Type 
drop-down box. 

Most types of Microsoft Word document can be 
loaded, although files that the writer has locked 
with a password can’t. This works going the other 
way, too – so you can’t save Word files with a 
password from OpenOffice.org.

Both the Open 
and Save windows 
have three buttons 
along the top to 
help you navigate 
around your 
filesystem. From left to right they: move 
up a folder (to the parent directory); create a 
new directory; and navigate directly to your 
home directory.

If you want to send your document to someone 
who has neither Word nor OpenOffice.org, or if you 
simply want to fix the layout to make the document 
easier to print, you can save to a PDF file directly 
from OOo. You can only do this in MS Word if you’ve 
paid for a commercial plugin, but in OOo Writer it’s 
free, and as easy as clicking Export As PDF from the 
File menu. 

Once you’ve done that, OOo will ask you two 
things: which pages you want to export, and how you 
want them saved. You’ll probably want to save all the 
pages as PDFs, so leave the top half of the dialog 
alone. In the bottom half you need to choose the 
quality of the PDF - Screen Optimized is the lowest 
quality, and Press Optimized is the highest.

Using just plain text, this document looks 
quite dull. We need to spice it up with 

some clip art – some sort of warning colouring 
would do it.

HOWTO… ADD CLIP ART 

All OpenOffice.org’s stock images and 
sounds are stored in the OOo Gallery, 

located under the Tools menu.

Select the clip art you want, then drag it 
where you want it in the document. In 

our example, that’s just below the header.

Drop in as much clip art as you want, 
then click the Gallery item on the Tools 

menu again to close the Gallery window.

The Writer Word Count function is in a different 
place from Word’s. To find it, go into the File menu, 
select Properties, then choose the Statistics tab from 
the window.

WORD COUNT

The PDF’s compression level affects its quality.

CORRECTING MISTAKES
Before you send anything out, you might want to use  
Writer’s spellchecker to double-check your work – 
even if your spelling is good! To activate the 
spellchecker, go to Tools > Spellcheck, then Check – 
or just hit F7. As with most spellcheckers, you can 
replace your questionable words with corrections, or 
add words to a custom dictionary so that OOo learns 
your vocabulary. You can also jump to the Thesaurus 
for synonyms.

If Writer isn’t using the correct language for its 
checks – perhaps using UK English rather than US 
English – go to Tools > Options > Language Settings 
to change the default language for new documents.
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Creating a table with the flyout tool is faster than 
using the dialog, and is much more visual.

While you’re in Tools, you might want to turn off the 
Word Completion feature. This stores words you type, 
and offers to complete them for you later on. It’s 
enabled by default in OOo, but most people find it 
annoying. If you’re one of them, disable it by going to 
Tools > AutoCorrect > Word Completion.

ADD TABLES AND GRAPHICS
It’d be a shame not to explore some of the more 
under-used features common to word processing 
programs, such as inserting graphics and data into 
your document. Writer is certainly capable, as you’d 
probably expect by now, of these tasks. 

The easiest way to add a table to your document 
is by using the Table menu. From there, go to Insert, 
then Insert Table, and a window will appear where 
you can specify the number of rows and columns 
you want, whether you want a header and border, 
and whether Writer should be allowed to split the 
table across pages (see image, top). 

If you prefer a more graphical way of working, 
click and hold on the first button on the toolbar to 

bring up the flyout, then click and hold on the grid 
icon (by default, this is usually third from the left) to 
bring up the quick table creator. Drag your mouse 
down and to the right to make the table larger, then 
click when you want to insert it.

The toolbar along the bottom is the place to get 
started with your own graphics. The icons along here 
offer you a variety of drawing primitives, such as 
straight lines, circles, boxes, curves, callouts, arrows, 
stars and text. 

When making items like these business cards, 
use the Synchronize Labels button to copy 
content from one card to the others.

DESIGNING A FLYER
We can use these tools to design a very simple flyer 
by combining simple shapes with text. 

Start by selecting a rectangle: click and drag on 
your page the shape you want for the flyer and it 
should appear – probably in a light blue colour, 
which is the default. Right-click on it and select Area 

to choose the colour you want it to be, then choose 
Gradient Fill from the window that appears. 
Gradient 3 (a yellow to red fade) should do fine, so 
select it and click OK. 

On top of this, we need to place some text, so 
select the text box icon from the drawing group (the 
icon is a big T), and make space over the gradient. 
Type in ‘In the sun?’, then right-click on the text and 
select Character to customise the font style, size and 
effects used for the text. We used the Nimbus Sans 

Linux has several alternatives to OOo Writer, of which 
the most popular are KWord and AbiWord. Both are 
very fast and come with many of the same features as 
Writer, but they aren’t so compatible with Microsoft 
Office formats. 

font at size 40, using white text with a shadow. 
Beneath that, draw another box and add the words, 
‘You need Sunblock 500!’, and colour that white too.

Beneath that you can add all the text you want – 
try to experiment with the various font sizes, colours 
and effects that Writer offers, but also with some of 
the more advanced drawing functionality such as 
Bezier curves.

ADDING A CONTENTS LIST
Having spent hours/weeks/years creating your 
masterpiece, the last thing you want to have to do is 
create the table of contents (TOC) for it – that’s 
something that can be automated, meaning more 
work for Writer and less for you. Hurrah!

Creating an automatic TOC requires two things. 
You need to tell Writer which parts of your text are 
headings, then you need to insert the TOC itself. You 
need the Stylist for this, so press F11 to open it.

Go down to your first top-level heading, select it, 
then choose Heading 1 from the style window. Mark 
your second-level headings as Heading 2, and so on.

Now click where you want your TOC to go, and 
select the Insert menu, then Indexes and Tables, 
then Indexes and Tables again. In the new window, 
click OK to accept the defaults – your new TOC 
should appear where you clicked.

MAKING BUSINESS CARDS
The best way to learn about the program is just to 
dive in and use it, so let’s try making something else 
nice and simple – business cards. Writer has a 
number of AutoPilots to guide you through various 
basic types of document – the Business Cards 
AutoPilot will help us here. 

The first thing you need is some perforated 
business card paper, available from most high-street 
stores. This is plain sheets of A4, with business-card 
shaped perforations, allowing you to print on to 
them, then easily pop them out. Writer knows how 
big each business card should be for a number of 
different brands of perforated paper; if you’re able to 
buy one of these brands you’ll have the easiest job, 
but often as long as the cards you buy are a standard 
size you should be OK. 

Go into Writer and click on File > New > Business 
Cards to bring up the AutoPilot. Then select the 
brand name and type of paper (or the ones that are 
closest to the type you bought), and click on New 
Document. Writer will create a new document 
matching your paper type – you’ll see it has divided 
up the page into card-sized blocks. Each of these 
represents one finished card, but you don’t need to 
fill them out individually. Instead, just design the one 
in the top-left corner, then click the Synchronize 
Labels button to have it copied over to the other 
labels. Writer really is easy to use. Enjoy it! ●

“If you’re sending your document to 
someone, you can save it as a PDF. 
This is as easy as clicking a button”

OR TRY: KWORD & ABIWORD
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We’re coming to the end of our tour of 
OpenOffice.org, but you’ve only really taken 
the first steps to being an advanced user. 
Here are our top 18 tips to help you progress. 

 ALL PROGRAMS
MACRO MAGIC

 1
If there are tasks you perform regularly, 
such as adding a style and a colour to a 
particular word, then you should try 

OOo’s macro systems. These are simply groups 
of actions you can record and play back at will, 
effectively performing actions for you. To record 
a macro, click on Tools > Macros > Record 
Macro. Do all the actions you want, then click 
the Stop Recording button. You’ll need to assign 
each macro a name when you have recorded it, 
and when you’ve done that you can re-run the 
macros from the same Macros menu as before.

THE STRONGEST LINK

2
All OpenOffice.org applications are capable of 
Object Linking and Embedding (OLE), which 
is a technology that allows you to embed files 

from one OOo app in another. To try this out, go to 
the Insert menu, select Object, then OLE Object. 
From the screen that appears, select Create From 
File, then click Search to select an OOo file from 
another application. When you click OK, it will be 
inserted in to your current document as you would 
see it normally. However, the real magic comes when 
you double-click on the object – you will see all the 
menus and toolbars change to look like the 
application it belongs to!

TURN OFF THE ASSISTANT!

3 
By this time you’re almost certainly sick of the 
OOo Help Assistant, which pops up regularly. 
Granted, it’s not as annoying as Clippy from 

Office – this one doesn’t say things without you 
clicking on it – but most people turn it off anyway! To 
do that, go to the Help menu and deselect the Help 
Agent option – and it’ll never bother you again. 

 WRITER
TRACK CHANGES

6
Anyone who has to work in a group 
environment should know that changing 
someone else’s documents is easy enough – 

the hard part is telling them what you’ve changed. 
Writer has help at hand through its Track Change 
features. Go to the Edit menu, select Changes, then 
click Record to have OOo monitor what changes you 
make so that others will be able to see them later 
on. If you receive a document set up like this, you 
can go through each change and choose to either 
accept or reject it.

COMPARE DOCUMENTS

7 
If someone made changes to your Writer 
document without change tracking turned on, 
you might think you would have to read 

through the entire thing to spot the differences. 
Fortunately, OOo has a Compare Document function 

Don’t feel restricted to a single-column layout of 
your text: you have the option of more 
sophisticated layouts in the Columns tab. 

 DRAW
GET DRAWING!

4 
Once you’re competent in the presentation 
maker Impress, you can make the jump to 
OOo Draw, the integrated vector art 

package. It looks and works much like Impress 
(although slides are called pages), and you can 
apply your new skills to it. We don’t have space 
here to cover the 3D artwork, which really is 
Draw’s highlight. You can drop cubes, spheres, 
cones and cylinders on to the page, then move 
them around in 3D. If you right-click on a 3D 
shape, you can also adjust the lighting and many 
other options in the 3D Options dialog.

GET CONNECTED

5 
When you’re using Draw to make 
flowcharts, don’t waste your time drawing 
and redrawing lines between the shapes – 

when you move the shapes, the lines won’t follow. 
Instead, use a connector (it’s to the right of the 
Line tool on the bottom toolbar), as this 
automatically redraws itself to follow the shapes 
you’ve attached them to.

3D shapes galore: squares and spheres, cones 
and cylinders all come with movable lighting, 
custom shading and metallic finishes. Draw is 
a pretty sophisticated art application.

hidden away in the 
Edit menu that will scan two documents 
and report the differences for you. To use 
it, open the first document, then click 
Compare Document; it will then prompt 
you for the second document. Once the 
comparison is complete, OOo will list the 
changes for you to accept or reject, as 
with change tracking.

SAVE ON RAM

8 
If you’re working on a 
document in Writer that’s 
packed with pictures and your 

computer is starting to slow down as a 
result, click View > Toolbars > Tools, 
then look for the icon that has a 
square, a circle and a triangle on. 
Clicking this hides all the pictures in 

your document. To get the pictures back, click the 
button again. 

PLAY WITH FONTWORK

9 
If you’re looking to do cool or unusual font 
effects, you should try out Fontwork. Select 
the text you want to play with, go to the 

Format menu, then choose Fontwork; this brings up 
a window full of options. The first part of the window 
lets you select a path the text should follow – do you 
want it to go left-to-right? Do you want it to curve 
upwards, or go around in a circle? Do you want the 
text to be placed directly on to the path, or be 
curved according to the path? You can choose all 
this and more, but we suggest you save your work 
before trying anything!

NEWSPAPER COLUMNS

 10 
Writer uses a one-column layout by 
default, which means that your text reads 
from the far left of the page to the far 

right of the page on each line. If you want to change 
this to use two or more columns, click the Format 
menu, then Page, then select the Columns tab from 
the window that appears. Here you can choose from 
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 IMPRESS

REUSE BUT DON’T TELL

 11
If you’re planning to give the same 
Impress presentation several times over 
different days, don’t bother changing the 

date on the slide each time you give the 
presentation. Instead, use the Date Stamp field, 
which automatically shows today’s date. To do this, 
go to the Insert menu, click Fields, then select 
Date (Variable).

LOW-QUALITY 
DISPLAY MODE

 12 
Working with complex slides on a slow 
machine isn’t fun: it can turn a 
five-minute editing job into an hour-long 

slog simply by chewing up more resources than 
your system has. Fortunately you can change the 
quality that Impress uses while you work by setting 
the Display Quality option under the View menu. By 
default it’s set to Color, but you can also choose 
Grayscale, Black & White and High Contrast. The 
latter is particularly helpful if you want to design 
your presentation to save eye strain, without 
affecting the final result.

EXPAND AND SUMMARISE

 13 
There are two helpful options under the 
Insert menu in Impress that can save 
you a lot of work. The first, Expand Slide, 

turns all the top-level headings in a given slide into 
slides in their own right. So, if you have a slide 
called ‘Fishing Techniques Made Easy’, which has 
the headings ‘Rod’, ‘Tackle’ and ‘Bait’, using the 
Expand Slide button will create three new slides – 
one each for the three headings. 

The second helpful option under this menu is 
Summary Slide, which creates a new slide 
containing the top-level headings of the current 
slide and all that follow it. Most presentations end 
with this sort of wrap-up slide anyway, and this 
saves you making it yourself.

PRACTICE MAKES PERFECT

 14 
Getting the timings right on your Impress 
slideshows is no easy task, particularly if 
you have complex animations or lots of 

slides. The solution here is to rehearse again and 
again until you get it right, and Impress can help 
you do that with the Rehearse Timings option 
under the Slide Show menu. This goes through 
your presentation as normal, but runs a timer in the 
bottom-left corner so you can make sure you’re 
working at the right pace.

OFFICE SOFTWARE

We’ve only had time to scratch the surface of 
OpenOffice.org’s features – it’s absolutely huge, so 
have fun exploring. For more guidance around the 
suite, tutorials and access to the project’s user mailing 
list, visit http://support.openoffice.org/index.html. 

 BASE
AUTOMATIC KEYS

 15 
Understanding primary keys is not fun, 
and so is best left to people who have 
read books on the topic. For the rest of 

us, Base can add an incrementing integer ID field, 
assign it to be the primary key, and thus ensure that 
it exists and is unique without us lifting a finger. The 
key is to do nothing: design your table as normal, but 
don’t add a primary key. When you click Save, Base 
will offer to make one for you.

 CALC  
TRACK YOUR FORMULAS

 16 
Building complex formulas often results in 
data being drawn from a very large 
spreadsheet. In this situation, how can 

you find out what caused an unusual result? Use the 
OOo Calc Detectives, available from the Tools menu. 
For example, if you select a cell that relies on input 
from other cells, go to the Detectives list and choose 

Trace Precedents to have Calc show you which cells 
are used in the formula.

FORCED INPUT

 17 
You can force a Calc cell to only accept 
values within a certain range through the 
Validity options under the Data menu. The 

Criteria tab lets you specify what size and type of 
numbers you want to accept, but you can also use 
the Error Alert tab to set a message that should 
appear if someone tries to ignore the rule. 

FUNCTION REMINDER

 18 
Calc has functions to perform all sorts of 
calculations, but we’ve only looked at 
SUM, MOD, and AVERAGE so far. Rather 

than try to memorise all the various functions, you 
can just click Insert > Functions to get to the full list. 
This shows you all the functions available, and also 
tells you what each does, and what it would return 
given sample input. You can also get to this window 
by pressing Ctrl+F2. ●

“The Object Linking and Embedding 
tool enables you to embed files from 
one OOo application in another.”

The Rehearse 
Timings option 
in Impress 
shows a timer 
to help you 
ensure all the 
animations and 
slide transitions 
take place at 
the right time.

Object Linking and Embedding lets you insert a 
Writer document into Draw, or vice versa.

WHAT NOW?

five basic column styles (one, two, and three 
columns), but also set custom widths and separator 
lines. Perfect!
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