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DESKTOP PUBLISHING

Desktop publishing
with Scribus

Don’t stop at word processing — use your imagination to create stunning documents for print or the web.

® FOR MOST document tasks, OpenOffice

/ will provide you with all the software you
need. It is possible to create quite complex

documents even using just 000's Writer. However, if
you need to go that little bit further, with tighter
control of fonts or graphics, precise positioning of
elements and more complicated, multi-page
structures, you will need some page layout software.
Scribus is currently the most feature-packed
graphical desktop publishing (DTP) software that
Linux has. The project is still quite new, but it has
improved dramatically in its few short years.

On the next few pages we'll show you how to get
up and running with Scribus, tackling basic layouts
and using images and type. Most distributions come
with plenty of fonts, covering the usual types you
need for a well-designed document, but you might
want to make sure you have some suitable images
ready as well.

SCRIBUS AT A GLANCE

The toolbar holds all the tools you need. Hold the
mouse pointer over them to see what they do.

This document navigator helps
you flip through the pages.
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Lorem Ipsum dolor sit amet. consectetuer adipiscing eflt. Ut a
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The rulers help position
elements precisely.

Text and images all
belong in boxes!

The Properties window is a quick and
easy way to alter objects on the page.

CREATE A DOCUMENT FROM A TEMPLATE

N13:81 OPEN A DOCUMENT
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When you open Scribus, you're faced with a rather
uninspiring grey window. In order to get to work, you
need to create a document! As with most DTP
software, it is possible to create master documents
or templates in Scribus, and some examples are
included. Select File > New From Template.
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Choose the Newsletter 2 style. This doesn't use too
many fonts and is pretty simple in terms of layout.

You can now get to work filling the newsletter with
real stories. To change the text, simply double-click

Once you select it, the document is created,

complete with dummy text and graphics. You should
save (through File > Save or Ctrl+S) before you start

making changes.
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in one of the text boxes. Then click and drag the
cursor to select the text, and type your own over the
top. And that’s it! Follow the rest of this tutorial for
tips on graphics and text.
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MAKE A TEXT BOX
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N13:24 FIND THE CURSOR
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In any Scribus document, text is always contained in
a text box. You can create a new text box by
selecting the Text tool (the eighth icon along in the
toolbar) and dragging out a rectangle.

13:X:3 ENLARGE YOUR TEXT
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Once you've dragged out the shape to the right size,
double-click inside the box to get the text cursor.
You can then enter whatever text you like, and see it
slowly fill out the text box you created.

2113:81 CONSULT STYLESHEETS
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Of course, the default size, style and font may not be
what you were after. For a document heading or a
headline for a story, you'll probably want something
much larger, and perhaps in a different font and
colour from the main text.

113: X ADD PREFERENCES

Select Tools > Properties to get the Properties
window to appear. This controls various aspects of
the selected object, and is an easy way to quickly
change various attributes. Click on the Text button,
select the text then enter something larger, such as
64pt, as the font size.

Y13: 4 LINK COLUMNS
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As is common in DTP software, Scribus lets you
create stylesheets. It certainly makes things easier
not having to remember all the properties you need
to change for a headline, or body text. To create a
paragraph style, select Edit > Paragraph Styles from
the menu, and click on New.

113:%:1 USE THE STORY EDITOR
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Here you can set up common character properties,
such as colour, font, size, spacing and leading,
making sure that your text is consistent throughout.
You can also easily load and save styles from other
documents. Note the spacing options at the bottom,
which make it easy to set up indented paragraphs.
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Most pages contain columns of text, where the text
runs on from one column to the next. To achieve this
in Scribus, drag out two text areas. Fill the first with
text (try right-clicking and choosing Insert Sample
Text). Then click on the Link tool (fifth from the right)
and click on the next text box.

LXFS07.scribus 55

For editing large stories across many columns, you
can edit the text in the easy-to-use Story Editor
instead. Right-click on any column and choose Edit
from the pop-up menu. The entire text will now
appear in a new story editor window, where you can
edit it as much as you like.
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Although there are lots of text controls, it is
sometimes easier to deal with text as a graphic.
Select the text box and choose Item > Convert To
Outlines. You won't be able to edit the words now;
each letter is a separate graphic, and can be
transformed as if it were an image.
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=54 WORKING WITH GRAPHICS

113:41 IMPORT YOUR IMAGE
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Y13:4 RESCALE IT
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To include an image in your document, you need to
create an image box, then import a graphic. Scribus
understands a number of file formats, but it’s best to
stick to PNG and JPEG images. Import graphics from
the File > Import menu.

13:X:] CREATE LAYERS
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The chances that your graphics box and the image
are exactly the right size for each other are a little
remote. So you'll usually have to rescale the image.
To quickly make the box fit the image, right-click and
choose Adjust Frame To Picture.
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If your imported images don't quite suit the pages,
you can send them to an image editor for tidying up.
Right-click and select Edit Picture. Scribus will open
the picture with Gimp, and wait for you to save and
exit before re-importing the graphic.
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When dealing with lots of images (and text boxes), it
may be easier to arrange the graphics in layers.
Choose Tools > Layers from the menu to open the
layer window. Here you can create new layers, and
select which you want to edit. Objects can be moved
between layers from the right-click menu.

N13: 1 MANAGE IMAGES
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For many documents, you'll want the text to ‘run’ or
‘wrap’ around images and other graphics. In the
Properties window, select Shape and then click on
the button marked Text Flows Around Frame. The
image must be brought to the front of any text (use
the right-click menu to do Level > Raise).

13:%: DRAW SHAPES
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Go further with the contour path, which easily wraps
text around irregular objects. Still in the Properties
window, select Shape > Use Contour Line. Now click
on Edit Shape and select Edit Contour Line in the
new window. Drag the contour points to define the
shape of the image.
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Keeping track of all the images used in a document
can be rather tricky. Scribus has a useful built-in
image manager for this. Select Extras > Manage
Pictures and a new window will pop up. This displays
a table of all the linked images, whether they are
available and if they are set to print.
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As well as images, you can use other graphical
shapes in your layouts. Choose from one of the
pre-defined shapes from the pulldown on the tool
bar, or make your own polygon shapes with the
Polygon tool.
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Regular graphics or text can be saved to the
Scrapbook (with the right-click menu), so that they
can be kept and used whenever required. Choose
Tools > Scrapbook from the menu to see the
contents of the Scrapbook, and just drag elements
on to the page.
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DOCUMENTS, PRINTING AND PDF OUTPUT
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13:81 CHECK THE SETUP

113:4 SAVE AS A TEMPLATE

N13:%] CHECK THE PRINTER

Before you think about printing, check the document
setup. Choose this from the menu and make sure
that the margins are compatible with the printer you
will be using (the actual physical page size can't be
changed at this point).

13X COLLECT FOR OUTPUT
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If you are going to regularly create similar
documents, it will be well worth saving a basic
layout as a template before you go too far with the
specific design. Choose File > Save As Template
from the menu.
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If you are printing from elsewhere, you may find the
Collect For Output option in the File menu useful.
This will gather the document, images and optionally
the fonts into one directory, ready to be copied to
disk or emailed.

1.4 PDF SETTING

For colour output, it's a good idea to check the
preview first. Choose Print Preview from the File
menu. The window that appears is the actual data
that will be sent to the printer. You can check colour
separations by toggling the CMYK (cyan, magenta,
yellow and ‘key; or black) buttons.

ST EXTRAS

Scribus will use the CUPS or another printing

system to output the document, so you don’t need
to worry about special printer setups. If you need to,
you can output to a PostScript file for printing from a
different computer.
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Use the File > Export menu to save out the
document as an EPS, SVG or PDF file. It is also
possible to output the whole document as a
straightforward image, which can be useful for
generating web graphics or thumbnails.
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For PDF output, the requester covers a lot of
additional options. The factors to consider here are
file size and the final use of the document. Image
compression can make the output file a lot smaller,
particularly if you set the print quality as Low. But
these PDFs won't print on to paper very well.

LXFS07.scribus 57

PDF output can contain interactive elements, such as
links and buttons. You can insert PDF buttons with
the PDF tool on the toolbar, second from the right.
Other elements can be tagged as bookmarks for
navigating the PDF files.
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PDF Exporting from Scribus
Screen Display and On-line PDF Forms

Choose these settings when downloading speed or small size is
importart.
Recomment ded Settings and Hints:
 Down-sample allImages to 72-96dpl.
Do not embed fonts. To ensure a reasonably close layout, choose
"Base 14 fonts" fonts which are typically included with al versions.

of and 2
“This would include your basic variations of Courier, Helvetica, Times
New Roman, Symbol and Zap Dingbat. which are all similar on most|
PC platforms.

 Choose the lowest qualy setting for compression which has
acceptable on-screen viewing resul.

. for Helvetica, as

often have this as an Included font

. PDFs into

PDF and Javascript
PDF presentations

print

Color Management

TP ToolBox

5 ino v 5
them to PNG with GSview, then place in your Scribus document.

There is a lot of useful information included in the
Scribus help files. Choose Help > Scribus Manual for
more details on options in the software and further
reading. Good luck! ®
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